- •13 Прокладка і заміна кабелю. Загальні рекомендації.
- •14. Поняття скс. Основні переваги скс.
- •15.Розподільні пункти скс - вузли локальної мережі. Варіанти установки розеток.
- •16. Підсистеми скс.
- •17.Загальні функції апаратних та кросових. План розміщення.
- •18. Принципи адміністрування скс.
- •19. Варіанти побудови горизонтальної підсистеми скс.
- •20. Кабельні траси підсистем зовнішніх, внутрішніх та горизонтальних магістралей.
- •21. Способи підключення мережевого обладнання до кабельної системі.
- •22. Етапи маркування. Компоненти, що маркуються.
- •23. Загальні механізми призначення адрес dhcp.
- •24. Етапи отримання dhcp-клієнтом конфігураційних параметрів від dhcp-серверу. Обнаружение dhcp
- •Предложение dhcp
- •27. Розподілення доменів за зонами в системі dns.
- •28. Рекурсивные и нерекурсивные сервера
- •29. «Пересильщіки» запитів та прискорювачі імен
- •30. Три сценарії пошуку ip-адреси в базі dns
- •31 Dns. Записи загальних типів. Приклади.
- •32. IPv6. Загальні характеристики.
- •33. IPv6. Система адресації
- •34. IPv6. Структура глобальної агрегіруемої адреси та її загальні поля.
- •35. IPv6. Структура пакету.
- •36. Віртуальні локальні мережі. Загальні характеристики.
- •37. Керування vlan.
- •38. Загальні схеми об’єднання vlan.
- •39. Транкові з’єднання.
- •41. Принципи роботи vpn.
- •42. Оверлейна модель організації vpn. Загальні характеристики.
- •43. Однорангова модель організації vpn. Загальні характеристики.
- •44. Класифікація vpn.
- •45. Варіанти побудови однорангових vpn.
- •46. Загальні характеристики сe-, p- та pe-маршрутизаторів. Приклад використання.
- •47. Транспортні послуги. Vpn. Загальні характеристики.
- •47. Транспортні послуги. Vpn. Загальні характеристики.
- •2) Доступ «по вызову» (Dial-up Access, Dial-up)
- •4)Доступ через другие сети
- •49. Транспортні послуги. Виділені канали. Загальні характеристики.
- •Аналоговые выделенные линии Типы аналоговых выделенных линий
- •50. Транспортні послуги. Традиційна телефонія. Загальні характеристики.
- •53. Технологія Frame Relay.
- •Физический уровень Frame Relay
- •Канальный уровень Frame Relay
- •54. Загальна схема просування кадрів по віртуальним каналам Frame Relay.
- •55. Технологія атм. Загальні характеристики.
- •Работа сети атм
- •56. Технологія атм. Характеристики трафіку.
- •57. Технологія атм. Категорії послуг.
- •58. Чиста ip-мережа. Загальні характеристики.
- •Общая структура глобальной сети ip
- •Четырехуровневая структура современной глобальной сети
- •Структура "чистой" сети ip
- •70. Технологія mpls. Робота протоколу ldp.
- •71. VoIp. Загальні характеристики.
- •72. VoIp. Причини використання.
- •73. VoIp. Двоплоскістна архітектура.
- •74. VoIp. Протокол rtp.
- •75. VoIp. Стандарт h.323. Загальні елементи.
- •76. VoIp. Загальні характеристики ras.
- •77. VoIp. Загальні характеристики h.225.
- •78. VoIp. Загальні характеристики h.245.
- •79. VoIp. Загальні характеристики sip.
79. VoIp. Загальні характеристики sip.
Протокол инициирования сеансов - Session Initiation Protocol (SIP)- является протоколом прикладного уровня и предназначается для организации, модификации и завершения сеансов связи: мультимедийных конференций, телефонных соединений и распределения мультимедийной информации, в основу которого заложены следующие принципы.
Персональная мобильность пользователей. Пользователи могут перемещаться без ограничений в пределах сети, поэтому услуги связи должны предоставляться им в любом месте этой сети. Пользователю присваивается уникальный идентификатор, а сеть предоставляет ему услуги связи вне зависимости от того, где он находится.
Для этого пользователь с помощью специального сообщения - REGISTER - информирует о своих перемещениях сервер определения местоположения.
Масштабируемость сети характеризуется, в первую очередь, возможностью увеличения количества элементов сети при ее расширении. Серверная структура сети, построенной на базе протокола SIP, в полной мере отвечает этому требованию.
Расширяемость протокола характеризуется возможностью дополнения протокола новыми функциями при введении новых услуг и его адаптации к работе с различными приложениями.
Интеграция в стек существующих протоколов Интернет. Протокол SIP является частью глобальной архитектуры мультимедиа, разработанной комитетом Internet Engineering Task Force (IETF).
Взаимодействие с другими протоколами сигнализации. Протокол SIP может быть использован совместно с протоколом Н.323. Возможно также взаимодействие протокола SIP с системами сигнализации ТфОП - DSS1 и ОКС7.
Одной из важнейших особенностей протокола SIP является его независимость от транспортных технологий. В качестве транспорта могут использоваться протоколы Х.25, Frame Relay, AAL5, IPX и др. Структура сообщений SIP не зависит от выбранной транспортной технологии. Но в то же время предпочтение отдается технологии маршрутизации пакетов IP и протоколу UDP.
Здесь же следует отметить, что сигнальные сообщения могут переноситься не только протоколом транспортного уровня UDP, но и протоколом ТСР. По сети с маршрутизацией пакетов IP может передаваться пользовательская информация практически любого вида: речь, видео и данные, а также любая их комбинация, называемая мультимедийной информацией.
80. VoIP. Загальні елементи SIP-мережі та їх характеристики.
Сеть SIP содержит следующие основные элементы.
Агент пользователя (User Agent или SIP client) является приложением терминального оборудования и включает в себя две составляющие: клиент агента пользователя (User Agent Client - UAC) и сервер агента пользователя (User Agent Server - UAS), иначе называемые клиент и сервер. Клиент UAC инициирует SIP-запросы, т.е. выступает в качестве вызывающей стороны. Сервер UAS принимает запросы и отвечает на них, т.е. выступает в качестве вызываемой стороны.
Запросы могут передаваться не прямо адресату, а на некоторый промежуточный узел. Такие узлы бывают двух основных типов: прокси-сервер и сервер переадресации
Прокси-сервер (proxy server) принимает запросы, обрабатывает их и отправляет дальше на следующий сервер, который может быть как другим прокси-сервером, так и последним UAS. Таким образом, прокси-сервер принимает и отправляет запросы и клиента, и сервера. Приняв запрос
от UAC, прокси-сервер действует от имени этого UAC.
Существует два вида прокси-серверов: с сохранением состояний (stateful) и без сохранения состояний (stateless). Сервер первого типа хранит в памяти входящий запрос, который явился причиной генерации одного или нескольких исходящих запросов. Эти исходящие запросы сервер также запоминает. Все запросы хранятся в памяти сервера только до окончания транзакции, т.е. до получения ответов на за просы. Сервер без сохранения состояний просто ретранслирует запросы и ответы, которые получает. Он работает быстрее, чем сервер 1-го типа, так как ресурс процессора не тратится на запоминание состояний, вследствие чего сервер этого типа может обслужить большее количество пользователей.
Протокол инициирования сеансов связи ( SIP ) |
Прикладной уровень |
Протоколы TCP и UDP |
Транспортный уровень |
Протоколы IPv4 и IPv6 |
Сетевой уровень |
PPP, AAL5. ATM, Ethernet, V.34. |
Уровень звена данных |
UTP5, ВОЛС и др. |
Физический уровень |
Рис. 5.1. Место протокола SIP в стеке протоколов TCP/IP
Прокси-сервер может модифицировать запросы, которые он переправляет дальше. Проще говоря, пользователь отсылает требование установить соединение на прокси-сервер, а тот сам “заботится” о том, чтобы оно было установлено. Прокси-сервер может размножать запрос и передавать его по разным направлениям, чтобы запрос достиг нескольких мест, в надежде на то, что нужный пользователь окажется в одном из них.
Сервер переадресации (redirect server) передает клиенту в ответе на запрос адрес следующего сервера или клиента, с которым первый клиент связывается затем непосредственно. Он не может инициировать собственные запросы. Адрес сообщается первому клиенту в поле Contactсообщений SIP. Таким образом, этот сервер просто выполняет функции поиска текущего адреса пользователя.
Пользователь может перемещаться от одной оконечной системы к другой, так что нужен какой-то метод определения его местоположения (рис. 5.2). Для этого в SIP используется сервер местоположения (location server) - это база адресов, доступ к которой имеют SIP-серверы, пользующиеся ее услугами для получения информации о возможном местоположении вызываемого пользователя. Принципы работы сервера местоположения не регламентированы документом RFC 2543, но там имеются примеры протоколов, которые могут использоваться для этогоLDAP (RFC 1777), rwnois (RFC 2167) и др. Упрощенно базу данных можно представить как совокупность адресных записей, в которых напротив “публикуемого” адреса пользователя его стоит текущий адрес. Приняв запрос, сервер SIP обращается к серверу местоположения, чтобы узнать адрес, по которому можно найти пользователя. В ответ тот сообщает либо список возможных адресов, либо информирует о невозможности найти их. С другой стороны, пользователь информирует SIP-сервер о своем местоположении сообщением REGISTER. Сервер местоположения может располагаться как совместно с SIP-сервером, где могут присутствовать некоторые элементы базы адресов, так и отдельно от него.
