Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
Vidpovidi__Morozov (1).docx
Скачиваний:
1
Добавлен:
01.07.2025
Размер:
108 Кб
Скачать
☆

Додаткові функції

Додатковими функціями багатьох веб-серверів є:

  • Ведення журналу серверу про звернення користувачів до ресурсів

  • Автентифікація користувачів

  • Підтримка сторінок, що динамічно генеруються

  • Підтримка HTTPS для захищених з'єднань з клієнтами

9. Протокол mime

Ко́мплексні розши́рення для інтерне́т-по́шти (англ. Multipurpose Internet Mail Extensions (MIME)) — Інтернет-стандарт, який розширює формат електронної пошти, додаючи підтримку відмінних від ASCIIкодуваннь, не текстові долучення, багаточастинні повідомлення та заголовки у не ASCII кодуванні. Фактично уся написана людиною е-пошта передається через SMTP у форматі MIME. Електронна пошта так тісно пов'язана з SMTP і стандартом MIME, що її іноді називають SMTP/MIME.

МІМЕ — це також фундаментальний компонент протоколів комунікації, наприклад HTTP, який вимагає, щоб дані передавалися в контексті подібних до електронної пошти повідомлень, хоча вони, можливо, не є електронною поштою.

Специфікація стандарту MIME описана у п'яти RFC документах, починаючи з RFC 2045, RFC 2046 та RFC 2047.

10. Веб сервер apache

Apache HTTP-сервер — відкритий веб-сервер Інтернет для UNIX-подібних, Microsoft Windows, Novell NetWare та інших операційних систем.

Apache розроблюється та підтримується спільнотою розробників відкритого програмного забезпечення під керівництвом Apache Software Foundation.

В 1996 році Apache обійшов NCSA HTTPd із того часу є найбільш популярним веб-сервером у світі. Станом на червень 2013 року Apache встановлений на 53.34% (358 974 045 серверів) для порівняння на другому місці Microsoft IIS їхня частка 17.22% (115 920 681 серверів)[

Можливості

Web-сервер Apache є самостійним, некомерційним, вільно розповсюджуваним продуктом. Продукт підтримує безліч можливостей, багато з яких реалізовані як скомпільовані модулі, які розширюють основні функціональні можливості. Вони різняться від серверної підтримки мов програмування до схем аутентифікації. Існують інтерфейси для підтримки мов програмування Perl, Python, Tcl і PHP.

Популярні методи стискування на Apache включають зовнішній модуль mod_gzip, створений для зменшення розміру веб-сторінок, переданих по HTTP.

Функції віртуального хостингу дозволяють одній інсталяції Apache обслуговувати різні веб-сайти. Наприклад, одна машина, з однією інсталяцією Apache може одночасно містити www.example.com, www.test.com, test47.test-server.test.com і так далі.

Використання[ред. • ред. Код]

Apache передусім використовується для передачі через HTTP статичних та динамічних веб-сторінок у всесвітній павутині. Багато веб-застосунків спроектовано, зважаючи на середовище і можливості, які надає цей веб-сервер.

Продукт може працювати в якості кешувального проксі-сервера, що дозволяє істотно підвищити продуктивність роботи користувачів локальної мережі при роботі з документами, розташованими в Інтернет. Можна задавати такі параметри і налаштування проксі-сервера:

  • типи файлів, які необхідно кешувати або навпаки, не включати в кеш;

  • максимальний обсяг дискового простору, відведений під кеш;

  • періодичний перегляд і індексування бази даних кеша з метою вивільнення дискового простору шляхом видалення застарілих об'єктів.

Apache зіграв ключову роль у початковому зростанні всесвітньої павутини, і продовжує бути найпопулярнішим у світі веб-сервером, де-факто платформою, на яку орієнтуються інші веб-сервери.

Відповідно до статистики[2] Netcaft за червень 2008 року, Apache є найпоширенішим серверним програмним забезпеченням в Мережі: на цей веб-сервер припадала частка близько 49 % відповідного сегменту ринку (майже 85 мільйонів сайтів). Друге місце за популярністю займають програмні платформи Microsoft — 35,4 % (61 мільйон сайтів).

Соседние файлы в предмете [НЕСОРТИРОВАННОЕ]