Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
Лекция06.doc
Скачиваний:
2
Добавлен:
01.07.2025
Размер:
507 Кб
Скачать
☆

6.2. Протоколы сетевого и транспортного уровней ip, tcp, udp, ipx

Протокол IP

Протокол IP (Internet Protocol) является наиболее эффективным на сегодняшний день протоколом образования больших интерсетей. Особенно он эффективен при построении сетей на основе медленных глобальных связей, так как он изначально разрабатывался для работы в таких условиях. Многолетняя проверка и усовершенствования этого протокола в сети Internet гарантируют его высокую степень отлаженности.

Основные характерные черты протокола IP:

•Стандарты протокола IP принимаются на основании открытого обсуждения сообществом Internet так называемых "Запросов для комментария" - Request For Comment (RFC). Каждый стандарт имеет порядковый номер, например, RFC-791 является общим описанием протокола IP, а RFC-1624 описывает порядок вычисления контрольной суммы IP-пакета.

•Протокол IP является протоколом дейтаграммного типа.

•Гибкая система адресации. Как адрес сети, так и адрес узла задаются администратором для каждого компьютера как параметры при конфигурировании стека TCP/IP в операционной системе, независимо от МАС-адреса сетевого

адаптера. Преимущества - независимость адреса узла от адреса используемого в нем оборудования. Недостаток - трудоемкость ручного конфигурирования адресов в больших сетях. Для IP-сетей разработан протокол DHCP, позволяющий автоматизировать процесс раздачи IP-адресов узлам сети с одного сервера. Существует 5 классов IP-адресов, отличающихся границей между номером сети и номером узла в 4-х байтовом общем адресном поле. Классы различаются по значению нескольких старших битов первого байта адреса. Небольшая длина IP-адреса определяет небольшую длину IP-заголовка - 20 байтов, что при максимальной длине IP-пакета в 64 Кбайта дает небольшие накладные расходы на служебную информацию. Примеры IP-адресов: 192.33.81.15,100.15.23.34.

• Отсутствие широковещательного адреса для сети (широковещательность поддерживается только для узлов одной определенной сети) позволяет избежать

широковещательных штормов без участия администратора.

• Наличие класса групповых адресов - multicast - с помощью которых один пакет доставляется всем узлам - членам группы с заданным адресом.

• Возможность гибкого задания границы между номером сети и номером узла при использовании в маршрутизаторах и компьютерах масок. Например, адрес 101.23.45.16 с маской 255.255,255 соответствуют сети 101.23.45 и номеру узла 16. Маски помогают делить одну сеть на подсети без приобретения у поставщика услуг Internet новых IP-адресов сетей.

• Использование иерархических символьных имен компьютеров, например www. ibm. com, понятных пользователю. Каждая часть имени соответствует одному административному домену, находящемуся под управления какого-либо административного органа сети Internet или ее поставщика услуг.

• Использование иерархической службы имен DNS для предоставления компьютерам справок о соответствии символьных имен IP-адресам, используемым в IP-пакетах. Служба DNS не использует широковещательные рассылки при своей работе, а основана на распределенной иерархической базе данных с прозрачным доступом. Каждый административный домен имеет свой DNS-сервер или DNS-серверы, в которых хранится их часть базы данных имен, При разрешении имени серверы DNS взаимодействуют прозрачным для клиента образом. Пока служба DNS не взаимодействует с сервисом назначения адресов DHCP, хотя разработка нового протокола Dynamic DNS, который будет взаимодействовать с DNS, уже идет.

• Инкапсуляция IP-пакетов в кадры локальных или глобальных сетей определена соответствующими стандартами Internet, например, стандарт RFC-1226 определяет

инкапсуляцию IP в пакеты сетей X.25, стандарт RFC-1490 - инкапсуляцию в кадры frame relay, а стандарт RFC-894 - инкапсуляцию в кадры Ethernet.

• Соответствие IP-адресов МАС-адресам сетевых адаптеров устанавливается протоколами семейства ARP (Address Resolution Protocol), которые определяются отдельно для каждого вида сетей, которые переносят IP-пакеты.

• Возможность фрагментации пакетов верхних уровней (то есть разбиения их на части без дублирования заголовков) обеспечивается за счет наличия специальных полей в заголовке IP-пакета, позволяющих разбивать пакеты на части при переходе в сеть с меньшим максимально допустимым размером кадра, а затем собирать из отдельных частей исходный пакет протокола верхнего уровня, например, TCP.

• Возможность указания класса обслуживания IP-пакетов маршрутизаторами: с низкой задержкой, с максимальной производительностью и с наивысшей надежностью.

• Достаточно большое максимальное значение поля "Время жизни" IP-пакета, определяемое его форматом в один байт. Это позволяет пакету пересечь

до 254 маршрутизаторов и не быть удаленным из сети, что важно для сверхбольших сетей. Реальное используемое начальное значение этого поля зависит от настройки конкретной операционной системы в компьютере-источнике.

Протоколы TCP и UDP

Протоколы транспортного уровня не используются для маршрутизации пакетов, а служат для повышения надежности доставки данных протоколов прикладного уровня, а также мультиплексируют протокол сетевого уровня с различными протоколами прикладного уровня.

Протокол UDP (User Datagram Protocol) так же, как IP является дейтаграммным протоколом, поэтому надежности при передаче данных прикладных протоколов он не прибавляет, а является просто мультиплексором между протоколом IP и такими протоколами как TFTP, ВООТР и др. Мультиплексирование происходит на основании таких полей пакета UDP, как порт источника данных и порт назначения данных. Номер порта соответствует определенному протоколу прикладного уровня или же определенной функции какого-либо протокола. Например, порт 67 закреплен за сервером протокола ВООТР, а порт 68 - за клиентом этого протокола.

Протокол TCP также выполняет роль мультиплексора между протоколом IP и протоколами прикладного уровня, за которыми также закреплены соответствующие значения портов пакета TCP. Однако TCP выполняет и вторую функцию протоколов транспортного уровня - он обеспечивает надежную передачу пакетов за счет установления соединения и нумерации пакетов по алгоритму скользящего окна. Номером соединения является пара конечных точек соединения, где конечная точка сама образуется из пары (номер узла, номер порта) приложения.

По сравнению с образованием виртуального канала, когда каждому соединению присваивается номер виртуального канала, который затем указывается в пакетах транспортного уровня для маршрутизации пакетов, использование обозначения соединений парой конечных точек позволяет стеку TCP/IP маршрутизировать каждый

IP-пакет отдельно, что повышает производительность и отказоустойчивость сети, и в то же время нумеровать TCP пакеты внутри, каждого соединения, обеспечивая их надежную доставку.

Маршрутизаторы для выполнения своих функций обычно работают только с заголовками пакетов сетевого уровня, то есть с IP-заголовками, но при выполнении функций фильтрации трафика могут просматривать и заголовки пакетов транспортного уровня, что позволяет использовать номер порта как условие фильтрации и в гораздо более удобной форме, чем при использовании мостов, запрещать использование того или иного сервиса (идентифицируемого номером порта) всем пользователям или определенному пользователю (на основании его IP-адреса).

Протокол IPX

Протокол IPX, так же, как и IP, является протоколом дейтаграммного типа. Однако он разрабатывался для применения в локальных сетях и поэтому некоторые возможности, имеющиеся в протоколе IP, не поддерживает.

Адрес получателя в протоколе IPX - это межсетевой адрес, который содержит три поля, а именно: номер сети (32 бита), номер узла (48 битов) и номер сокета (16 битов).

• Номер сети идентифицирует каждый сегмент в общем случае многосерверной сети; эти номера назначают администраторы сети, когда инициализируют файл-серверы.

• Адрес узла является МАС-адресом узла, то есть в данном случае на сетевом уровне используется локальный адрес узла.

• Сокет (socket - гнездо или разъем) определяет собственно прикладную программу-получатель, работающую на станции назначения. Прикладные программы открывают и закрывают сокеты во многом так же, как они открывают и закрывают файлы.

Наличие поля сокета (аналога порта протоколов UDP и TCP) в пакете IPX говорит о том, что этот протокол поддерживает не только маршрутизацию в составных сетях, но и выполняет роль мультиплексора по отношению к протоколам прикладного уровня. В стеке Novell это свойство явным образом используется при работе файлового сервиса -протокол NCP непосредственно работает с протоколом IPX, минуя транспортный протокол SPX, что уменьшает накладные расходы, связанные с многоуровневостью.

Протокол IPX является одним из наиболее легко настраиваемых протоколов сетевого уровня. Номер сети задается администратором только на серверах, а номер узла вообще вручную не задается, так как он автоматически считывается из сетевого адаптера компьютера. Административные издержки при конфигурировании сети сводятся из-за этого к минимуму. При этом отпадает необходимость в использовании протокола типа ARP. выясняющего соответствие между сетевыми адресами узлов и их МАС-адресами. Однако при смене сетевого адаптера нужно скорректировать адрес узла, если для его выяснения используется справочная служба типа NDS.

В версии стека IPX для локальных сетей соответствие символьных имен серверов их сетевым адресам устанавливалось с помощью широковещательного протокола Service Advertising Protocol (SAP), поэтому проблем при смене у сервера сетевого адаптера не возникало, Однако широковещательные рассылки - не очень хороший способ взаимодействия в глобальной сети, недаром в стеке TCP/IP они для выяснения соответствия символьных имен IP-адресам не используются. Модернизируя свой стек для применения в глобальных сетях, компания Novell использует теперь справочную службу NDS для нахождения разнообразной информации о имеющихся в сети ресурсах и сервисах, в том числе и о соответствии имени сервера его сетевому адресу. Так как служба NDS поддерживается только серверами с версией NetWare 4 и выше, то для работы с версиями NetWare 3.х маршрутизаторы распознают пакеты SAP по номеру их определенного сокета и передают их на все порты, имитируя широковещательные рассылки локальной сети, что, конечно, съедает значительную часть пропускной способности медленных глобальных линий.

Еще несколько особенностей протокола IPX ограничивают его применение в глобальных сетях.

• Отсутствие полей, поддерживающих фрагментацию пакетов верхнего уровня, требует задания такого размера пакета IPX, который бы гарантированно уложился бы во все кадры локальных и глобальных сетей на всем пути следования по составной сети. Возможно поэтому длина поля данных пакета IPX ограничена 546 байтами. При заголовке в 30 байтов (его большая длина связана с большим размером адреса, включающего 6-байтовый МАС-адрес узла) накладные расходы на служебную информацию оказываются достаточно большими.

• Время жизни пакета ограничено числом 15, что может оказаться недостаточным для большой сети.

• Отсутствие поля качества сервиса не позволяет маршрутизаторам автоматически подстраиваться к требованиям приложения по передаче трафика.

Следующее ограничение относится к протоколу NCP, так как именно он обеспечивает надежную передачу данных между клиентом и сервером, являясь протоколом с установлением соединения. Этот протокол не использует метод скользящего окна при передаче своих пакетов, а просто не отправляет очередной пакет до прихода подтверждения о приеме предыдущего пакета. Такой метод нормально работает в быстродействующих локальных сетях, но очень медленно передает данные на медленных глобальных связях.

В последних версиях NetWare компания Novell произвела много необходимых модификаций в своем стеке для его успешной работы в глобальных сетях:

• Имеется NLM для реализации метода скользящего окна - так называемый Burst Mode Protocol NLM.

• Имеется NLM для поддержки длинных IPX-пакетов - Large Internet Packet NLM.

• Использование службы NDS позволяет отказаться от широковещательного протокола SAP.

Кроме того, постоянное повышение скорости глобальных сервисов уменьшает недостатки оригинальных протоколов стека IPX, что позволяет некоторым обозревателям говорить об успешной работе операционной системы NetWare в глобальных сетях и без указанных нововведений.