Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
Vstup_TCP.docx
Скачиваний:
0
Добавлен:
01.07.2025
Размер:
277 Кб
Скачать
☆

Використання масок в ір-адресації

Традиційна схема поділу ІР-адреси на номер мережі і номер вузла базується на понятті класу, який визначається значеннями кількох перших біт адреси. Саме тому, що перший байт адреси 185.23.44.206 попадає у діапазон 128-191, ми можемо сказати, що ця адреса відноситься до класу В, а значить, номером мережі є перші два байти, доповнені двома нульовими байтами - 185.23.0.0, а номером вузла - 0.0.44.206.

Для гнучкого встановлення межі між номером мережі і номером вузла використовують маску, Маска - це число, яке використовується у парі з ІР-адресою; двійковий запис маски містить одиниці у тих розрядах, які повинні у ІР-адресі інтерпретуватися як номер мережі. Поскільки номер мережі є цілою частиною адреси, одиниці у масці також повинні бути безперервною послідовністю. Для стандартних класів мереж маски мають такі значення:

  • клас А - 11111111.00000000.00000000.00000000 (255.0.0.0);

  • клас В - 11111111.11111111.00000000.00000000 (255.255.0.0);

  • клас С - 11111111.11111111.11111111.00000000 (255.255.255.0).

Для запису масок використовують і інші формати, наприклад, зручно інтерпретувати значення маски, записаної у шістнадцятьковому коді: FF.FF.00.00 - маска для адрес класу В. Часто зустрічається і таке позначення 185.23.44.206/16 - цей запис означає, що маска для цієї адреси містить 16 одиниць або що у вказаній адресі під номер адреси мережі відведено 16 двійкових розрядів.

Адресація і технологія cidr

Технологія безкласової междоменной маршрутизації (Classless Inter-Domain Routing, CIDR), яка описана в документах RFC 1517, RFC 1518, RFC 1519, RFC 1520 і яка вперше була офіційно оголошена в 1993 році, дозволяє центрам розподілу адрес уникнути видачі абонентам зайвих адрес.

Розподіл IP-адреси на номери мережі і вузла в технології CIDR відбувається на основі маски змінної довжини, що призначається постачальником послуг. Необхідною умовою застосування CIDR є наявність у організації, що розпоряджається адресами, безперервних діапазонів адрес. Такі адреси мають однаковий префікс, тобто однакову цифрову послідовність у кількох старших розрядах. Нехай в розпорядженні деякого постачальника послуг є безперервний простір IP-адрес в кількості 2n. Звідси випливає, що префікс має довжину (32 - n) розрядів. Решта n розрядів грає роль лічильника послідовних номерів.

Коли споживач звертається до постачальника послуг з проханням про виділення йому деякого числа адрес, то в наявному пулі адрес «вирізається» неперервна область S1,S2 або S3, в залежності від необхідної кількості адрес. При цьому повинні бути виконані наступні умови:

  • кількість адрес у виділеної області має дорівнювати степеню двійки;

  • початкова межа пулу адрес, що виділяється повинна бути кратна необхідній кількості вузлів.

Очевидно, що префікс кожної з показаних на малюнку областей має власну довжину - чим менше кількість адрес в даній області, тим довший її префікс.

Завдяки CIDR постачальник послуг одержує можливість «нарізати» блоки з виділеного йому адресного простору відповідно до вимог кожного клієнта.

Соседние файлы в предмете [НЕСОРТИРОВАННОЕ]