Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
Лекции_20115_01.docx
Скачиваний:
2
Добавлен:
01.07.2025
Размер:
2 Мб
Скачать
☆

Глоссарий

A5

A trade-secret cryptographic algorithm used in European cellular telephones.

Access control

A method of restricting access to resources, allowing only privileged entitiesaccess.

Additional recipient request key

A special key whose presence indicates that all messages encrypted to its associatedbase key should also be automatically encrypted to it. Sometimes referred to by itsmarketing term, additional decryption key.

AES (Advanced Encryption Standard)

The US government standard for the algorithm to replace the older DES. Thiswas an open competition, and the selected algorithm was Rijndael (q.v.). The AEShas 16-byte blocks and can operate with 128, 192, or 256-bit keys.

AKEP (Authentication Key Exchange Protocol)

Key transport based on symmetric encryption allowing two parties to exchange ashared secret key, secure against passive adversaries.

Algorithm (encryption)

A set of mathematical rules (logic) used in the processes of encryption and decryption.

Algorithm (hash)

A set of mathematical rules (logic) used in the processes of message digest creationand key/signature generation.

Anonymity

Of unknown or undeclared origin or authorship, concealing an entity’s identification.

ANSI (American National Standards Institute)

Develops standards through various Accredited Standards Committees (ASC).The X9 committee focuses on security standards for the financial services industry.

API (Application Programming Interface)

Provides the means to take advantage of software features, allowing dissimilar softwareproducts to interact upon one another.

ASN.1 (Abstract Syntax Notation One)

ISO/IEC standard for encoding rules used in ANSI X.509 certificates, two typesexist - DER (Distinguished Encoding Rules) and BER (Basic Encoding Rules).

Asymmetric keys

A separate but integrated user key-pair, comprised of one public key and one privatekey. Each key is one way, meaning that a key used to encrypt information cannot be used to decrypt the same data.

Authentication

The process of demonstrating an entity is what it claims to be.

Authorization certificate

An electronic document to prove one’s access or privilege rights, also to prove oneis who they say they are.

Authorization

The process of determining what an entity is allowed to do.

Blind signature

Ability to sign documents without knowledge of content, similar to a notary public.

Block cipher

A symmetric cipher operating on blocks of plain text and cipher text, usually 64 or128 bits.

Blowfish

A 64-bit block symmetric cipher consisting of key expansion and data encryption.A fast, simple, and compact algorithm in the public domain written by BruceSchneier.

CA (Certificate Authority)

A trusted third party (TTP) who creates certificates that consist of assertions onvarious attributes and binds them to an entity and/or to their public key.

CAPI (Crypto API)

Microsoft’s crypto API for Windows-based operating systems and applications.

Capstone

An NSA-developed cryptographic chip that implements a US government KeyEscrow capability.

CBC (Cipher Block Chaining)

The process of having plain text XORed with the previous cipher text blockbefore it is encrypted, thus adding a feedback mechanism to a block cipher.

CERT (Computer Emergency Response Team)

Security clearinghouse that promotes security awareness. CERT provides 24-hourtechnical assistance for computer and network security incidents. CERT is locatedat the Software Engineering Institute at Carnegie Mellon University in Pittsburgh,PA.

Certificate (digital certificate)

An electronic document consisting of a public key, information about the key’sholder, and a digital signature binding the key and information together. It is adocument that states the signer’s belief that the information and the key belongtogether. Binding names, email addresses, etc. to a key creates an Identity Certificate.

CFM (Cipher Feedback Mode)

A block cipher that has been implemented as a self-synchronizing stream cipher.

CDSA (Common Data Security Architecture)

Intel Architecture Labs (IAL) developed this framework to address the data securityproblems inherent to Internet and Intranet for use in Intel and others’ Internetproducts.

Certification

Endorsement of information by a trusted entity.

Ciphertext

The output of a cipher. The cipher starts with plaintext (q.v), and uses a key (q.v)to create ciphertext.

Confidentiality

The act of keeping something private and secret from all but those who are authorizedto see it.

Cookie

Persistent Client State HTTP Cookie—a file or token of sorts, that is passed fromthe web server to the web client (your browser) that is used to identify you andcould record personal information such as ID and password, mailing address,credit card number, and other information.

Credentials

Something that provides a basis for credit or confidence.

CRL (Certificate Revocation List)

An online, up-to-date list of previously issued certificates that are no longer valid.

Cross-certification

Two or more organizations or Certificate Authorities that share some level oftrust.

Cryptanalysis

The reverse of cryptography, cryptanalysis is the art and science of breakingciphers, ciphertexts, or keys.

CRYPTOKI

Also known as PKCS#11, this is a standard API for using cryptographic tokensincluding smart cards and accelerators.

Cryptography

The art and science of creating messages that have some combination of being private,signed, unmodified with non-repudiation.

Cryptosystem

A system comprised of cryptographic algorithms, all possible plain text, ciphertext, and keys.

Data integrity

A method of ensuring information has not been altered by unauthorized orunknown means.

Decryption

The process of turning cipher text back into plain text.

DES (Data Encryption Standard)

A 64-bit block cipher, symmetric algorithm also known as Data Encryption Algorithm

(DEA) by ANSI and DEA-1 by ISO. Widely used for over 20 years,adopted in 1976 as FIPS 46.

Dictionary attack

A calculated brute force attack to reveal a password by trying obvious and logicalcombinations of words.

Diffie-Hellman

The first public key algorithm, invented in 1976, using discrete logarithms in afinite field.

Digital cash

Electronic money that is stored and transferred through a variety of complex protocols.

Direct trust

An establishment of peer-to-peer confidence.

Discrete logarithm

The underlying mathematical problem used in/by asymmetric algorithms, likeDiffie-Hellman and Elliptic Curve. It is the inverse problem of modular exponentiation,which is a one-way function.

DMS (Defense Messaging System)

Standards designed by the U.S. Department of Defense to provide a secure andreliable enterprise-wide messaging infrastructure for government and militaryagencies.

DNSSEC (Domain Name System Security Working Group)

A proposed IETF draft that will specify enhancements to the DNS protocol toprotect the DNS against unauthorized modification of data and against masqueradingof data origin. It will add data integrity and authentication capabilities tothe DNS via digital signatures.

DSA (Digital Signature Algorithm)

The signing-only public key algorithm used in the Digital Signature Standard.DSA is a variant of the Elgamal (q.v.) algorithm.

Digital signature

An electronic identification of a person or thing created by using a public keyalgorithm. Intended to verify to a recipient the integrity of data and identity of thesender of the data.

DSS (Digital Signature Standard)

A U.S. Federal Information Processing Standard (FIPS) for digital signatures,using DSA and SHA-1.

ECC (Elliptic Curve Cryptosystem)

Variants of the Diffie-Hellman family of public key algorithms, these operate onother sets than the integers and give smaller keys faster execution.

EDI (Electronic Data Interchange)

The direct, standardized computer-to-computer exchange of business documents(purchase orders, invoices, payments, inventory analyses, and others) betweenyour organization and your suppliers and customers.

Elgamal

A variant of Diffie-Hellman that permits public key encryption similar to RSAencryption. The Diffie-Hellman keys in PGP are Elgamal keys.

Elgamal scheme

Used for both digital signatures and encryption based on discrete logarithms in afinite field; can be used with the DSA function.

Encryption

The process of disguising a message in such a way as to hide its substance.

Entropy

A mathematical measurement of the amount of uncertainty or randomness.

FEAL

A block cipher using 64-bit block and 64-bit key, design by A. Shimizu and S.Miyaguchi at NTT Japan.

Filter

A function, set of functions, or combination of functions that applies some numberof transforms to its input set, yielding an output set containing only thosemembers of the input set that satisfy the transform criteria. The selected membersmay or may not be further transformed in the resultant output set. An examplewould be a search function that accepts multiple strings having a boolean relationship(( like a or like b ) but not containing c), and optionally forces the caseof the found strings in the resultant output.

Fingerprint

A unique identifier for a key that is obtained by hashing specific portions of thekey data.

FIPS (Federal Information Processing Standard)

A U.S. government standard published by NIST.

Firewall

A combination of hardware and software that protects the perimeter of the public/private network against certain attacks to ensure some degree of security.

GAK (Government Access to Keys)

A method for the government to escrow individual’s private key.

Gost

A 64-bit symmetric block cipher using a 256-bit key, developed in the formerSoviet Union.

GSS-API (Generic Security Services API)

A high-level security API based upon IETF RFC 1508, which isolates session-orientedapplication code from implementation details.

Hash function

A one-way hash function—a function that produces a message digest that cannotbe reversed to produced the original.

HMAC (Hash-based Message Authentication Code)

A mechanism to use a hash function such as SHA-1 to create a MAC (q.v.) basedon a shared key.

Hierarchical trust

A graded series of entities that distribute trust in an organized fashion, commonlyused in ANSI X.509 issuing certifying authorities. PGP’s meta-introducers are amechanism for using hierarchical trust with PGP certificates.

IDEA (International Data Encryption Standard)

A 64-bit block symmetric cipher using 128-bit keys based on mixing operationsfrom different algebraic groups. Considered one of the strongest algorithms.

IETF (Internet Engineering Task Force)

A large open international community of network designers, operators, vendors,and researchers concerned with the evolution of the Internet architecture and thesmooth operation of the Internet. It is open to any interested individual. See

Identity certificate

A signed statement that binds a key to the name of an individual and has theintended meaning of delegating authority from that named individual to the publickey.

Initialization vector (IV)

A block of arbitrary data that serves as the starting point for a block cipher using achaining feedback mode (see cipher block chaining).

Integrity

Assurance that data is not modified (by unauthorized persons) during storage ortransmittal.

IPsec

A TCP/IP layer encryption scheme under consideration within the IETF.ISO (International Organization for Standardization)Responsible for a wide range of standards, like the OSI model and international

relationship with ANSI on X.509.

ITU-T (International Telecommunication Union-Telecommunication)

Formally the CCITT (Consultative Committee for International Telegraph andTelephone), a worldwide telecommunications technology standards organization.

Kerberos

A server-based authentication system developed at MIT. Microsoft has built avariant of Kerberos into its domain system.

Key

A number used in a cipher to encrypt plaintext into ciphertext.

Key escrow

A key recovery (q.v.) mechanism that works by simply keeping copies of keys.

Key exchange

A scheme for two or more nodes to transfer a secret session key across an unsecuredchannel.

Key length

The number of bits representing the key size; the longer the key, the stronger it is.

Key management

The process and procedure for safely storing and distributing accurate cryptographickeys; the overall process of generating and distributing cryptographic keyto authorized recipients in a secure manner.

Key recovery

A mechanism for retrieving cryptographic keys with the ultimate intent ofdecrypting ciphertext with them.

Key splitting

A process for dividing portions of a single key between multiple parties, none havingthe ability to reconstruct the whole key.

LDAP (Lightweight Directory Access Protocol)

A simple protocol that supports access and search operations on directories containinginformation such as names, phone numbers, and addresses across otherwiseincompatible systems over the Internet.

MAA (Message Authenticator Algorithm)

An ISO standard that produces a 32-bit hash, designed for IBM mainframes.

MAC (Message Authentication Code)

The symmetric-key equivalent of a digital signature. MACs do not hide data, butthey let someone who knows the key know whether it has been modified.

MD2 (Message Digest 2)

128-bit, one-way hash function designed by Ron Rivest, dependent on a randompermutation of bytes.

MD4 (Message Digest 4)

128-bit, one-way hash function designed by Ron Rivest, using a simple set of bitmanipulations on 32-bit operands.

MD5 (Message Digest 5)

Improved, more complex version of MD4, but still a 128-bit, one-way hash function.

Message digest

A number that is derived from a message. Change a single character in the messageand the message will have a different message digest.

MIC (Message Integrity Check)

Originally defined in PEM for authentication using MD2 or MD5. Micalg (messageintegrity calculation) is used in secure MIME implementations.

MIME (Multipurpose Internet Mail Extensions)

A freely available set of specifications that offers a way to interchange text in languageswith different character sets, and multimedia email among many differentcomputer systems that use Internet mail standards.

MMB (Modular Multiplication-based Block)

Based on IDEA, Joan Daemen developed this 128-bit key/128-bit block size symmetricalgorithm, not used because of its susceptibility to linear cryptanalysis.

MOSS (MIME Object Security Service)

Defined in RFC 1848, it facilitates encryption and signature services for MIME,including key management based on asymmetric techniques (not widely used).

MSP (Message Security Protocol)

The military equivalent of PEM, an X.400-compatible application level protocolfor securing e-mail, developed by the NSA in late 1980.

MTI

A one-pass key agreement protocol by Matsumoto, Takashima, and Imai that providesmutual key authentication without key confirmation or entity authentication.

NAT (Network Address Translator)

RFC 1631, a router connecting two networks together; one designated as inside,is addressed with either private or obsolete addresses that need to be convertedinto legal addresses before packets are forwarded onto the other network (designatedas outside).

NIST (National Institute for Standards and Technology)

A division of the U.S. Dept. of Commerce that publishes open, interoperabilitystandards called FIPS.

Non-repudiation

The belief that signature or MAC verifies, that the key owner cannot deny creatingit.

One-time pad

A large non-repeating set of truly random key letters used for encryption, consideredthe only perfect encryption scheme, invented by Major J. Mauborgne and G.Vernam in 1917.

One-way hash

A function of a variable string to create a fixed length value representing the originalpre-image, also called message digest, fingerprint, message integrity check(MIC).

OpenPGP

The IETF standardization of PGP. It consists of two RFCs, RFC 2440 and RFC3156.

Open PGP/MIME

An IETF standard (RFC 3156) that provides privacy and authentication using theMultipurpose Internet Mail Extensions (MIME) security content types describedin RFC1847.

Orange Book

The National Computer Security Center book entitled Department of DefenseTrusted Computer Systems Evaluation Criteria that defines security requirements.

PAP (Password Authentication Protocol)

An authentication protocol that allows PPP peers to authenticate one another,does not prevent unauthorized access but merely identifies the remote end.

Passphrase

An easy-to-remember phrase used for better security than a single password; keycrunching converts it into a random key.

Password

A sequence of characters or a word that a subject submits to a system for purposesof authentication, validation, or verification.

PCT (Private Communication Technology)

A network encryption protocol similar to SSL, created by Microsoft and VISA.The IETF merged PCT with SSL creating TLS.

PEM (Privacy Enhanced Mail)

A protocol to provide secure internet mail, (RFC 1421-1424) including servicesfor encryption, authentication, message integrity, and key management. PEMuses ANSI X.509 certificates.

Perfect forward secrecy

A property of a cryptosystem in which if one message is compromised, no latermessages are compromised.

Permutation – перестановка (p-блоки в алгоритме DES)

Primitive filter

Aa function that applies a single transform to its input set, yielding an output setcontaining only those members of the input set that satisfy the transform criteria.An example would be a search function that accepts only a single string and outputsa list of line numbers where the string was found.

PKCS (Public Key Crypto Standards)

A set of de facto standards for public key cryptography developed in cooperationwith an informal consortium (Apple, DEC, Lotus, Microsoft, MIT, RSA, andSun) that includes algorithm-specific and algorithm-independent implementationstandards. Specifications defining message syntax and other protocols controlledby RSA Data Security Inc.

PKI (Public Key Infrastructure)

A widely available and accessible certificate system for obtaining an entity’s publickey with some degree of certainty that you have the “right” key and that it has notbeen revoked.

Plaintext

The input of a cipher. The cipher starts with plaintext, and uses a key (q.v) to createciphertext.

Pseudo-random number generator

A mathematical process that gives apparently random numbers.

Private key

The privately held “secret” component of an integrated asymmetric key pair, oftenreferred to as the decryption key.

Public key

The publicly available component of an integrated asymmetric key pair oftenreferred to as the encryption key.

random number

An important aspect to many cryptosystems, and a necessary element in generatinga unique key(s) that are unpredictable to an adversary. True random numbersare usually derived from natural sources.

RC2 (Ron’s Cipher 2)

Variable key size, 64-bit block symmetric cipher, a trade secret held by RSA, SDI.

RC4 (Ron’s Cipher 4)

Variable key size stream cipher, once a proprietary algorithm of RSA Security, Inc.

RC5 (Ron’s Cipher 5)

A block cipher with a variety of arguments, block size, key size, and number ofrounds.

RIPE-MD

An algorithm developed for the European Community’s RIPE project, designedto resist known cryptanalysis attacks and produce a 128-bit hash value, a variationof MD4.

REDOC

A U.S.-patented block cipher algorithm developed by M. Wood, using a 160-bitkey and an 80-bit block.

Revocation

Retraction of certification or authorization.

RFC (Request for Comment)

An IETF document, either FYI (For Your Information) RFC sub-series that areoverviews and introductory or STD RFC sub-series that identify specify Internetstandards. Each RFC has an RFC number by which it is indexed and by which itcan be retrieved (www.ietf.org).

Rijndael

A block cipher designed by Joan Daemen and Vincent Rijmen, chosen as the newAdvanced Encryption Standard (AES). It is considered to be both faster andsmaller than its competitors. The key size and block size can be 128-bit, 192-bit,or 256-bit in size and either can be increased by increments of 32 bits.

ROT-13 (Rotation Cipher)

A simple substitution (Caesar) code, rotating each 26 letters 13 places.

RSA

RSA Security, Inc. or referring to the principals Ron Rivest, Adi Shamir, and LenAdleman; or referring to the algorithm they invented. The RSA algorithm is usedin public key cryptography and is based on the fact that it is easy to multiply twolarge prime numbers together, but hard to factor them out of the product.

SAFER (Secure And Fast Encryption Routine)

A non-proprietary block cipher 64-bit key encryption algorithm. It is not patented,is available license free, and was developed by Massey, who also developedIDEA.

Salt

A random string that is concatenated with passwords (or random numbers) beforebeing operated on by a one-way function. This concatenation effectively lengthensand obscures the password, making the cipher text less susceptible to dictionaryattacks.

SDSI (Simple Distributed Security Infrastructure)

A new PKI proposal from Ronald L. Rivest (MIT), and Butler Lampson(Microsoft). It provides a means of defining groups and issuing group-membership,access-control lists, and security policies. SDSI's design emphasizes linkedlocal name spaces rather than a hierarchical global name space.

SEAL (Software-optimized Encryption ALgorithm)

A fast stream cipher for 32-bit machines designed by Rogaway and Coppersmith.

Secret key

Either the “private key” in public key (asymmetric) algorithms or the “sessionkey” in symmetric algorithms.

Secure channel

A means of conveying information from one entity to another such that an adversarydoes not have the ability to reorder, delete, insert, or read (SSL, IPSec, whisperingin someone’s ear).

Self-signed key

A public key that has been signed by the corresponding private key for proof ofownership.

SEPP (Secure Electronic Payment Protocol)

An open specification for secure bankcard transactions over the Internet. Developedby IBM, Netscape, GTE, Cybercash, and MasterCard.

SESAME (Secure European System for Applications in a Multi-vendor Environment)

European research and development project that extended Kerberos by addingauthorization and access services.

Session key

The secret (symmetric) key used to encrypt each set of data on a transaction basis.A different session key is used for each communication session.

SET (Secure Electronic Transaction)

Provides for secure exchange of credit card numbers over the Internet.

SHA-1 (Secure Hash Algorithm)

A 160-bit hash function; part of DSS.

Single sign-on

One log-on provides access to all resources of the network.

SKIP (Simple Key for IP)

Simple key-management for Internet protocols, developed by Sun Microsystems,Inc.

Skipjack

The 80-bit key encryption algorithm contained in NSA’s Clipper chip.

SKMP (Secure key Management Protocol)

An IBM proposed key-recovery architecture that uses a key encapsulation techniqueto provide the key and message recovery to a trusted third-party escrowagent.

S/MIME (Secure Multipurpose Mail Extension)

A proposed standard developed by Deming software and RSA Data Security forencrypting and/or authenticating MIME data. S/MIME defines a format for theMIME data, the algorithms that must be used for interoperability (RSA, RC2,SHA-1), and the additional operational concerns such as ANSI X.509 certificatesand transport over the Internet.

SNAPI (Secure Network API)

A Netscape driven API for security services that provide ways for resources to beprotected against unauthorized users, for communication to be encrypted andauthenticated, and for the integrity of information to be verified.

SPKI (Simple Public Key Infrastructure)

An IETF proposed draft standard (by Ellison, Frantz, and Thomas) public keycertificate format, associated signature and other formats, and key acquisition protocol.Recently merged with Ron Rivest’s SDSI proposal.

SSH (Secure Shell)

An IETF proposed protocol for securing the transport layer by providing encryption,cryptographic host authentication, and integrity protection.

SSH (Site Security Handbook)

The Working Group (WG) of the Internet Engineering Task Force has beenworking since 1994 to produce a pair of documents designed to educate the Internetcommunity in the area of security. The first document is a complete reworkingof RFC 1244, and is targeted at system and network administrators, as well asdecision makers (middle management).

SSL (Secure Socket Layer)

Developed by Netscape to provide security and privacy over the Internet. Supportsserver and client authentication and maintains the security and integrity ofthe transmission channel. Operates at the transport layer and mimics the “socketslibrary,” allowing it to be application independent. Encrypts the entire communicationchannel and does not support digital signatures at the message level. TheIETF merged SSL with PCT creating TLS.

SST (Secure Transaction Technology)

A secure payment protocol developed by Microsoft and Visa as a companion tothe PCT protocol.

Stream cipher

A class of symmetric key encryption where transformation can be changed foreach symbol of plain text being encrypted, useful for equipment with little memoryto buffer data.

STU-III (Secure Telephone Unit)

NSA designed telephone for secure voice and low-speed data communications foruse by the U.S. Dept. of Defense and their contractors.

Substitution cipher

The characters of the plain text are substituted with other characters to form thecipher text.

S/WAN (Secure Wide Area Network)

RSA Data Security, Inc. driven specifications for implementing IPSec to ensureinteroperability among firewall and TCP/IP products. S/WAN's goal is to useIPSec to allow companies to mix-and-match firewall and TCP/IP stack productsto build Internet-based Virtual Private Networks (VPNs).

Symmetric algorithm

Also known as conventional, secret key, and single key algorithms; the encryptionand decryption key are either the same or can be calculated from one another.

TACACS+ (Terminal Access Controller Access Control System)

A protocol that provides remote access authentication, authorization, and relatedaccounting and logging services, used by Cisco Systems.

Timestamping

Recording the time of creation or existence of information.

TLS (Transport Layer Security)

The IETF standardization of SSL, merging in with it PCT. Today, much of whatis colloquially called SSL is actually TLS.TLSP (Transport Layer Security Protocol)ISO 10736, draft international standard.

Transposition cipher

The plain text remains the same but the order of the characters is transposed.

Triple DES

An encryption configuration in which the DES algorithm is used three times withthree different keys.

Trust

A firm belief or confidence in the honesty, integrity, justice, and/or reliability of aperson, company, or other entity.

TTP (Trust Third-Party)

A responsible party in which all participants involved agree upon in advance, toprovide a service or function, such as certification, by binding a public key to anentity, time-stamping, or key-escrow.

Twofish

A new 256-bit block cipher, symmetric algorithm. Twofish was one of five algorithmsthat the U.S. National Institute of Standards and Technology (NIST) consideredfor the Advanced Encryption Standard (AES).

Validation

A means to provide timeliness of authorization to use or manipulate informationor resources.

Verification

To authenticate, confirm, or establish accuracy.

VPN (Virtual Private Network)

Allows private networks to span from the end-user, across a public network (Internet)directly to the home gateway of choice, such as your company’s Intranet.

WAKE (Word Auto Key Encryption)

Produces a stream of 32-bit words, which can be XORed with plain text stream toproduce cipher text, invented by David Wheeler.

Web of Trust

A distributed trust model used by PGP to validate the ownership of a public keywhere the level of trust is cumulative based on the individual’s knowledge of the“introducers.”

W3C (World Wide Web Consortium)

An international industry consortium founded in 1994 to develop common protocolsfor the evolution of the World Wide Web.

X.509v3

An ITU-T digital certificate that is an internationally recognized electronic documentused to prove identity and public key ownership over a communication network.It contains the issuer’s name, the user’s identifying information, and theissuer’s digital signature, as well as other possible extensions in version 3.

X9.17

An ANSI specification that details the methodology for generating random andpseudo-random numbers.

Zone Master Key

A Zone Master Key (ZMK) is a key-encrypting key which is distributed manually between two (or more) communicating sites, within a shared network, in order that further keys can be exchanged automatically (without the need for manual intervention). The ZMK is used to encrypt keys of a lower level for transmission. For local storage, a ZMK is encrypted under one of the LMK pairs.

Within the VISA environment this is known as a ZCMK.

Хеширование (иногда хэширование, англ.hashing) — преобразование входного массива данных произвольной длины в выходную битовую строку фиксированной длины. Такие преобразования также называются хеш-функциями или функциями свёртки, а их результаты называют хешем, хеш-кодом или дайджестом сообщения (англ.message digest).