Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
Вопросы на собеседование (3).doc
Скачиваний:
1
Добавлен:
01.07.2025
Размер:
360 Кб
Скачать
☆

Виды утилит по функциям[править | править вики-текст]

  • Диспетчеры файлов;

  • Архиваторы (с возможным сжатием данных);

  • Просмотрщики;

  • Утилиты для диагностики аппаратного или программного обеспечения;

  • Утилиты восстановления после сбоев;

  • Оптимизатор диска — вид утилиты для оптимизации размещения файлов на дисковом накопителе, например, путём дефрагментации диска;

  • Шредеры файлов;

  • Деинсталлятор — программа для удаления программного обеспечения[3];

  • Утилиты управления процессами.

Краткое описание и примеры использования сетевых утилит командной строки Windows: ARP IPCONFIG GETMAC NBTSTAT NETSH NETSTAT NET NSLOOKUP PATHPING PING ROUTE TELNET TRACERT

Что такое ICMP? ICMP (англ. Internet Control Message Protocol — протокол межсетевых управляющих сообщений[1]) — сетевой протокол, входящий в стек протоколов TCP/IP. В основном ICMP используется для передачи сообщений об ошибках и других исключительных ситуациях, возникших при передаче данных, например, запрашиваемая услуга недоступна, или хост, или маршрутизатор не отвечают. Также на ICMP возлагаются некоторые сервисные функции.

  • С какими ОС работали? Vista, XP, 7 и т.д.

  • Что такое Wi-Fi? Wi-Fi — (произносится "Вай-фай") торговая марка Wi-Fi Alliance для беспроводных сетей на базе стандарта IEEE 802.11. Под аббревиатурой Wi-Fi (от английского словосочетания Wireless Fidelity[1], которое можно дословно перевести как «беспроводное качество» или «беспроводная точность») в настоящее время развивается целое семейство стандартов передачи цифровых потоков данных по радиоканалам. Обычно схема Wi-Fi сети содержит не менее одной точки доступа и не менее одного клиента. Также возможно подключение двух клиентов в режиме точка-точка (Ad-hoc), когда точка доступа не используется, а клиенты соединяются посредством сетевых адаптеров «напрямую». Точка доступа передаёт свой идентификатор сети (SSID (англ.)русск.) с помощью специальных сигнальных пакетов на скорости 0,1 Мбит/с каждые 100 мс. Поэтому 0,1 Мбит/с — наименьшая скорость передачи данных для Wi-Fi. Зная SSID сети, клиент может выяснить, возможно ли подключение к данной точке доступа. При попадании в зону действия двух точек доступа с идентичными SSID приёмник может выбирать между ними на основании данных об уровне сигнала. Стандарт Wi-Fi даёт клиенту полную свободу при выборе критериев для соединения. Более подробно принцип работы описан в официальном тексте стандарта[9].

Для чего нужен OFDM? OFDM (англ. Orthogonal frequency-division multiplexing — мультиплексирование с ортогональным частотным разделением каналов) является цифровой схемой модуляции, которая использует большое количество близко расположенных ортогональных поднесущих. Каждая поднесущая модулируется по обычной схеме модуляции (например, квадратурная амплитудная модуляция) на низкой символьной скорости, сохраняя общую скорость передачи данных, как и у обычных схем модуляции одной несущей в той же полосе пропускания. На практике сигналы OFDM получаются путём использования БПФ (Быстрое преобразование Фурье). Основным преимуществом OFDM по сравнению со схемой с одной несущей является её способность противостоять сложным условиям в канале. Например, бороться с затуханием в области ВЧ в длинных медных проводниках, узкополосными помехами и частотно-избирательным затуханием, вызванным многолучевым характером распространения, без использования сложных фильтров-эквалайзеров. Канальная эквализация упрощается вследствие того, что OFDM сигнал может рассматриваться как множество медленно модулируемых узкополосных сигналов, а не как один быстро модулируемый широкополосный сигнал. Низкая символьная скорость делает возможным использование защитного интервала между символами, что позволяет справляться с временным рассеянием и устранять межсимвольную интерференцию (МСИ). Сигнал OFDM – сумма нескольких ортогональных поднесущих, на каждой из которых передаваемые на основной частоте данные независимо модулируются с помощью одного из типов модуляции (BPSK, QPSK, 8-PSK, QAM и др.). Далее этим суммарным сигналом модулируется радиочастота.

Что такое SIP и RTP? SIP (англ. Session Initiation Protocol — протокол установления сеанса) — протокол передачи данных, описывающий способ установления и завершения пользовательского интернет-сеанса, включающего обмен мультимедийным содержимым (IP-телефония, видео- и аудиоконференции, мгновенные сообщения, онлайн-игры).

Протокол описывает, каким образом клиентское приложение (например, софтфон) может запросить начало соединения у другого, возможно, физически удалённого клиента, находящегося в той же сети, используя его уникальное имя. Протокол определяет способ согласования между клиентами об открытии каналов обмена на основе других протоколов, которые могут использоваться для непосредственной передачи информации (например, RTP). Допускается добавление или удаление таких каналов в течение установленного сеанса, а также подключение и отключение дополнительных клиентов (то есть допускается участие в обмене более двух сторон — конференц-связь). Протокол также определяет порядок завершения сеанса.

Протокол RTP (англ. Real-time Transport Protocol) работает на уровне приложений (OSI - 7) и используется при передаче трафика реального времени. Протокол был разработан Audio-Video Transport Working Group в IETF и впервые опубликован в 1996 году как RFC 1889; выведен из употребления обновлением RFC 3550 в 2003 году.

Протокол RTP переносит в своём заголовке данные, необходимые для восстановления аудиоданных или видеоизображения в приёмном узле, а также данные о типе кодирования информации (JPEG, MPEG и т. п.). В заголовке данного протокола, в частности, передаются временная метка и номер пакета. Эти параметры позволяют при минимальных задержках определить порядок и момент декодирования каждого пакета, а также интерполировать потерянные пакеты.

RTP не имеет стандартного зарезервированного номера порта. Единственное ограничение состоит в том, что соединение проходит с использованием чётного номера, а следующий нечётный номер используется для связи по протоколу RTCP. Тот факт, что RTP использует динамически назначаемые адреса портов, создаёт ему трудности для прохождения межсетевых экранов, для обхода этой проблемы, как правило, используется STUN-сервер.

Установление и разрыв соединения не входит в список возможностей RTP, такие действия выполняются сигнальным протоколом (например, RTSP или SIP протоколом).

RTP был разработан как протокол реального времени, из конца в конец (end-to-end), для передачи потоковых данных. В протокол заложена возможность компенсации джиттера и обнаружения нарушения последовательности пакетов данных — типичных событий при передаче через IP-сети. RTP поддерживает передачу данных для нескольких адресатов через Multicast.[1] RTP рассматривается как основной стандарт для передачи голоса и видео в IP-сетях и совместно с кодеками.

Что такое IP-TV и UDP? IPTV или Телевидение по протоколу интернета (англ. Internet Protocol Television) (IP-TV, IP-телевидение) — технология (стандарт) цифрового телевидения в сетях передачи данных по протоколу IP, новое поколение телевидения. В последнее время часто путается с технологией ОТТ, которая, в свою очередь является подклассом IPTV в области распространения видеоконтента.

Архитектура комплекса IPTV, как правило, включает в себя следующие составляющие:

  • Подсистема управления комплексом и услугами, которую ещё называют «Промежуточное программное обеспечение» или «IPTV Middleware»

  • Подсистема приёма и обработки контента

  • Подсистема защиты контента

  • Подсистема видео серверов

  • Подсистема мониторинга качества потоков и клиентского оборудования.

В качестве клиентского оборудования могут выступать все компьютеры (соответствующие системным требованиям), специализированные ТВ приставки, медиа-плееры, телевизоры с технологией Smart TV, мобильные устройства. На программном уровне доступ к ресурсам IPTV может осуществляться как при помощи специальных приложений (программ), так и при помощи обычного интернет-браузера, встроенного в устройство.

Доставка контента до клиентского оборудования осуществляется либо по управляемой IP-сети оператора связи с использованием технологии multicast или unicast (в зависимости от топологии сети), либо без привязки в сетях операторов связи (ОТТ).

Главным достоинством IPTV является интерактивность и возможность предоставления пользователям широкого набора дополнительных услуг, связанных с потреблением контента (Video on Demand (VoD), TVoIP, Time Shifted TV, Network Personal Video Recorder, Electronic Program Guide, Near Video on Demand). Возможности протокола IP позволяют предоставлять не только видеоуслуги, но и гораздо более широкий пакет услуг, в том числе интерактивных и интегрированных.

Помимо базовых услуг, IPTV может включать ряд дополнительных сервисов (Video Telephony, Voting, Information Portals, Web, Games, MOD KOD). Это возможно на основе унификации и стандартизации различных оконечных устройств, интеграции звука, видео и данных на основе IP-протокола и предоставления услуг на единой технологической платформе.

В IPTV есть возможность использовать для одного видеоряда двух и более каналов звукового сопровождения, например на русском и английском языках.

Преимущество IPTV перед аналоговым кабельным ТВ:

  • Изображение и звук обычно качественнее, вплоть до HD-разрешения и 5.1-канального аудио

  • Интерактивность (возможность просмотреть, например, справку по фильму, оставить отзыв)

  • Сервисные возможности timeshift и video-on-demand

  • UDP (англ. User Datagram Protocol — протокол пользовательских датаграмм) — один из ключевых элементов TCP/IP, набора сетевых протоколов для Интернета. С UDP компьютерные приложения могут посылать сообщения (в данном случае называемые датаграммами) другим хостам по IP-сети без необходимости предварительного сообщения для установки специальных каналов передачи или путей данных. Протокол был разработан Дэвидом П. Ридом в 1980 году и официально определён в RFC 768.

  • UDP использует простую модель передачи, без неявных «рукопожатий» для обеспечения надёжности, упорядочивания или целостности данных. Таким образом, UDP предоставляет ненадёжный сервис, и датаграммы могут прийти не по порядку, дублироваться или вовсе исчезнуть без следа. UDP подразумевает, что проверка ошибок и исправление либо не нужны, либо должны исполняться в приложении. Чувствительные ко времени приложения часто используют UDP, так как предпочтительнее сбросить пакеты, чем ждать задержавшиеся пакеты, что может оказаться невозможным в системах реального времени. При необходимости исправления ошибок на сетевом уровне интерфейса приложение может задействовать TCP или SCTP, разработанные для этой цели.

  • Природа UDP как протокола без сохранения состояния также полезна для серверов, отвечающих на небольшие запросы от огромного числа клиентов, например DNS и потоковые мультимедийные приложения вроде IPTV, Voice over IP, протоколы туннелирования IP и многие онлайн-игры.

UDP-приложения используют датаграммные сокеты для установки соединения между хостами. Приложение связывает сокет с его конечной точкой передачи данных, которая является комбинацией IP-адреса и порта службы. Порт — это программная структура, определяемая номером порта — 16-битным целочисленным значением (то есть от 0 до 65535). Порт 0 зарезервирован, хотя и является допустимым значением порта источника в случае, если процесс-отправитель не ожидает ответных сообщений

UDP — минимальный ориентированный на обработку сообщений протокол транспортного уровня, задокументированный в RFC 768.

UDP не предоставляет никаких гарантий доставки сообщения для вышестоящего протокола и не сохраняет состояния отправленных сообщений. По этой причине UDP иногда называют Unreliable Datagram Protocol (англ. — Ненадёжный протокол датаграмм).

UDP обеспечивает многоканальную передачу (с помощью номеров портов) и проверку целостности (с помощью контрольных сумм) заголовка и существенных данных. Надёжная передача в случае необходимости должна реализовываться пользовательским приложением