Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
Лекции ЗИ.doc
Скачиваний:
4
Добавлен:
01.07.2025
Размер:
6 Мб
Скачать
☆

Криптография при работе в сети.

Архитектура взаимодействия открытых систем (ISO/OSI) предлагает рассматривать взаимодействие программ на разных уровнях или "слоях"; соответственно, в разных слоях реализуется и защита сетевых взаимодействий. В зависимости от уровня, на котором используются криптографические средства, информационная система может противостоять тем или иным атакам. Так, аутентификация на сетевом уровне позволит вам убедиться, что вы действительно работаете с нужным компьютером. Однако аутентифицировать конкретное приложение вы сможете только на транспортном уровне, а конкретного человека - на прикладном.

Шифрование ip-трафика.

Для обеспечения защиты данных на сетевом уровне ОС MS Windows поддерживает протокол IPSec, утвержденный Рабочей группой инженеров Internet (IETF) в качестве стандартного расширения безопасности для протокола IP. IPSec поддерживает аутентификацию на сетевом уровне (аутентификацию хостов сети), конфиденциальность и целостность данных.

Защищенные соединения.

Стандартом де-факто обеспечения безопасности для сетевых приложений, взаимодействующих в архитектуре "клиент-сервер" (таких как Web-приложения или системы электронной почты), является протокол SSL. С незначительными изменениями он закреплен IETF в спецификации RFC2246 Transport Layer Security и рекомендован разработчикам Internet-приложений. Этот протокол обеспечивает аутентификацию взаимодействующих приложений, конфиденциальность и целостность передаваемой информации.

Программные продукты Microsoft, такие как Internet Explorer, Outlook Express, Internet Information Server, в общем, соответствуют рекомендациям IETF RFC2246, однако на ряд моментов следует обратить внимание.

Во-первых, взаимная аутентификация клиента и сервера предусмотрена только в продуктах, реализующих протокол HTTP (Internet Explorer и IIS). Другие продукты Microsoft (такие как серверы SMTP и NNTP и почтовый клиент Outlook Express) реализуют SSL/TLS только в режиме аутентификации сервера.

Во-вторых, в клиентских программах отсутствуют средства для выработки ключей и цифровых сертификатов, необходимых при использовании SSL/TLS протоколов. Т.е. эти продукты не самодостаточны и для обеспечения комплексной защиты требуется использование сторонних программ.

Шифрование и цифровая подпись сообщений электронной почты.

На сегодня существуют два открытых стандарта шифрования и цифровой подписи сообщений электронной почты: OpenPGP и S/MIME. Почтовые программы Microsoft Outlook и Outlook Express реализуют S/MIME. Для того чтобы заверять свои сообщения цифровой подписью, вам необходимо получить цифровой сертификат в формате X.509. Для шифрования сообщения необходимо наличие цифровых сертификатов его получателей. Нужно отметить, что последние версии почтовых программ Microsoft реализуют не только S/MIME (IETF RFC2633), но и расширения этой спецификации (IETF RFC2634), включающие, например, такой сервис, как достоверное подтверждение получения сообщения (квитирование).