Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:

Izuch_comp_i__progr

.pdf
Скачиваний:
45
Добавлен:
14.04.2015
Размер:
7 Мб
Скачать
☆

-81 -

Частные сети, создаваемые и поддерживаемые частными

лицами

По скорости передачи информации выделяют низко-, средне- и

высокоскоростные компьютерные сети. Единица скорости передачи сигнала,

измеряемая числом дискретных переходов или событий в секунду. Если каждое событие представляет собой один бит, бод эквивалентен бит/сек. Наиболее распространенной единицей измерения скорости передачи информации в сетях является бит/с.

Низкоскоростные (до 10 Мбит/с),

Среднескоростные (до 100 Мбит/с),

Высокоскоростные (свыше 100 Мбит/с);

По типу среды передачи компьютерные сети разделяются на:

Проводные (коаксиальные, на витой паре, оптоволоконные и т.д.)

Беспроводные (с передачей информации по радиоканалам, в

инфракрасном диапазоне).

Архитектура компьютерных сетей

Состав основных элементов в сети зависит от ее архитектуры.

Архитектура – это концепция, определяющая взаимосвязь, структуру и функции взаимодействия объектов в сети. Она предусматривает логическую,

функциональную и физическую организацию технических и программных средств сети. Архитектура определяет принципы построения и функционирования аппаратного и программного обеспечения элементов сети.

В основном выделяют три архитектуры:

-архитектура терминал-главный компьютер;

-архитектура клиент-сервер;

-одноранговая архитектура.

Архитектура терминал–главный компьютер (terminal–host computer architecture) – это концепция компьютерной сети, в которой вся обработка

- 82 -

данных осуществляется одним или группой главных компьютеров высокой мощности (серверы, мейнфреймы). Рассматриваемая архитектура предполагает два типа оборудования:

Раздел II. Главный компьютер (либо группа компьютеров), который осуществляет управление сетью, обеспечивает хранение и обработку данных.

Раздел III. Терминалы, предназначенные для передачи главному компьютеру команд на организацию сеансов и выполнения заданий, ввода данных для выполнения заданий и получения результатов.

Пример архитектуры сети с главными компьютерами может служить системная сетевая архитектура (System Network Architecture – SNA),

предложенная корпорацией IBM в 80-х годах 20-го века и получившее в дальнейшем широкое развитие в секторе корпоративных сетевых решений, а

также ряд решений, предлагаемых корпорацией SUN Microsystems.

Одноранговая архитектура (peer-to-peer architecture) – это концепция компьютерной сети, в которой ее ресурсы рассредоточены по всем системам.

Данная архитектура характеризуется тем, что в ней все системы равноправны.

Обычно подобная архитектура реализуется в локальных компьютерных сетях.

К одноранговым сетям относятся малые сети, где любая рабочая станция может, например, выполнять одновременно функции файлового сервера и рабочей станции. Чтобы ресурс стал общим, его необходимо отдать в общее пользование, используя службы удаленного доступа сетевых одноранговых операционных систем. В зависимости от того, как будет установлена защита данных, другие пользователи смогут пользоваться файлами сразу же после их создания. Одноранговые компьютерные сети достаточно хороши для небольших рабочих групп и являются наиболее легким и дешевым решением для объединения небольшого количества равноправных пользователей в небольшом офисе или доме.

- 83 -

Архитектура клиент-сервер (client-server architecture) – это концепция компьютерной сети, предполагающая наличие специально выделенного сервера,

содержащего основные ресурсы сети и контролирующего доступ к ним клиентов.

Рассматриваемая архитектура определяет два типа компонентов: серверы и клиенты.

Сервер – это элемент сети под управлением специальной операционной системы, предоставляющий собственные ресурсы другим объектам сети

(клиентам) по их запросам. Сервер обслуживает клиентов, выполняет их задания и возвращает клиентам результаты их выполнения. Сам сервер может быть клиентом только вышестоящего сервера, таким образом, формируется своеобразная иерархия.

Клиенты – это элементы сети (рабочие станции, персональные компьютеры и т.п.), использующие ресурсы сервера и предоставляющие

интерфейсы пользователя.

Таким образом, компьютерная сеть может быть построена по разнообразным принципам, технологиям и функциям, что определяет понятие

архитектуры сети. Выбор архитектуры сети осуществляется на этапе ее проектирования и зависит от ряда структурно-функциональных факторов:

количества элементов (пользователей) проектируемой сети; территориального расположения элементов сети и их географической разобщенности; мощности имеющегося оборудования; организационной структуры коллектива пользователей и др.

Архитектура компьютерной сети полностью или частично определяет и ее топологию. Сетевая топология (от греч. τόπος, место) – это описание конфигурации сети, схема расположения и соединения сетевых устройств.

Сетевая топология может быть:

-84 -

физической – описывает реальное расположение и связи между узлами сети.

логической – описывает хождение сигнала в рамках физической топологии.

Существует множество способов соединения сетевых устройств, из них можно выделить четыре базовых топологии: шина, кольцо, звезда и ячеистая

топология. Остальные топологии являются комбинациями базовых. В общем случае такие топологии называются смешанными или гибридными, но некоторые из них имеют собственные названия, например «Дерево».

Рисунок 3.1.Топологии компьютерных сетей: А. Линия; В. Каждый-с-каждым; С. Звезда; D. Кольцо; E. Шина; F. Дерево

Уровни организации и технологии сетевого взаимодействия

Для единого представления данных в сетях с неоднородными устройствами и программным обеспечением международная организация по стандартизации

(ISO) разработала базовую эталонную модель взаимодействия открытых систем

(Open System Interconnection, OSI). Эта модель описывает правила и процедуры передачи данных в различных сетевых средах и между различными устройствами. Основным элементом модели является уровень – набор

- 85 -

структур и программ, обеспечивающих обработку информационного потока на определенном этапе его передачи. Уровень выступает единицей декомпозиции совокупности функций, обеспечивающих информационное взаимодействие прикладных процессов. Выделяют семь уровней модели OSI (рис.3.2). Уровни не зависят друг от друга, но каждый из них «отвечает» за определенные этапы в процессе передачи данных по сети.

Процесс прохождения данных по уровням сверху вниз (от прикладного до физического уровней) называется инкапсуляцией, в ходе которого передаваемые данные дополняются служебной информацией каждого из уровней (заголовки и хвостовики). Обратный процесс, происходящий при получении данных из сети,

называется декапсуляцией, в ходе которого с данных снимаются «внешние оболочки».

 

Пользователи

Интерфейс

 

 

 

 

пользователя

 

Прикладныепроцессы

Прикладной

 

интерфейс

 

 

Уровни:

 

 

7

Прикладной

 

6

Представительский

Область

5

Сеансовый

взаимодействия

4

Траспортный

открытых

3

Сетевой

систем

2

Канальный

 

1

Физический

 

Физическиесредствасоединения

 

Рисунок 3.2. Модель OSI и ее уровни

Уровень 1, физический

Физический уровень получает данные от вышележащего канального уровня и преобразует их в оптические или электрические сигналы, соответствующие 0 и 1 бинарного потока. Эти сигналы посылаются в среду передачи. На принимающей стороне, сигналы воспринимаются сетевым устройством,

преобразуются в 1 и 0 и передаются выше – канальному уровню для дальнейшей обработки. Механические, электрические или оптические свойства среды передачи определяются именно на физическом уровне и предполагают определенные стандарты, регламентирующие типы кабелей и

- 86 -

разъемов. Единицей передачи данных на физическом уровне вычислительной сети является сигнал. Во взаимодействии сетевых устройств на физическом уровне основные роли играют такие компоненты как сетевые интерфейсы,

линии связи, концентраторы (повторители, хабы), преобразователи среды и т.д.

Физически сигнал возникает и регистрируется сетевыми интерфейсами

(Network Interface Card, NIC), передается по кабелю или в эфире, а

распространяется с помощью концентраторов и усилителей.

Уровень 2, канальный

Этот уровень обслуживает вышестоящий уровень – сетевой и использует ресурсы нижележащего – физического уровня. Важным понятием на канальном уровне является понятие MAC-адреса (физического адреса). MAC-адрес3 – это имя сетевого устройства, идентифицирующее его в локальной вычислительной сети на канальном уровне. Единицей передачи информации на канальном уровне является «кадр». Каждый кадр обязательно имеет три части: заголовок, полезную нагрузку и хвостовик. Основную роль в адресации кадра играет его заголовок, где указываются MAC-адреса отправителя и получателя кадра. Именно по MAC-адресу получателя из всего потока кадров происходит «отбор» кадров, предназначенных данной системе. На канальном уровне выполняется первый этап контроля передачи данных, т.е. обнаружение и уничтожение поврежденных кадров. Типовой подход к решению данной задачи базируется на обработке контрольной суммы кадра4.

На канальном уровне функционируют такие сетевые компоненты как:

Сетевые интерфейсы и их драйвера.

Коммутаторы (switches) - устройство либо программа, осуществляющая выбор одного из возможных вариантов направления передачи данных.

3Он же часто называется «физический адрес». Большинство сетевых протоколов канального уровня используют одно из трёх пространств MAC-адресов: MAC-48, EUI-48 и EUI-64. Адреса типа MAC-48 наиболее распространены; они используются в таких технологиях, как Ethernet, Token ring, FDDI и др. Они состоят из 48 бит (6 байт), таким образом, адресное пространство MAC-48 насчитывает 248 (или 281 474 976 710 656) адресов. Согласно подсчётам IEEE, этого запаса адресов хватит по меньшей мере до 2100 года.

4Для этого используется специальная математическая формула CRC (Cyclic Redundancy Check — циклический избыточный код), предназначенная для вычисления 32-разрядного значения, которое помещается в поле FCS.

- 87 -

Выбор направления передачи данных осуществляется по MAC-адресу

пункта назначения.

Мосты (ретрансляционная система, соединяющая каналы передачи данных).

Уровень 3, сетевой

На сетевом уровне происходит обработка данных, передаваемых между сетями, здесь формируются сетевые адреса отправителя и получателя, а также выполняется определение оптимального маршрута передачи данных. Единица данных, циркулирующая на этом уровне называется дейтаграммой или пакетом. Пакет – абстрактный блок полезной информации, с которой имеет дело сетевой уровень, обладающий адресами отправителя и получателя.

На сетевом уровне функционирует три протокола: IP, ICMP, IGMP. Основным их них является протокол IP (Internet Protocol, межсетевой протокол)5, именно ему отведена роль «рабочей лошадки» в семействе TCP/IP.

Протокол ICMP6 (Internet Control Message Protocol, Межсетевой Протокол Управляющих Сообщений) служит для обмена сообщениями об ошибках и различных особых случаях, требующих специальной обработки на более высоких уровнях.

IP-протокол построен на технологии «пакетной коммутации»7,

предполагающей, что каждый IP-пакет отправляется в сеть независимо от других пакетов. Cетевой узел на основании заголовка пакета и собственной информации об окружающих его узлах сети выбирает следующий узел, на который следует перенаправить пакет. При этом пакеты, имеющие один и тот

5IP стандартизирован докуменом RFC 791, IP через Ethernet – документом RFC 894. Дополнения к стандарту IP содержатся в RFC 1122 и в ряде других источниках.

6Спецификация ICMP содержится в RFC 792.

7Одним из пионеров в области пакетной коммутации является Леонард Клейнрок, начавший работы над теорией пакетной коммутации в 1959 г. Практическая реализация принципов пакетной коммутации состоялась в 1965, когда два молодых ученых: Лоуренс Робертс и Томас Мэрилл впервые связали низкоскоростной коммутируемой телефонной линией на скорости 1200 бит/с два компьютера - ТХ-2 из Lincoln Lab Массачусетского технологического института и AN / FSQ -32 из System Development Corporation, находившийся в Санта Монике (штат Калифорния, США). Данная компьютерная сеть стала первой сетью с пакетной коммутацией. В 1966 г. Л. Робертс стал руководителем группы по разработке компьютерной сети ARPANET, ставшей предшественницей Интернета.

- 88 -

же IP-адрес назначения, от станции отправителя к станции получателя, могут следовать разными путями. Восстановление правильной последовательности пакетов происходит либо на конечном узле маршрута, либо непосредственно на станции назначения. Функции обнаружения и восстановления пакетов так же организуются либо на конечном узле, либо на станции назначения.

В IP-дейтаграммы (IP-пакеты) инкапсулированы все данные, передаваемые по сети (сегменты TCP, UDP, ICMP и IGMP). Протокол IP является

«ненадежным», т.е. он не гарантирует, что каждый отправленный пакет достигнет пункта назначения. Контроль доставки, восстановление очередности при этом возлагается на вышележащие сервисы (транспортные протоколы,

прикладной уровень). IP-пакет (дейтаграмма)8 состоит из заголовка и полезной нагрузки, которая заполнена данными, полученными с вышестоящего

(транспортного) уровня.

IP-адреса представляют собой основу адресной передачи пакетов. IP-адрес – уникальный идентификатор устройства, подключённого к IP-сети (ПК,

маршрутизатор, сетевой принтер и т.д.). IP-адрес представляет собой числовое значение размером 4 байта (32-битовое двоичное число). Основной формой записи IP-адреса является точечно-десятичное представление (DDN, dotteddecimal notation), когда он представлен в виде четырех десятичных чисел (от 0

до 255), разделённых точками, например, 192.168.0.1. IP-адрес содержит два ключевых компонента IP-адресации: номер сети и номер узла.

Верное прочтение IP-адреса невозможно без правильного выделения из него номера сети и номера узла. Именно для этого существует маска сети (сетевая маска, маска подсети), представляющий собой специальный шаблон, наложение которого на IP-адрес показывает, какие части последнего описывают сеть, а

какие – узел. Маска сети также, как и IP-адрес, обычно представляется в

8 Здесь и далее в главе приводится описание протокола IP 4-й версии. Для знакомства с особенностями новой, 6- й версии протокола, авторы рекомендуют обратиться к специальной литературе, например, RFC 2460.

- 89 -

точечно-десятичной нотации. Биты, равные 1, в сетевой маске показывают, что соответствующий бит в IP-адресе описывает сеть, а биты, равные 0 – узел в сети.

Например, узел с IP-адресом 12.34.56.78 и маской подсети 255.255.0.0

находится в сети 12.34.0.0, а его номер в этой сети 56.78. Наложение на тот же IP-

адрес иной маски приведет к смещению прочтения, вследствие чего будет получен адрес другого устройства, например с маской 255.255.255.0 адрес сети будет вычислен как 12.34.56, а номер узла в ней – 56. Очевидно, это уже другое устройство. Таким образом, сетевая маска позволяет верно интерпретировать IP-

адрес, что необходимо для корректной адресации пакетов в IP-сетях.

Основная нагрузка по межсетевому взаимодействию (пересылке пакетов между различными сетями) лежит на специальных сетевых устройствах,

называемых маршрутизаторами. Маршрутизатор входит сразу в несколько сетей, в силу чего имеет несколько IP-адресов, принадлежащих каждый своей сети, и пересылает пакеты из одной сети в другую. Для реализации своей функции маршрутизатор должен «знать» топологию сети и выбрать подходящий путь прохождения пакетов. Выбор маршрута осуществляется на основе протоколов маршрутизации, содержащих информацию о топологии сети и алгоритмов маршрутизации, базирующихся на определенных критериях выбора.

Как уже указывалось, адресация на сетевом уровне построена на применении IP-адресов как уникальных идентификаторах сетевых компонентов в IP-сетях. В то же время, IP-пакет, уходя с сетевого уровня, попадает на уровень канальный, где он «инкапсулируется» в кадр этого уровня (например,

кадр Ethernet), который «выбрасывается» в локальную сеть. Адресация кадров,

описанная ранее, основана на MAC-адресах. Таким образом, необходим механизм, обеспечивающий адекватное преобразование адресов сетевого уровня (IP-адресов) в адреса канального уровня (МАС-адреса). Подобным механизмом является специально разработанные протокол разрешения адресов

(Address Resolution Protocol – ARP) и протокол обратного разрешения адресов

- 90 -

(Reverse Address Resolution Protocol – RARP9). Назначение ARP – определение физического адреса получателя (МАС-адреса) по его IP-адресу. В случае, если

IP-адрес получателя соответствует другой локальной сети, а качестве физического адреса получателя используется MAC-адрес маршрутизатора.

Действие протокола RARP, как следует из его названия, обратно действию ARP,

т.е. RARP определяет IP-адрес узла сети по известному физическому адресу.

Уровень 4, транспортный

Транспортный уровень обеспечивает передачу данных между двумя узлами сети (между двумя приложениями). Этот уровень получает данные от приложений, формирует блоки данных (UDP-дейтаграммы и TCP-сегменты),

добавляет к ним служебную информацию и предает на сетевой уровень. При получении данных из сети, процесс осуществляется в обратном направлении.

На транспортном уровне участвуют два протокола: UDP (User Datagram Protocol – протокол дейтаграммы пользователя)10 и TCP (Transmission Control Protocol – протокол управления передачей)11. UDP не обеспечивает надежного транспортного сервиса, он лишь оформляет порцию данных, поступающих от приложений, в пакет и отдает его сетевому уровню. В отличие от UDP, TCP

обеспечивает и гарантирует надежный, основанный на соединении обмен байтовыми потоками данных. В нем предусмотрены механизмы установки соединения, контроля отправки и получения, обнаружения ошибок и вывода соответствующих сообщений, а также целый ряд других функций,

направленных на повышение надежности передачи данных.

Уровень приложений

Задачами этого уровня является перенос файлов, обмен почтовыми сообщениями и управление сетью. Большинство сетевых приложений построено по модели «клиент-сервер». Сервер, в данном случае, - это приложение предоставляющее определенную услугу, ресурс (службу). Доступ

9ARP стандартизирован документом RFC 826. Протокол RARP – RFC 903.

10Официальные спецификации UDP изложены в RFC 768

11Первое описание TCP было опубликовано в RFC 793

Соседние файлы в предмете [НЕСОРТИРОВАННОЕ]