- •Introduction to OpenFlow
- •Overview
- •Planes of Networking
- •Planes of Networking (Cont)
- •Data vs. Control Logic
- •OpenFlow: Key Ideas
- •History of OpenFlow
- •Separation of Control and Data Plane
- •Flow Table Example
- •Matching
- •Counters
- •OpenFlow V1.0
- •Actions
- •Actions (Cont)
- •Hardware OpenFlow Switches
- •Software OpenFlow Switches
- •Open vSwitch
- •Open vSwitch Features
- •Open vSwitch Features (Cont)
- •OVSDB
- •OpenFlow V1.1
- •OpenFlow V1.1 (Cont)
- •OpenFlow V1.2
- •OpenFlow 1.3
- •OpenFlow V1.3 (Cont)
- •OpenFlow V1.3 (Cont)
- •OpenFlow V1.4
- •OpenFlow Evolution Summary
- •Bootstrapping
- •OpenFlow Configuration Protocol (OF-Config)
- •OF-Config (Cont)
- •OF-Config Concepts
- •OF-Config Evolution
- •OpenFlow Notification Framework
- •Implementation Issues
- •OpenFlow: Future Work Items
- •Summary
- •Reading List
- •References
- •References (Cont)
- •Wikipedia Links
- •Wikipedia Links (Optional)
- •Acronyms
- •Acronyms (Cont)
- •Acronyms (Cont)
- •Acronyms (Cont)
Open vSwitch
Open Source Virtual Switch
Nicira Concept
Can Run as a stand alone hypervisor switch or as a distributed switch across multiple physical servers
Default switch in XenServer 6.0, Xen Cloud Platform and supports Proxmox VE, VirtualBox, Xen KVM
Integrated into many cloud management systems including OpenStack, openQRM, OpenNebula, and oVirt
Distributed with Ubuntu, Debian, Fedora Linux. Also FreeBSD
Ref: http://openvswitch.org/ |
http://www.cse.wustl.edu/~jain/cse570-13/ |
|
Washington University in St. Louis |
©2013 Raj Jain |
14-17
Open vSwitch Features
Inter-VM communication monitoring via:
NetFlow: Cisco protocol for sampling and collecting traffic statistics (RFC 3954)
sFlow: Similar to NetFlow by sflow.org (RFC 3176)
Jflow: Juniper’s version of NetFlow
NetStream: Huawei’s version of NetFlow
IPFIX: IP Flow Information Export Protocol (RFC 7011) - IETF standard for NetFlow
SPAN, RSPAN: Remote Switch Port Analyzer – port mirroring by sending a copy of all packets to a monitor port
GRE-tunneled mirrors: Monitoring device is remotely
connected to the switch via a GRE tunnel
Washington University in St. Louis |
http://www.cse.wustl.edu/~jain/cse570-13/ |
©2013 Raj Jain |
14-18
Open vSwitch Features (Cont)
Link Aggregation Control Protocol (LACP)
IEEE 802.1Q VLAN
IEEE 802.1ag Connectivity Fault Management (CFM)
Bidirectional Forwarding Detection (BFD) to detect link faults (RFC 5880)
IEEE 802.1D-1998 Spanning Tree Protocol (STP)
Per-VM traffic policing
OpenFlow
Multi-table forwarding pipeline
IPv6
GRE, VXLAN, IPSec tunneling
Kernel and user-space forwarding engine options
Washington University in St. Louis |
http://www.cse.wustl.edu/~jain/cse570-13/ |
©2013 Raj Jain |
14-19
OVSDB
Open vSwitch Database Management Protocol (OVSDB)
Monitoring capability using publish-subscribe mechanisms
Stores both provisioning and operational state
Java Script Object Notation (JSON) used for schema format and for JSON-RPC over TCP for wire protocol (RFC 4627)
<database-schema> “name”: <id> “version”: <version>
“tables”: {<id>: <table-schema>,…}
|
Control and Mgmt Cluster |
|
|
|
|||||
|
|
|
|
|
|
|
|
|
|
|
OVSDB |
|
|
|
OpenFlow |
|
|
|
|
|
|
|
|
|
|
|
|
|
|
OVSDB Server |
|
ovs-vswitchd |
|
|
|||||
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
||
|
|
|
|
Forwarding Path |
|
||||
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
RPC Methods: List databases, Get Schema, Update, Lock, …
Open vSwitch project includes open source OVSDB client and
server implementations
Ref: B. Pfaff and B. Davie, “The Open vSwitch Database Management Protocol,” IETF draft, Oct 2013, http://tools.ietf.org/html/draft-pfaff-ovsdb-proto-04
Washington University in St. Louis |
http://www.cse.wustl.edu/~jain/cse570-13/ |
©2013 Raj Jain |
|
14-20
