Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
Завдання_4.doc
Скачиваний:
17
Добавлен:
05.12.2018
Размер:
162 Кб
Скачать
☆

Функціонування електронної пошти

Електронна пошта багато в чому подібна на звичайну поштову службу.

Рис. 4.1. Відправлення й одержання пошти

Основні протоколи:

  • SMTP (Simple Mail Transfer Protocol) - простий протокол передачі пошти, використовується для відправлення пошти, як клієнтом на сервер, так і сервером на інший сервер.

  • POP3 (Post Office Protocol) - використовується для прийому пошти клієнтом із сервера.

  • IMAP 4 (Internet Message Access Protocol) -

  • UUCP (Unix-Unix-CoPy) - використовується для відправлення і прийому пошти, як клієнтом на(с) сервер(а), так і сервером на інший сервер. Тепер майже не використовується, тому розглядати не будемо.

Протокол SMTP

Перший стандарт - RFC0788 (Simple Mail Transfer Protocol J. Postel Nov-01-1981).

Остання версія - RFC2821 (Simple Mail Transfer Protocol J. Klensin, Ed. April 2001).

Simple Mail Transfer Protocol - протокол високого рівня (а саме, рівня додатків), використовується для відправлення пошти, як клієнтом на сервер, так і сервером на інший сервер.

Порт по замовчуванні - 25.

Основний недолік протоколу, це відсутність аутентифікації і "докачки" (як у FTP, HTTP) повідомлень, тобто якщо ви посилаєте великий лист (10Мбайт), то у випадку розриву з'єднання ваше повідомлення прийдеться передавати заново, і можливо так до нескінченності. Тому великі листи необхідно різати на частини.

Модель протоколу:

Рис. 4.2. Модель протоколу SMTP

Події роботи SMTP протоколу:

  • Клієнт ініціює з'єднання із сервером

  • Клієнт посилає запити на обслуговування

  • Сервер відповідає на ці запити

Протокол POP3

Post Office Protocol (POP) - протокол доставки пошти користувачеві з його поштової скрині свого поштового сервера РОР. Коли пошта прийшла на сервер (по SMTP), вона розкладається по поштових скриньках. Щоб забрати пошту із скрині потрібний POP.

Перший стандарт РОРЗ визначений у RFC 1225 (Post Office Protocol-Version 3, J. Myers, M. Rose November 1994).

Остання версія RFC1939 (J. Myers, M. RoseMay1996 )

Порт за замовчуванням - 110.

Користувач може одержати доступ до Рор-серверу з будь-якої точки доступу до Інтернет.

Модель протоколу POP3:

Рис. 4.3. Модель протоколу POP

Принцип роботи POP

У протоколі РОРЗ обговорені три стадії процесу одержання пошти:

  • авторизація

  • транзакція

  • відновлення (завершення транзакції)

Після того як сервер і клієнт РОРЗ встановили з'єднання, починається стадія авторизації. На стадії авторизації клієнт ідентифікує себе для сервера. Якщо авторизація пройшла успішно, сервер відкриває поштову скриньку клієнта і починається стадія транзакції. У ній клієнт або запитує в сервера інформацію (наприклад, список поштових повідомлень), або просить його зробити визначену дію (наприклад, знищити поштове повідомлення). Нарешті, на стадії відновлення сеанс зв'язку закінчується.

Протокол IMAP

Протокол IMAP4 (Internet Message Access Protocol) дозволяє клієнтам одержувати доступ і маніпулювати повідомленнями електронної пошти на сервері. Був розроблений для заміни POP3.

Порт за замовчуванням - 143.

У відмінності від POP3 дозволяє клієнтові маніпулювати повідомленнями на сервері.

Перший прийнятий стандарт - RFC1730 (J. Myers December 1994)

Останній прийнятий стандарт - RFC3501 (VERSION4rev1M.CrispinMarch2003)

Принцип роботи IMAP

Кожна команда клієнта починається з ідентифікатора або тега команди, що складається з букв і цифр, (наприклад, А0001, А0002 і т.д.). Тег є унікальним ідентифікатором даної команди клієнта. Відповіді сервера або наступні команди клієнта можуть посилатися на дану команду по її тегу.

Стрічки даних, що передані із сервера у відповідь на команду клієнта, можуть не містити тег, а містити символ "*". Це означає, що вони є проміжними рядками потоку даних відповіді, а ідентифікатор їхньої команди утримується в останньому рядку потоку.

Взаємодія клієнта сервером не будується за принципом "запит-відповідь". Клієнт може відправити нову команду на сервер не чекаючи відповіді на попередню.

Формат повідомлення.

Перший стандарт - RFC0724 (Proposed official standard for the format of ARPA Network messages D. Crocker, K.T. Pogran, J. Vittal, D.A. Henderson May-12-1977).

Остання версія - RFC2822 (Internet Message Format P. Resnick,Ed.April2001)

Текстова (ASCII) інформація може передаватися такою, якою є. Інша інформація повинна бути закодована, тому що споконвічно не передбачалося її передавати. При використанні розширення протоколу SMTP - ESMTP (Enhaced SMTP) можна кодувати в 8-бітному вигляді. Це усе виконує поштова програма.

Види кодування:

base64 - кодує із набору 00-FFв ASCII, щоб можна було передавати по SMTP (кодують бінарні файли).

7bit - не кодує, вказує, що код ASCII.

8bit - вказує, що не тільки символи ASCII.

quoted-printable - використовується для кодування національних мов, символів другої частини таблиці ("А" - "=3D").

Повідомлення складається з:

  • конверта повідомлення (інформація для доставки й обробки повідомлення)

  • тіла повідомлення (дані відправника)

Приклади повідомлень:

From: <vasy@list.ru> // адреса відправника

To: <pety@kfti.knc.ru> // адреса одержувача

Subject: З новим роком! // тема повідомлення

Mime-Version: 1.0 // ініціалізація Mime

X-Mailer: mPOP Web-Mail 2.19 // тип і версія поштової програми клієнта

Date: Fri, 19 Sep 2003 08:37:43 +0400 // дата відправлення повідомлення

Reply-To: <vasy@list.ru> // адреса для відповіді

Content-Type: text/plain; charset=koi8-r // тип і підтип MIME

Content-Transfer-Encoding: 8bit // ідентифікатор типу кодування

Message-Id: <E1A0D1b-000AnC-00.vasy-list-ru@f15.mail.ru> // унікальний ідентифікатор повідомлення

З новим роком, Петре! //Тіло повідомлення

Приклад простого повідомлення

Деякі поля заголовка:

From - адреси відправників.

Sender - адреса реального відправника.

Приклад:

From: vasy@mail.ru

pety@mail.ru

Sender: misha@mail.ru

To - адреса одержувача.

Cc - адреси одержувачів копій повідомлень.

Приклад:

To: vasy@mail.ru

pety@mail.ru

Cc: misha@mail.ru, katy@mail.ru

Date - дата відправлення повідомлення.

Subject - тема повідомлення.

Message-ID - унікальний ідентифікатор повідомлення.

Reply-To - адреса для відповіді.

Received - адреси і час обробки повідомлення проміжним сервером.

X-Mailer - тип і версія поштової програми клієнта.

Comments - коментарі.

Priority - пріоритетність.

Organization - назва організації відправника

MIME-Version - поле для ідентифікації стандарту MIME, значить лист використовує MIME.

Content-Type - тип і підтип MIME (text/html,audio/midi).

Content-Transfer-Encoding - ідентифікатор типу кодування (base64, quoted-printable, 7bit, 8bit, binary і т.д.).

base64 - кодує з набору 00-FF в ASCII, щоб можна було передавати по SMTP (кодують бінарні файли).

7bit - не кодує, указує що код ASCII.

8bit - указує, що не тільки символи ASCII.

quoted-printable - використовується для кодування національних мов, символів другої частини таблиці ("А" - "=3D").