- •Засоби аналізу та управління мережами конспект лекцій
- •1Протокол управління мережами snmp
- •1.1Архітектури систем управління мережами
- •1.1.1Схема «менеджер ‒ агент»
- •1.1.2Структури розподілених систем управління
- •1.1.3Платформенний підхід
- •1.1.4Стандартизовані елементи системи управління
- •1.1.5Введення в snmp
- •1.1.6Стандарти систем управління на основі протоколу snmp
- •1.1.7Концепції snmp-управління
- •1.1.8Протокол мережного управління snmp
- •1.1.9Короткий опис база даних mib
- •1.1.10Керуюча база даних mib
- •1.1.11Формати і імена об'єктів snmp mib
- •1.1.12Специфікація rmon mib
- •1.1.13Проблеми безпеки протоколу snmp v1/2
- •Уразливість в стандартній конфіругаціі Windows nt snmp Сервісу.
- •Проблема в os Solaris версії до 2.6.
- •1.2Характеристика snmPv3
- •1.2.1Відмінності snmPv3
- •1.2.2Безпека в snmPv3
- •2Програмні засоби моделювання та аналізу мереж
- •2.1Cisco Packet Tracer - Знайомство з програмою. Інтерфейс
- •2.1.1Використання Cisco Packet Tracer
- •2.1.2Командний режим операційної системи ios
- •3Програмні засоби управління мережами
- •3.1Якість обслуговування в комп’ютерних мережах
- •3.2Служба QoS
- •3.3Функції і архітектура систем управління мережами
- •3.4Платформений підхід
- •3.5.1Історія Tivoli
- •3.5.2Програмні рішення ibm Tivoli для інтелектуального управління іт - інфраструктурою підприємств і організацій
- •3.5.3Технології ibm / Tivoli для бізнес-орієнтованого управління додатками і системами
- •3.5.4 Технології ibm / Tivoli для малих і середніх підприємств
- •3.5.5Інтелектуальне управляюче програмне забезпечення Tivoli
- •3.5.6Ефективність завдяки інтеграції
- •3.5.7Продуктивність завдяки автоматизації
- •3.5.8Оптимізація віддачі бізнесу
- •3.5.9Користувачі, бізнес-процеси та іт - ресурси
- •3.5.10 Переваги, пз і рішення Tivoli
- •3.5.12 Компоненти ibm Tivoli Monitoring
- •Навчальне видання
- •Засоби аналізу та управління мережами конспект лекцій
1.1.9Короткий опис база даних mib
Management Information Base (MIB, база керуючої інформації) - віртуальна база даних, яка використовується для управління об'єктами в мережі зв'язку. Найбільш часто це поняття пов'язують з Simple Network Management Protocol (SNMP), але також воно використовується в більш широкому сенсі - в контексті моделі управління мережі OSI / ISO. Хоча термін MIB призначений для позначення всієї доступної інформації про об'єкт, він також часто використовується для позначення конкретного підмножини, яке правильніше називати MIB-модулем.
Об'єкти в MIB, згідно RFC 2578, визначаються за допомогою підмножини "Structure of Management Information Version 2 (SMIv2)" стандарту ASN.1. Програмне забезпечення, що виконує розбір, називається MIB-компілятором.
База даних має ієрархічну (деревоподібну) структуру. До записів можна звернутися через ідентифікатори об'єктів (англ. object identifier, OID). Бази MIB обговорюються в документациях RFC, зокрема в RFC 1155 і супутніх йому RFC 1213 та RFC 1157.
MIB представляє з себе набір змінних, що характеризують стан об'єкта управління. Ці змінні можуть відображати такі параметри, як кількість пакетів, оброблених пристроєм, стан його інтерфейсів, час функціонування пристрою і т.п.
Кожен виробник мережевого устаткування, крім стандартних змінних, включає в MIB параметри, специфічні для даного пристрою. Однак, при цьому не порушується принцип подання та доступу до адміністративної інформації - всі вони будуть змінними в MIB.
Тому SNMP як безпосередньо мережевий протокол надає тільки набір команд для роботи зі змінними MIB. Цей набір включає наступні операції:
Таблиця 1. Набір команд для роботи зі змінними MIB
get-request |
Використовується для запиту одного або більше параметрів MIB |
get-next-request |
Використовується для послідовного читання значень. Зазвичай використовується для читання значень з таблиць. Після запиту першого рядка за допомогою отримати-запиту Get-Next-запиту використовують для читання залишилися рядків таблиці |
set-request |
Використовується для встановлення значення однієї або більше змінних MIB |
get-response |
Повертає відповідь на запит отримаєте-Request, Get-Next-запиту або набору-запиту |
trap |
Повідомну повідомлення про події типу холодного або теплого перезапуску або "падінні" деякого link'а. |
Для того, щоб проконтролювати роботу деякого пристрою мережі, необхідно просто отримати доступ до його MIB, яка постійно оновлюється самим пристроєм, і проаналізувати значення деяких змінних.
Важливою особливістю протоколу SNMP є те, що в ньому не містяться конкретні команди управління пристроєм. Замість визначення всього можливого спектру таких команд, безумовно загромоздив б сам протокол, який вважається все-таки простим, визначені перемінні MIB, перемикання яких сприймається пристроєм як вказівку виконати деяку команду.
Таким чином вдається зберегти простоту протоколу, але разом з цим зробити його досить потужним засобом, що дає можливість стандартним образом задавати набори команд управління мережевими пристроями. Завдання забезпечення виконання команд полягає, таким чином, в реєстрації спеціальних змінних MIB і реакції пристрою на їх зміни.
Як відбувається адресація в MIB до деякої її змінної?
За своєю структурою MIB представляє із себе дерево, зображене на рис. 5.
Рис. 5.
Кожному елементу відповідає чисельний і символьний ідентифікатор. В ім'я змінної включається повний шлях до неї від кореневого елемента кореня.
Наприклад, час роботи пристрою з моменту перезавантаження зберігається в змінної, що знаходиться в розділі системи під номером 3 і називається sysUpTime. Відповідно, ім'я змінної буде включати весь шлях: ...... ISO (1) організація (3) Міністерство оборони (6) Інтернет (1) Упр (2) MIB-2 (1) система (1) sysUpTime (3). , або на мові чисел: 1.3.6.1.2.1.1.3. Слід зауважити, що при цьому вузли дерева розділяються крапками.
Існує стандартна гілку MIB, що відноситься до розділу управління MGMT, яку зазвичай підтримують всі мережеві пристрої.
