- •Методические указания по проведению практических занятий и лабораторный практикум
- •Практические занятия Практическое занятие№1
- •1. Теоретическая часть
- •Повышение функциональности
- •2. Задания для самостоятельного выполнения
- •Лицензионное программное обеспечение имеет ряд преимуществ.
- •Техническая поддержка производителя программного обеспечения.
- •Обновление программ.
- •Законность и престиж.
- •В ногу с техническим прогрессом
- •Профессиональные предпродажные консультации
- •4. Содержание отчёта
- •5. Контрольные вопросы
- •Практическое занятие№2 Работа с запросами sql к удалённому серверу баз данных
- •1. Теоретическая часть
- •2. Методические указания
- •Практическое занятие№3 Изучение возможностей ActiveX для браузера Internet Explorer
- •2. Методические указания
- •Практическое занятие№4 Подключение различных расширений к современным браузерам
- •2. Методические указания
- •Практическое занятие№5 Проверка правильности отображения сайта в различных браузерах
- •Лабораторный практикум Лабораторная работа №1 Служебные утилиты для работы в Интернет. Изучение протокола http
- •1. Теоретическая часть
- •2. Методические указания
- •Ipconfig /ключи
- •1) Утилита ping
- •Утилита traceroute
- •3. Утилита netstat
- •4. Утилита telnet
- •3. Задания для практического выполнения
- •1. Просмотр сетевых настроек
- •4. Содержание отчёта
- •5. Контрольные вопросы
- •Лабораторная работа №2 Структура xml документа. Xml схемы
- •1. Теоретическая часть
- •2. Порядок выполнения лабораторной работы
- •3. Задания для практического выполнния
- •4. Содержание отчёта
- •5. Контрольные вопросы
- •Лабораторная работа №3 Программная обработка xml документов с помощью xml dom
- •1. Теоретическая часть
- •2. Порядок выполнения лабораторной работы
- •3. Задание для практического выполнения
- •4. Содержание отчёта
- •5. Контрольные вопросы
- •Лабораторная работа №4 Форматирование и преобразование xml документа с помощью xsl. Xslt преобразование xml документа
- •1. Теоретический материал
- •2. Порядок выполнения лабораторной работы
- •3. Задание для практического выполнния
- •4. Содержание отчёта
- •5. Контрольные вопросы
- •Лабораторная работа №5. Введение в JavaScript. Программное взаимодействие с html документами на основе dom api
- •1. Теоретическая часть
- •2. Практическая часть
- •3. Задания для практического выполнения
- •4. Содержание отчёта
- •5. Контрольные вопросы
- •Лабораторная работа №6 Клиентские сценарии. Использование регулярных выражений
- •1. Теоретический материал
- •3. Порядок выполнения практической части
- •Лабораторная работа №7 Использование языка JavaScript для работы с формами html
- •Лабораторная работа №8 Использование JavaScript для создания динамического html
- •2. Пример выполнения практической части
- •Лабораторная работа №9 Функции JavaScript. Создание простейшего меню
- •2. Пример выполнения практической части
- •Лабораторная работа №10. Работа с данными и переменными. Арифметические и логические операции. Условные команды
- •2. Порядок выполнения практической части
- •3. Задание для практического выполнения
- •4. Содержание отчёта
- •5. Контрольные вопросы
Лабораторный практикум Лабораторная работа №1 Служебные утилиты для работы в Интернет. Изучение протокола http
Цель работы: изучение структуры IP-адреса; ознакомление с наиболее популярными утилитами для диагностики сетевой конфигурации и сетевых соединений; ознакомление с основами протокола HTTP.
1. Теоретическая часть
IP-адрес состоит из двух частей: номера сети и номера узла в сети.
Самой распространенной является запись IP-адреса в виде четырех чисел, разделенных точками, каждое из которых представляет значение байта в десятичной форме, например: 213.180.204.11. Запись адреса не предусматривает специального разграничительного знака между номером сети и номером узла.
Для разделения этих частей обычно используется 2 подхода:
С помощью маски (RFC 950, RFC 1518), представляющей собой число в паре с IP-адресом. С помощью операции «логическое И» над этими двумя числами выделяется номер сети.
С помощью классов адресов (RFC 791).
Вводится пять классов адресов: A,B,C,D,E.
A,B,C – используются для адресации сетей, D и E – имеют специальное назначение. Признаком, на основании которого IP-адрес относят к тому или иному классу, являются значения нескольких первых битов адреса.
Таблица 4 – Распределение адресов в IP сетях.
В рамках IP протокола существуют ограничения при назначении IP-адресов, а именно
номера сетей и номера узлов не могут состоять из двоичных нулей или единиц;
eсли IP-адрес состоит только из двоичных нулей, то он называется неопределенным адресом и обозначает адрес того узла, который сгенерировал этот пакет;
eсли в поле номера сети стоят только нули, то по умолчанию считается, что узел назначения принадлежит той же самой сети, что и узел, который отправил пакет; такой адрес может быть использован только в качестве адреса отправителя;
если все двоичные разряды IP-адреса равны 1, то пакет с таким адресом назначения должен рассылаться всем узлам, находящимся в той же сети, что и источник этого пакета; такой адрес называется ограниченным широковещательным, поскольку пакет не сможет выйти за границы сети;
если в поле адреса назначения в разрядах, соответствующих номеру узла, стоят только единицы, то пакет рассылается всем узлам сети, номер которой указан в адресе назначения; такой тип адреса называется широковещательным;
если первый октет адреса равен 127, то такой адрес называется внутренним адресом стека протоколов; он используется для тестирования программ, организации клиентской и серверной частей приложений, установленных на одном компьютере;
групповые адреса, относящиеся к классу D, предназначены для экономичного распространения в Интернете, большой корпоративной сети аудио- или видеопрограмм.
Стандартным классам сетей можно поставить в соответствие следующие значения маски:
класс A – 255.0.0.0;
класс B – 255.255.0.0;
класс C – 255.255.255.0;
Рассмотрим следующий пример:
Исходные данные |
IP адрес |
62.76.167.21 |
Маска сети |
255.255.255.0 |
|
Логическая операция |
И |
|
Результат |
Адрес сети |
62.76.167.0 |
Номер компьютера |
21 |
|
