- •«Томский политехнический университет»
- •Е.С. Чердынцев мультимедийные сети
- •Глава 1. Введение в мультимедиа
- •1.1. Классификация мультимедиа
- •1.2. Текст
- •1.3. Звук
- •1.4. Графика и анимация
- •1.6.1. Характеристики реального времени (ограничения на задержки и нестабильность)
- •1.5. Видео
- •1.6. Требования к передаче мультимедиа по сетям
- •1.6.2. Требование высокой пропускной способности
- •1.6.3. Требования к ошибкам
- •1.6.4. Поддержка мультикаста
- •1.6.5. Управление сессиями
- •1.6.6. Безопасность
- •1.6.7. Поддержка мобильности
- •Глава 2. Поддержка распределенного мультимедиа трафика в Интернете
- •2.1. Поддержка трафика реального времени в Интернете
- •2.1.1. Задержки при обработке пакетов
- •2.1.2. Задержки при передаче пакетов
- •2.1.3. Задержка передачи
- •2.1.4. Задержки маршрутизации и обработки очередей
- •2.2. Требование высокой пропускной способности
- •2.3. Ошибки характеристик сети
- •2.4. Предлагаемые модели сервисов Интернет
- •2.4.1. Уточнение требований к сервисам и описанию трафика
- •2.4.2. Управление доступом
- •2.4.3. Управление трафиком
- •2.4.4. Классификация пакетов
- •2.4.5. Планирование пакетов
- •2.4.6. Потеря пакетов
- •2.4.7. Маршрутизация на основе QoS
- •2.5. Интегрированные сервисы
- •2.5.1. Классы гарантированного обслуживания
- •2.5.2. Сервис управления загрузкой
- •2.5.3. Сервис негарантированной доставки
- •2.5.4. Недостатки модели Intserv для Интернета
- •2.6. Дифферецированный сервис
- •2.6.1. Per Hop Behavior
- •2.7. Мультипротокольная коммутация по меткам
- •Глава 3. Расширение стека протоколов tcp/ip для поддержки функциональных требований распределенных мультимедийных приложений
- •3.1. Поддержка мультикаста
- •3.2. Управление сессиями
- •3.3. Безопасность
- •3.4. Мобильность
- •3.6. Session Initiation Protocol
- •Глава 4. Введение в rtp
- •4.1. Базовые принципы rtp
- •4.2. Стандартные элементы rtp
- •4.3. Связанные с rtp стандарты
- •Глава 5. Описание протокола rtp
- •5.1. Сессии rtp
- •5.2. Структура пакета rtp
- •5.3. Проверка качества пакета
- •5.4. Трансляторы и миксеры
- •Глава 6. Описание протокола rtсp
- •6.1. Компоненты rtcp
- •6.2. Передача пакетов rtcp
- •6.3. Формат пакетов rtcp
- •6.4. Безопасность и конфиденциальность
- •6.5. Проверка корректности данных
- •6.6. База данных участников сессии
- •6.7. Управление характеристиками времени
- •6.7.1. Отчетные интервалы
- •6.7.2. Базовые правила передачи
- •6.7.3. Процедура пересмотра вперед
- •6.7.4. Процедура пересмотра назад
- •6.7.5. Пересмотр пакетов bye
- •6.7.6. Общие проблемы реализации
- •Глава 7. Захват мультимедиа, проигрывание и управление характеристиками времени
- •7.1. Поведение отправителя
- •7.2. Захват мультимедиа и сжатие
- •7.2.1. Захват и сжатие звука
- •7.2.2. Захват и сжатие изображения
- •7.2.3. Использование предварительно записанной информации
- •7.3. Генерация пакетов rtp
- •7.3.1. Метки времени и модель времени rtp
- •7.3.2. Фрагментация
- •7.3.3. Заголовки, зависящие от формата данных
- •7.4. Поведение получателя
- •7.5. Получение пакетов
- •7.5.1. Получение пакетов данных
- •7.5.2. Получение управляющих пакетов
- •7.6. Буфер проигрывания
- •7.7. Декодирование, смешивание и проигрывание
- •7.7.1. Декодирование
- •7.7.2. Смешивание звука
- •Глава 8. Синхронизация звука и изображения
- •8.1. Поведение отправителя
- •8.2. Поведение получателя
- •8.3. Точность синхронизации
- •Глава 9. Компенсация ошибок
- •9.1. Компенсация потерь звука
- •9.1.1. Измерение качества звука
- •9.1.2. Замещение периодами тишины
- •9.1.3. Замещение шума
- •Глава 10. Исправление ошибок
- •10.1. Прямое исправление ошибок
- •Глава 11. Контроль перегрузок
- •11.1. Необходимость контроля перегрузок
- •10.1.1. Контроль четности
- •References
- •Multimedia networks
- •Published in author’s version
References
A. Leon-Garcia and I. Widjaja, Communication Networks: Fundamental Concepts and Key Architectures, McGraw-Hill, 2000.
J. Leigh, O. Yu, D. Schonfeld, R. Ansari, et. al., “Adaptive networking for tele-immersion”, Proc. Immersive Projection Technology/Eurographics Virtual Environments Workshop (IPT/EGVE), Stuttgart, Germany, 2001.
D. Salomon, Data Compression: The Complete Reference, Springer, 1998.
V.K. Garg, IS-95 CDMA and cdma2000, Prentice Hall, 1999.
W. Kinsner, "Compression and its metrics for multimedia", Proceedings of First IEEE International Conference on Cognitive Informatics, 2002, pp: 107-121.
J. Watkinson, The MPEG Handbook: MPEG-I, MPEG-II, MPEGIV, Focal Press, 2001.
L.C. Wolf, C. Griwodz and R. Steinmetz, "Multimedia Communication", Proceedings of the IEEE, vol: 85(12), December 1997.
J. Kurose and K. Ross, Computer Networking: A top-down approach featuring the Internet, Addision Wesley, 2001.
G. Kessler, “An overview of cryptography”, online version available at http://www.garykessler.net/library/crypto.html
J. Su, F. Hartung, and B. Girod, "Digital Watermarking of Text, Image, and Video Documents", Computers & Graphics, vol: 22 (6), pp: 687 - 695, February 1999.
B. P. Crow, I. Widjaja, J.G. Kim, P.T. Sakai, "IEEE 802.11: Wireless Local Area Networks", IEEE Communications Magazine, September 1997.
D. Bertsekas and R. Gallager, Data Networks, Prentice Hall, 1987.
R. Steinmetz, "Analyzing the multimedia operating system", IEEE Multimedia, vol: 2(1), Spring 1995, pp: 68-84
Yu, O. and Khanvilkar, S., “Dynamic Adaptive Guaranteed QoS Provisioning over GPRS Wireless Mobile Links”, ICC2002, vol: 2, pp: 1100-1104.
L.C. Wolf, C. Griwodz and R. Steinmetz, "Multimedia Communication", Proceedings of the IEEE, vol: 85(12), December 1997.
B. Furht, “Real-time issues in distributed multimedia systems”, Proceedings of the Second Workshop on Parallel and Distributed Real-Time Systems, April 1994, pp: 88-97.
N. Tang, S. Tsui and L. Wang, "A Survey of Admission Control Algorithms", on-line report available at http://www.cs.ucla.edu/~tang/
A. Tanenbaum, Computer Networks, 3e, Prentice Hall, 1996.
M. Labrador and S. Banerjee, “Packet Dropping policies for ATM and IP networks”, IEEE communication surveys, 3rd Quarter 1999, vol: 2(3).
W. Sun and R. Jain, “QoS/policy/constraint based routing”, Class report avail. on-line at ftp://ftp.netlab.ohio-state.edu/pub/jain/courses/cis788-99/qos_routing/index.html.
Z. Avramovic, “Policy based routing in the Defense Information System Network”, IEEE Military Communications Conference, vol: 3, pp: 1210-1214.
F. Kuipers, P.V. Mieghem, T. Korkmaz and M. Krunz, "An Overview of Constraint-Based Path Selection Algorithms for QoS Routing", IEEE Communications Magazine, December 2002.
P. P. White, “RSVP and integrated services in the Internet: a tutorial”, IEEE Communications Magazine, vol: 35(5), May 1997, pp: 100-106.
R. Braden, L. Zhang, S. Berson, S. Herzog and S. Jamin, "Resource ReSerVation Protocol (RSVP): Version 1 Functional Specification", RFC2205, September 1997.
D. Schonfeld, “Image and Video Communication Networks”, (Invited Chapter). Handbook of Image and Video Processing. A. Bovik (ed.), Academic Press: San Diego, California, Chapter 9.3, pp. 717-732, 2000.
E. Rosen, A. Viswanathan, R. Callon, “Multiprotocol Label Switching Architecture”, RFC3031, January 2001.
M. Banikazemi, R. Jain, "IP Multicasting: Concepts, Algorithms, and Protocols", Class report avail. on-line at http://ftp.netlab.ohio-state.edu/pub/jain/courses/cis788-97/ip_multicast/index.htm
] L.H. Sahasrabuddhe and B.M. Mukherjee, "Multicast Routing Algorithms and Protocols: A Tutorial", IEEE Network, January/February 2000.
A. Striegel and G. Manimaran, "A Survey of QoS Multicasting Issues", IEEE Communications Magazine, June 2002.
M. Handley and V. Jacobson, “SDP: Session Description Protocol”, RFC2327, April 1998.
A.B. Johnston, Understanding the Session Initiation Protocol, Artech House, 2000.
M. Handley, C. Perkins and E. Whelan, “Session Announcement Protocol”, RFC2974, October 2000.
R. Arora, R. Jain, "Voice over IP : Protocols and Standards", Class report avail. on-line at ftp://ftp.netlab.ohio-state.edu/pub/jain/courses/cis788-99/voip_protocols/index.html
B. Cavusoglu, D. Schonfeld, and R. Ansari, “Real-time adaptive forward error correction for MPEG-2 video communications over RTP networks”, Proceedings of the IEEE International Conference on Multimedia and Expo, Baltimore, Maryland, 2003, to appear.
H. Schulzrinne, A. Rao and R. Lanphier, "Real Time Streaming Protocol (RTSP)", RFC2326, April 1998.
E. Mulabegovic, D. Schonfeld, and R. Ansari, “Lightweight Streaming Protocol (LSP)”, ACM Multimedia Conference, Juan Les Pins, France, 2002.
S. Kent and R. Atkinson, "Security Architecture for the Internet Protocol", RFC2401, November 1998.
R. Oppliger, “Security at the Internet Layer”, Computer, vol: 31(9), September 1998.
C.E. Perkins, “Mobile networking through Mobile IP”, IEEE Internet Computing, vol: 2(1) Jan/Feb 1998, pp: 58-69.
G.A. Thom, "H.323: the multimedia communications standard for local area networks", IEEE Communications Magazine , vol: 34(12), December 1996, pp: 52-56.
H. Liu and P. Mouchtaris, "Voice over IP Signaling: H.323 and Beyond", IEEE Communications Magazine, October 2000.
D. D. Clark and D. L. Tennenhouse. "Architectural Considerations for a New Generation of Protocols," Proceedings of the SIGCOMM Symposium on Communications Architectures and Protocols, Computer Communications Review, Volume 20, Number 4, September 1990.
J. H. Saltzer, D. P. Reed, and D. D. Clark. "End-to-End Arguments in System Design," ACM Transactions on Computer Systems, Volume 2, Number 4, November 1984.
M. Handley, J. Crowcroft, C. Bormann, and J. Ott. "Very Large Conferences on the Internet: The Internet Multimedia Conferencing Architecture," Journal of Computer Networks and ISDN Systems, Volume 31, Number 3, February 1999.
H. Schulzrinne, S. Casner, R. Frederick, and V. Jacobson. "RTP: A Transport Protocol for Real-Time Applications," Internet Engineering Task Force, RFC 1889, January 1996.
H. Schulzrinne, S. Casner, R. Frederick, and V. Jacobson. "RTP: A Transport Protocol for Real-Time Applications," Internet Engineering Task Force, Work in Progress (Update to RFC 1889), March 2003.
M. Handley and V. Jacobson. "SDP: Session Description Protocol," Internet Engineering Task Force, RFC 2327, April 1998.
H. Schulzrinne. "RTP Profile for Audio and Video Conferences with Minimal Control," Internet Engineering Task Force, RFC 1890, January 1996.
H. Schulzrinne and S. Casner. "RTP Profile for Audio and Video Conferences with Minimal Control," Internet Engineering Task Force, Work in Progress (Update to RFC 1890), March 2003.
M. Baugher, D. McGrew, D. Oran, R. Blom, E. Carrara, M. Naslund, and K. Norrman. "The Secure Real Time Transport Protocol," Internet Engineering Task Force, Work in Progress, June 2002.
J. Ott, S. Wenger, N. Sato, C. Burmeister, and J. Rey. "Extended RTP Profile for RTCP-Based Feedback (RTP/AVPF)," Internet Engineering Task Force, Work in Progress, February 2003.
P. Luthi. "RTP Payload Format for ITU-T Recommendation G.722.1," Internet Engineering Task Force, RFC 3047, January 2001.
K. McKay. "RTP Payload Format for PureVoice Audio," Internet Engineering Task Force, RFC 2658, August 1999.
H. Schulzrinne and S. Petrack. "RTP Payload for DTMF Digits, Telephony Tones and Telephony Signals," Internet Engineering Task Force, RFC 2833, May 2000.
R. Finlayson. "A More Loss-Tolerant RTP Payload Format for MP3 Audio," Internet Engineering Task Force, RFC 3119, June 2001.
T. Turletti and C. Huitama. "RTP Payload Format for H.261 Video Streams," Internet Engineering Task Force, RFC 2032, October 1996.
D. Hoffman, G. Fernando, V. Goyal, and M. Civanlar. "RTP Payload Format for MPEG1/MPEG2 Video," Internet Engineering Task Force, RFC 2250, January 1998.
C. Bormann, L. Cline, G. Deisher, T. Gardos, C. Maciocco, D. Newell, J. Ott, G. Sullivan, S. Wenger, and C. Zhu. "RTP Payload Format for the 1998 Version of ITU-T Rec. H.263 Video (H.263+)," Internet Engineering Task Force, RFC 2429, October 1998.
C. Perkins, I. Kouvelas, O. Hodson, V. Hardman, M. Handley, J. C. Bolot, A. Vega-Garcia, and S. Fosse-Parisis. "RTP Payload for Redundant Audio Data," Internet Engineering Task Force, RFC 2198, September 1997.
J. Rosenberg and H. Schulzrinne. "An RTP Payload Format for Generic Forward Error Correction," Internet Engineering Task Force, RFC 2733, December 1999.
Educational Edition
Cherdyntsev Evgeny Sergeevich
