Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
Лабораторная работа № 9.doc
Скачиваний:
4
Добавлен:
01.07.2025
Размер:
1 Мб
Скачать
☆

Техническая информация о протоколе

SSH-сервер обычно прослушивает соединения на TCP-порту 22. Спецификация протокола SSH-2 содержится в RFC+4251. Для аутентификации сервера в SSH используется протокол аутентификации сторон на основе алгоритмов электронно-цифровой подписи RSA или DSA.Для аутентификации клиента также может использоваться ЭЦП RSA или DSA, но допускается также аутентификация с помощью пароля (режим обратной совместимости с Telnet) и даже ip-адреса хоста (режим обратной совместимости с rlogin). Аутентификация по паролю наиболее распространена, она безопасна, так как пароль передается по зашифрованному виртуального канала. Аутентификация по ip-адресу опасна, эту возможность чаще отключают. Для создания общего секрета (сеансового ключа) используется алгоритм Диффи - Хеллмана (DH). Для шифрования передаваемых данных используется симметричное шифрование, алгоритмы AES, Blowfish или 3DES. Целостность передаваемых данных проверяется с помощью CRC32 в SSH1 или HMAC-SHA1 / HMAC-MD5 в SSH2.

Для сжатия шифрующих данных может использоваться алгоритм LempelZiv (LZ77), который обеспечивает такой же уровень сжатия, и архиватор ZIP. Сжатие SSH включается только по запросу клиента, и на практике используется редко. [Править] См также b Защита конфиденциальных данных и анонимность в интернете в Викиучебник?

SFTP

SCP

SSL

TLS

Стандарты

RFC +4250 (англ.) - The Secure Shell (SSH) Protocol Assigned Numbers

RFC 4251 (англ.) - The Secure Shell (SSH) Protocol Architecture

RFC +4252 (англ.) - The Secure Shell (SSH) Authentication Protocol

RFC +4253 (англ.) - The Secure Shell (SSH) Transport Layer Protocol

RFC +4254 (англ.) - The Secure Shell (SSH) Connection Protocol

RFC +4255 (англ.) - Using DNS to Securely Publish Secure Shell (SSH) Key Fingerprints

RFC +4256 (англ.) - Generic Message Exchange Authentication for the Secure Shell Protocol (SSH)

RFC 4335 (англ.) - The Secure Shell (SSH) Session Channel Break Extension

RFC 4344 (англ.) - The Secure Shell (SSH) Transport Layer Encryption Modes

RFC +4345 (англ.) - Improved Arcfour Modes for the Secure Shell (SSH) Transport Layer Protocol

RFC +4419 (англ.) - Diffie-Hellman Group Exchange for the Secure Shell (SSH) Transport Layer Protocol

RFC +4432 (англ.) - RSA Key Exchange for the Secure Shell (SSH) Transport Layer Protocol

RFC 4716 (англ.) - The Secure Shell (SSH) Public Key File Format

SSH-клиенты

OpenSSH - свободная библиотека и набор утилит для шифрования

PuTTY - популярный кроссплатформенный SSH-клиент

Сравнение SSH-клиентов (англ.)

MidpSSH (англ.) - SSH-клиент для мобильных телефонов

Программы доступа к файлам

FTP Commander Deluxe - программа поддерживает все безопасные протоколы

WinSCP - SFTP-клиент для Microsoft Windows

SftpDrive - SFTP-клиент для Microsoft Windows

SSH Filesystem - позволяет подключить директорию, доступную на удаленной машине по ssh, как локальную директорию в GNU / Linux

История развитие

SSH обычно используется для входа на удаленную машину и выполнять команды, но он также поддерживает туннельный протокол, портовое экспедирование TCP и UDP порт | TCP порты. он может передавать файлы с помощью соответствующих SSH File Transfer Protocol | SSH File Transfer (SFTP) или Secure Copy (SCP) протоколов SSH использует клиент-сервер модель.

SSH программа обычно используется для подключения принятия отдаленных подключений. И то и другое обычно присутствует на большинстве современныхоперационных систем, включая Mac OS, большинство распределений GNU / Linux, OpenBSD, FreeBSD, [[NetBSD]], Solaris и OpenVMS. Известно, что Windowsявляется одним из немногих современных / серверных операционных систем, которые не включают SSH по умолчанию.

SSH играет важную роль в вычислений для решения проблем с подключением, избегая вопросов безопасности, подвергая виртуальную машину непосредственно к Интернету. Туннель SSH может обеспечить безопасный путь через Интернет, через брандмауэр на виртуальной машине. [2]