- •Устройство
- •Структура команд Telnet
- •Применение
- •Безопасность
- •Telnet и другие протоколы
- •Принцип работы протокола Rlogin Установка связи
- •Завершение соединения
- •Безопасность
- •Стандарты и программные реализации
- •Техника безопасности использования ssh
- •Примеры использования ssh
- •Техническая информация о протоколе
- •История развитие
- •Версия 1.X
- •Известны уязвимости
- •Версия 1.99
- •Версия 2.X
- •Уязвимости
- •Передача файлов с использованием ssh
- •Улучшение
- •Лабораторное задание
- •Часть 1
- •3 Настройка доступа по Telnet
- •4 Настройка по протоколу ssh
Передача файлов с использованием ssh
Есть несколько механизмов передачи файлов с помощью защищенных протоколов Shell.
Secure Copy (SCP), который произошел от RCP Протокол по SSH
Rsync, должен быть более эффективным, чем SCP
SSH File Transfer Protocol (SFTP), безопасная альтернатива FTP (не путать с FTP через SSH)
Файлы передаются по протоколу оболочки (так называемый FISH), выпущенный в 1998 году, который превратился из Unix Shell команды через SSH
SSH-2 протокол имеет внутреннюю архитектуру (определено в RFC 4251) с четко разделенными слоями. К ним относятся:
Транспортный слой (RFC +4253). Этот слой обрабатывает начальный обмен ключами, проверку подлинности сервер, устанавливает шифрование, сжатие и проверку целостности данных. Он предоставляет в высший слой интерфейс для отправки и получения текстовых пакетов размером до 32768 байт каждый (этот размер может быть увеличен в определенной реализации). Транспортный уровень также организует повторный обмен ключами. Как правило, это происходит после передачи 1 Гб данных или когда прошла 1:00, что быстрее наступит.
Слой аутентификации пользователя (RFC 4252). Этот слой обрабатывает проверку подлинности клиента и предоставляет ряд методов аутентификации.Аутентификация является клиенто-ориентированной: когда пользователь получает запрос на ввод пароля, то это может быть запрос SSH клиента, а не сервера. Сервер просто отвечает на запросы клиента о подлинности. Широко применяемые методы аутентификации пользователей включают следующее:
Пароль: Метод простой пароль аутентификации, в том числе средство, позволяющее пароль, чтобы быть изменены. Этот метод не реализован всеми программами.
с открытым ключом: метод открытого ключа проверки подлинности на основе, как правило, поддерживают по крайней мере, DSA или RSAпары ключей, с другими реализациями также поддерживает X.509 сертификаты.
Интерактивный (RFC +4256): универсальный метод, когда сервер отправляет один или несколько запросов ввода информации и клиент отражает их и отправляет обратно ответ введены в пользователем. Используется для обеспечения одноразовый пароль аутентификации, такие какS / Key или SecurID. Используется некоторых конфигурациях OpenSSH, когда PAM является основным поставщиком хост аутентификации для обеспечения эффективной аутентификации по паролю, что иногда приводит к неспособности войти в систему с клиентом, который поддерживает только простые пароль метод проверки подлинности.
GSSAPI методы аутентификации, которые обеспечивают расширяемой схемы для выполнения SSH аутентификации с использованием внешних устройств, таких как Kerberos 5 или NTLM, обеспечивая [[Single Sign On]] Возможность SSH сессий. Эти методы, как правило, осуществляются коммерческими реализациями SSH для использования в организациях, хотя OpenSSH действительно рабочая реализации GSSAPI.
Соединения слоев (RFC 4254). Этот слой определяет понятие каналы, канал запросы и глобальный запросов с помощью которой SSH услуги. Одно соединение SSH можно разместить несколько каналов одновременно, каждая передача данных в обоих направлениях. Канал запросы используются для релейный выход за полосу канала конкретные данные, такие, как изменился размер окна терминала или код выхода из серверного процесса. SSH клиент запрашивает сервер на стороне порта, который будет направляться с использованием глобальной запросу. Стандартные типы каналов включают в себя:
Оболочка для терминала, SFTP и Exec запросов (в том числе SCP трансфертов)
Прямой TCP / IP для клиент-сервер передаются соединение
Направленный-TCP / IP для сервер-клиент направляется соединений
SSHFP DNS-запись (RFC четыре тысячи двести пятьдесят-пять) предоставляет общественности отпечатки пальцев ключа хоста для того, чтобы помочь в проверке достоверности хозяина.
Это открытая архитектура обеспечивает значительную гибкость, позволяя SSH, который будет использоваться для различных целей, кроме безопасной оболочки. Функциональность транспортного уровня только сравнима с Transport Layer Security (TLS) слой аутентификации пользователей весьма расширяемой с помощью пользовательских методов аутентификации и соединения слоев обеспечивает возможность мультиплексирования многих средних сессий в одно соединение SSH, функция сравнима с BEEP и не доступны в TLS.
