Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
PROTOKOLY.docx
Скачиваний:
0
Добавлен:
01.07.2025
Размер:
62 Кб
Скачать
☆

Представления

ASN.1  — это язык для описания абстрактного синтаксиса данных, используемый OSI. Стандарт записи, описывающий структуры данных для представления, кодирования, передачи и декодирования данных. RFC 3727.

XML-RPC — протокол вызова удалённых процедур, использующий XML для кодирования своих сообщений и HTTP в качестве транспортного механизма. Создан в 1998 году.

XDR — международный стандарт передачи данных в Интернете. XDR — это стандарт IETF с 1995 г. Он позволяет данным быть упакованными независящим от архитектуры, таким образом, данные могут передаваться между гетерогенными компьютерными системами. RFC 4506.

AFP — протокол сетевой модели OSI, предоставляющий доступ к файлам в MacOSX. Он поддерживает Юникод-совместимые имена файлов, ограничения файлов POSIX и ACL.

ICA — закрытый протокол для сервера приложений. Разработан компанией CitrixSystems. Протокол определяет спецификацию обмена данными между сервером и клиентом. Использует порт TCP 1494.

NCP — протокол, который используется в некоторых продуктах от Novell, является надстройкой над протоколом IPX или TCP/IP и используется для организации обмена между рабочей станцией и файловым сервером. NCP связан и используется в операционной системе NetWare, но его части были реализованы на другие платформы, такие как Linux, Windows NT и Unix. RFC 460.

Lightwheight Presentation Protocol – используется для представления услуг презентации ISO поверх стеков протоколов на основе протокола TCP/IP. RFC 1085

Сеансовый AppleTalk — стек протоколов, разработанных AppleComputer для компьютерной сети. Он был изначально включён в Macintosh (1984), но потом компания отказалась от него в пользу TCP/IP. Первый протокол сеансового уровня называется протоколом потоков данных (AppleTalkDataStreamProtocol — ADSP). Протокол ADSP предоставляет полностью дуплексные услуги, ориентированные на установление соединения и характеризующиеся высокой степенью надёжности. Создан в 1984 году.

H.245 — протокол согласования параметров соединения, используется например в H.323 или H.324 сеансе связи. Канал контроля, работающий по стандарту H.245, служит для выявления понимаемого обеими сторонами набора функций, для управления работой логических каналов и некоторых общих сообщений. В каждом сеансе связи существует один и только один канал H.245.

InternetStorageNameService (iSNS) (Служба имён хранилищ Интернета) — сетевой протокол, позволяющий автоматизировать открытие, управление и конфигурирование ISCSI и FibreChannel устройств (с использованием iFCP шлюзов) в TCP/IP сетях. Протокол iSNS описывается в RFC 4171.iSNS предоставляет управление сервисами аналогично тем, которые имеются в семействе FibreChannel, что позволяет для стандартной IP сети работать во многом таким же образом, как работает в FibreChannel сеть хранения данных.

NetBIOS (NetworkBasicInput/OutputSystem) — протокол для работы в локальных сетях на персональных ЭВМ типа IBM/PC, разработан в виде интерфейса, который не зависит от фирмы-производителя. Был разработан фирмой SytekCorporation по заказу IBM в 1983 году. Он включает в себя интерфейс сеансового уровня (англ. NetBIOSinterface), в качестве транспортных протоколов использует TCP и UDP.ОсобенностьюNetBIOS является возможность его работы поверх разных протоколов, самыми распространёнными/известными из которых являются NetBEUI, IPX и стек протоколов TCP/IP; причём если старые версии Windows ориентировались на более лёгкие в реализации и менее ресурсоёмкие NetBEUI и IPX, то современные Windows ориентируются на TCP/IP. RFC 1001.

PPTP (Point-to-PointTunnelingProtocol) — туннельный протокол типа точка-точка, позволяющий компьютеру устанавливать защищённое соединение с сервером за счёт создания специального туннеля в стандартной, незащищённой сети. PPTP помещает (инкапсулирует) кадры PPP в IP-пакеты для передачи по глобальной IP-сети, например Интернет. PPTP может также использоваться для организации туннеля между двумя локальными сетями. РРТР использует дополнительное TCP-соединение для обслуживания туннеля. Спецификация протокола была опубликована как «информационная» RFC 2637 в 1999 году.

RPC (RemoteProcedureCall, RPC) — класс технологий, позволяющих компьютерным программамвызывать функции или процедуры в другом адресном пространстве (как правило, на удалённых компьютерах). Обычно реализация RPC технологии включает в себя два компонента: сетевой протокол для обмена в режиме клиент-сервер и язык сериализации объектов (или структур, для необъектных RPC). RFC 1831.

SMPP — (ShortMessagePeer-to-Peer) короткие сообщения одноранговой Сети. Является открытым стандартом в телекоммуникационной отрасли, который разработан специально, чтобы обеспечить гибкий интерфейс для передачи коротких сообщений между внешними сущностями (устройства, приложения) коротких сообщений (ESME), маршрутизаторами и центров сообщений (SMSC). SMPP использует модель работы клиент-сервер. Центр сообщений (SMSC), как правило, выступает в качестве сервера, ожидая подключения от клиента — ESME. Когда SMPP используется для SMS пиринга, отправляющий MC обычно выступает в качестве клиента.

SSL (SecureSocketsLayer — уровень защищённых cокетов) — криптографический протокол, который подразумевает более безопасную связь. Он использует асимметричную криптографию для аутентификации ключей обмена, симметричное шифрование для сохранения конфиденциальности, коды аутентификации сообщений для целостности сообщений. Протокол широко использовался для обмена мгновенными сообщениями и передачи голоса через IP (англ. VoiceoverIP — VoIP) в таких приложениях, как электронная почта, интернет-факс и др. RFC 6101.