Сетевойуровень
Internet Protocol (IP, досл. «межсетевойпротокол») — маршрутизируемый протокол сетевогоуровня стека TCP/IP. Именно IP стал тем протоколом, который объединил отдельные компьютерные сети во всемирную сеть Интернет. Неотъемлемой частью протокола является адресация сети. Создан в 1981 году. RFC 791. IP объединяет сегменты сети в единую сеть, обеспечивая доставку пакетов данных между любыми узлами сети через произвольное число промежуточных узлов (маршрутизаторов). Он классифицируется как протокол сетевого уровня по сетевой модели OSI.
IPv4 (InternetProtocolversion 4) — четвёртая версия интернет протокола (IP). Первая широко используемая версия. Протокол описан в RFC 791 (сентябрь 1981 года), заменившем RFC 760 (январь 1980 года). IPv4 использует 32-битные (четырёхбайтные) адреса, ограничивающие адресное пространство 4 294 967 296 (232) возможными уникальными адресами.Традиционной формой записи IPv4 адреса является запись в виде четырёх десятичных чисел (от 0 до 255), разделённых точками. Через дробь указывается длина маски подсети.
IPv6 (InternetProtocolversion 6) — новая версия протокола IP, призванная решить проблемы, с которыми столкнулась предыдущая версия (IPv4) при её использовании в Интернете, за счёт использования длины адреса 128 бит вместо 32. Протокол был разработан IETF. Создан в 1996 году. RFC 2460.
NAT (NetworkAddressTranslation — «преобразование сетевых адресов») — это механизм в сетях TCP/IP, позволяющий преобразовывать IP-адреса транзитных пакетов. Такжеимеетназвания IP Masquerading, Network Masquerading и Native Address Translation. Преобразование адреса методом NAT может производиться почти любым маршрутизирующим устройством — маршрутизатором, сервером доступа, межсетевым экраном.RFC 2663.
Трансляция порт-адрес (Portaddresstranslation, PAT) — технология трансляции сетевого адреса в зависимости от TCP/UDP-порта получателя. Является частным случаем NAT. Также может использоваться термин DNAT (Destination NAT).
IPX (internetwork packetexchange — межсетевой обмен пакетами) — протокол сетевого уровня модели OSI в стеке протоколов IPX/SPX. Предназначен для передачи датаграмм. Для передачи данных установки соединения не требуется (так же, как для IP и NetBIOS). Обеспечивает связь между серверами с сетевой операционной системы NetWare и конечными станциями.RFC 1792.
CLNP — бесконтактныйсетевойпротокол (Connection Less Network Protocol).
CLNP — это дейтаграммный протокол педачи данных, функционально очень похожий на протокол IP, используемый в интернете. В протоколе CLNP нет средств определения и исправления ошибок (эти функции возлагаются на транспортный уровень). Протокол CLNP не требует, чтобы канал связи был установлен перед передачей данных. CLNP отправляет сообщения их адресатам независимо от любых других сообщений. Iso 8473.
IPsec (сокращение от IP Security) — набор протоколов для обеспечения защиты данных, передаваемых по межсетевому протоколу IP. Позволяет осуществлять подтверждение подлинности (аутентификацию), проверку целостности и/или шифрование IP-пакетов. IPsec также включает в себя протоколы для защищённого обмена ключами в сети Интернет. В основном, применяется для организации VPN-соединений. RFC 2401.
ICMP (InternetControlMessageProtocol) позволяет маршрутизатору сообщить конечному узлу об ошибках, с которыми машрутизатор столкнулся при передаче какого-либо IP-пакета от данного конечного узла. Протокол ICMP - это протокол сообщения об ошибках, а не протокол коррекции ошибок. RFC 792.
Протокол маршрутной информации (Routing Information Protocol) — один из самых простых протоколовмаршрутизации. Применяется в небольших компьютерных сетях, позволяет маршрутизаторам динамически обновлять маршрутную информацию (направление и дальность в хопах), получая ее от соседних маршрутизаторов. Создан в 1969 году. RFC 1058.
OSPF (OpenShortestPathFirst) — протокол динамической маршрутизации, основанный на технологии отслеживания состояния канала (link-statetechnology) и использующий для нахождения кратчайшего пути алгоритм Дейкстры.Протокол OSPF был разработан IETF в 1988 году. Последняя версия протокола представлена в RFC 2328. OSPF имеет следующие преимущества:
Высокая скорость сходимости по сравнению с дистанционно-векторными протоколами маршрутизации;
Поддержка сетевых масок переменной длины (VLSM);
Оптимальное использование пропускной способности с построением дерева кратчайших путей;
EIGRP (EnhancedInteriorGatewayRoutingProtocol) — протокол маршрутизации, разработанный фирмой Cisco на основе протокола IGRP той же фирмы. Релиз протокола состоялся в 1994 году. EIGRP использует механизм DUAL для выбора наиболее короткого маршрута. Единственным недостатком протокола EIGRP на данный момент является его ограниченность в использовании оборудования только компании Cisco. Хотя в феврале 2013 года Cisco открыла EIGRP, его внедрение в маршрутизаторы других производителей официально не объявлено.
BGP (BorderGatewayProtocol, протокол граничного шлюза) — динамический протокол маршрутизации.Относится к классу протоколов маршрутизации внешнего шлюза (англ. EGP — ExternalGatewayProtocol).На текущий момент является основным протоколом динамической маршрутизации в сети Интернет. BGP поддерживает бесклассовую адресацию и использует суммирование маршрутов для уменьшения таблиц маршрутизации. С 1994 года действует четвёртая версия протокола, все предыдущие версии являются устаревшими. RFC 4271.
IGMP (InternetGroupManagementProtocol — протокол управления группами Интернета) — протокол управления групповой (multicast) передачей данных в сетях, основанных на протоколе IP. IGMP используется маршрутизаторами и IP-узлами для организации сетевых устройств в группы. RFC 3376.
DDP (Протокол описания диска, ди-ди-пи, англ. DiscDescriptionProtocol) — профессиональный формат обмена, используемый в индустрии мастеринга для определения содержания Оптических дисков, включая CD и DVD. DDP-файл содержит разного типа информацию о диске, например, о файловой структуре, наименовании исполнителя. Всего 4 части[1]:
Аудио образы (.DAT файлы)
DDPID (DDP идентификаторы)
DDPMS (DDP дескриптор потока)
PQDESCR (дополнительный код дескриптора)
Simple Key-Management for Internet Protocol (или SKIP) — протокол, разработанныйоколо 1995 годаорганизацией IETF Security Working Group дляобменаключамишифрования.SKIP является гибридным протоколом распределения ключей, похожим на SSL, кроме того, он один раз устанавливает долгосрочные ключи, а затем не требует предварительной связи в целях установления или обмена ключами.RFC 2356.
GRE (GenericRoutingEncapsulation — общая инкапсуляция маршрутов) — протокол туннелирования сетевых пакетов, разработанный компанией CiscoSystems. RFC 1701. Его основное назначение — инкапсуляция пакетов сетевого уровня сетевой модели OSI в IP пакеты.Туннелирование подразумевает три протокола:
пассажир — инкапсулированный протокол (IP, CLNP, IPX, AppleTalk, DECnetPhase IV, XNS, VINES и Apollo)
протокол инкапсуляции (GRE)
транспортный протокол (UDP)
RARP (ReverseAddressResolutionProtocol — Обратный протокол преобразования адресов) — протокол сетевого уровня модели OSI, выполняет обратное отображение адресов, то есть преобразует физический адрес в IP-адрес. Протокол применяется во время загрузки узла (например компьютера), когда он посылает групповое сообщение-запрос со своим физическим адресом. RARP является дополнением к ARP, и описан в RFC 903.
