- •Глава 1
- •Глава 2
- •2.5. Модели транспортных сетей в оптических мультисер-
- •Глава 3
- •3.1.2. Формирование виртуальных контейнеров и функции
- •3.1.6. Технологические решения по контролю качества трактов и
- •Глава 5
- •5.3.2. Фазовые дрожания и их нормирование относительно
- •Глава 4
- •4.3. Мультиплексоры вывода/ввода adm с электрическими и
- •4.5. Оптический сетевой элемент с функциями
- •5.4.4. Отображение функций управления через окна графического
- •5.5. Автоматически коммутируемые оптические транспортные
- •Глава 6
- •6.4. Коммутационные и алгоритмические возможности
- •6.5. Этапы разработки проекта оптической транспортной
- •Глава 1
- •1.1. Определение системы передачи
- •1.2. Обобщенная схема оптической системы передачи
- •1.3. Принципы построения аппаратуры оптических систем передачи и транспортных сетей
- •Глава 2
- •2.1. Модель транспортной сети sdh
- •2.2. Модель транспортной сети atm
- •2.3. Модель транспортной сети otn-oth
- •2.4. Модель транспортной сети Ethernet
- •2.5. Модели транспортных сетей в оптических мультисервисных транспортных платформах
- •Глава 3
- •3.1. Технология мультиплексирования sdh
- •3.1.1. Термины, определения и обозначения в sdh
- •3.1.2. Формирование виртуальных контейнеров и функции заголовков рон3.1.2.
- •3.1.3. Сцепленные виртуальные контейнеры
- •3.1.4. Синхронный транспортный модуль stm-n
- •3.1.5. Формирование указателей ptr
- •3.1.6. Технологические решения по контролю качества трактов и секций sdh
- •3.2. Технология асинхронного режима передачи atm
- •3.2.1. Термины, определения и обозначения в atm
- •3.2.2. Уровни адаптации atm
- •3.2.3. Функции уровня atm
- •3.2.4. Размещение и передача ячеек atm на физическом уровне
- •3.3. Технология оптической транспортной сети otn-oth
- •3.3.1. Термины, определения и обозначения otn-oth
- •3.3.2. Формирование блоков нагрузки оптических каналов opUk
- •3.3.3. Блок данных оптического канала odUk
- •3.3.4. Оптический транспортный блок otUk
- •3.3.5. Блок оптического канала оси
- •3.3.6. Блок переноса оптического канала осс
- •3.3.7. Блок группирования оптических несущих частот ocg-n
- •3.3.8. Блок оптического транспортного модуля otm-n.M
- •3.4. Технология мультиплексирования Ethernet
- •3.4.1. Ethernet стандарта ieee 802.3
- •3.4.2. Ethernet стандарта ЕоТ
- •3.4.3. Построение схем мультиплексирования Ethernet
- •3.4.4. Технологическое решение для t-mpls
- •3.5. Технологические согласования транспортных сетей
- •3.5.1. Протокольное решение laps
- •3.5.2. Протокольное решение gfp
- •3.5.3. Технология защищаемого пакетного кольца rpr
- •Глава 4
- •4.1. Регенератор и оптический усилитель
- •4.2. Терминальные мультиплексоры
- •4.2.1. Терминальный мультиплексор с функциями портов pdh
- •4.2.2. Терминальный мультиплексор с функциями портов Ethernet
- •4.2.3. Терминальный мультиплексор с функциями портов atm
- •4.2.4. Терминальный мультиплексор с функциями портов отн
- •4.2.5. Терминальный мультиплексор с функциями портов ason
- •4.2.6. Терминальный мультиплексор с линейными портами wdm
- •4.3. Мультиплексоры вывода/ввода adm с электрическими и
- •4.4. Цифровой кроссовый коммутатор sdxc
- •4.5. Оптический сетевой элемент с функциями
- •4.6. Платформенный принцип построения сетевых
- •Глава 5
- •5.1. Структуры транспортных сетей
- •5.2. Схемы защиты транспортных сетей
- •5.2.2. Защита секции мультиплексирования в кольцевой сети
- •5.2.3. Защита соединений тракта
- •5.2.4. Защитные переключения в сети с многовол-
- •5.2.5. Защитные переключения в транспортной сети Ethernet
- •5.3. Синхронизация в транспортных сетях
- •5.3.1. Нормирование проскальзываний
- •5.3.2. Фазовые дрожания и их нормирование относительно проскальзываний
- •5.3.3. Генераторы сигналов синхронизации
- •5.3.4. Распределение тактового синхронизма
- •5.3.6. Аудит сети синхронизации
- •5.4. Управление в транспортных сетях
- •5.4.1. Общие принципы управления сетями связи
- •5.4.2. Функции управления транспортной сетью
- •5.4.3. Стандартные элементы сети управления
- •5.4.4. Отображение функций управления через окна графиче-
- •5.5. Автоматически коммутируемые оптические транс-
- •5.5.1. Общая структура ason/astn
- •5.5.2. Логическое построение ason
- •5.5.3. Построение сигнальной сети и ее функции
- •5.5.4. Протоколы сигнальной системы ason
- •5.5.5. Однонаправленные и двунаправленные lsp
- •5.5.6. Транспортировка сообщений защиты lsp
- •5.5.7. Механизм сигнализации с использованием протокола
- •5.5.8. Механизм сигнализации с использованием протокола
- •Глава 6
- •6.1. Принципы планирования
- •6.2. Виды нагрузки транспортной сети и требуемые ресурсы
- •6.3.1. Интерфейсы одноволновых систем оптической передачи
- •6.3.2. Интерфейсы многоволновых систем
- •6.3.3. Реализация многоволновых интерфейсов
- •6.4. Коммутационные и алгоритмические возможности транс
- •6.5. Этапы разработки проекта оптической транспортной сети
5.5.7. Механизм сигнализации с использованием протокола
RSVP-TE
Протокол резервирования ресурсов — проектирования трафика (RSVP-TE, Resource Reservation Protocol — Traffic Engineering) является частью спецификаций интерфейсов UNI и E-NNI. Этот протокол сигнализации используется для соединений контроллера вызова в интерфейсе UNI, контроллера соединения (PC) и администратора ресурсов линии (LRM). Адресация транспортных ресурсов в этом протоколе производится идентификаторами пункта пула подсети SNPP (Subnetwork Point Pool). Пара таких идентификаторов определяет звено связи SNPP. Имена SNPP определяются из пространства транспортных имен, к которым относятся: имена транспортных ресурсов интерфейса UNI (виртуального канала, сцепленного соединения на основе VC-X-Xv, оптического канала ОСЬ и т.д.), блоков управления и ввода адреса сигнализации, подсети, контроллера соединения и т.д. При этом контроллер маршрутизации и идентификаторы управления соединением не используются для создания имен звеньев связи.
В описание основных процедур протокола RSVP-TE входят собственно процедуры, сообщения и форматы объектов для передачи сигнальной информации по сети пакетами IP. Описание протокола RSVP-TE включает дополнительные сообщения (рис. 5.62).
Расширением протокола RSVP-TE являются объект для наращивания поля имен от А до Z и также спецификации CoS и GoS для поддержки запросов на услуги интерфейса UN1.
Формат сообщений GMPLS RSVP-TE основан на базовой структуре пакета данных, определенной в документах RFC 2205, RFC 2961, RFC 3209, RFC 3474 (рис. 5.63). К этому формату добавляются необходимые объекты сигнальных сообщений (на рис. 5.63 не обозначены), например, в которых записан идентификатор оператора сети, идентификатор вызова, адрес элемента исходной транспортной сети и т.д. Сообщение RSVP состоит из заголовка и некоторого количества объектов, характерных для каждого типа сообщений. Типы сообщений кодируются: 1 — Path; 2 — Resv; 3 — Path Err; 5 — Path Tear; 7 — Resv Conf; 13 — Ack; 15 — Srefresh; 20 — Hello; 21 — Notify. В поле «версия» указывается версия протокола RSVP-TE. В поле «флаги» отмечается групповая или индивидуальная рассылка сообщения. Поле «контрольная сумма RSVP» предназначено для обнаружения ошибок. В поле «параметры передачи» передаётся сообщение о необходимом QoS. В поле «длина RSVP» фиксируется общее число байтов всего пакета с основной частью и объектами.
Типы сообщений имеют следующее назначение:
Path используется для инициирования запросов на установление соединения, на разъединение, промежуточного в направлении вызова запроса на разъединение, ответа на сообщение Resv;
Resv используется для ответа на запрос об установлении соединения с сообщением Path, при инициировании запроса на разъединение от получателя вызова и т.д.;
Resv Conf используется для ответа на запрос об установлении соединения Resv;
Path Tear используется для ответа на запрос о разъединении Resv, ответа на сообщение Path Err во время операций установки и разъединения и т.д.;
Path Err используется для ответа на запрос об установлении соединения Path, если это соединение не может быть установлено, для ответа на запрос о разъединении Path, для отправки сообщения о неудачной операции установки соединения, для отправки сообщения о неудачной операции разъединения;
Notify используется для того, чтобы асинхронно уведомлять контроллер соединения об ошибках при соединении;
Hello используется для обеспечения сеанса резервирования RSVP и инициирования процедуры перезагрузки;
Аск используется в качестве уведомления об отправке сообщения;
Srefresh используется для обновления состояния сообщения RSVP-TE без передачи сообщений Path и Resv, что приводит к уменьшению количества передаваемой информации для поддержания синхронизма вызова и соединения;
Использование рассмотренных сообщений иллюстрируется общим описанием потока сигнальных сообщений для процедуры настройки (рис. 5.64):
сообщение о пути (Path) для запрашиваемого соединения отправлено от исходного пункта к пункту назначения;
после приема сообщения Path пунктом назначения между исходным пунктом и пунктом назначения устанавливается сеанс резервирования ресурсов RSVP;
пункт назначения отвечает на сообщение Path одним из двух сообщений в обратном направлении (Resv — при нормальной настройке сети и Path Err — при ошибке процедуры настройки);
после приема исходным пунктом сообщения Resv может быть отправлено дополнительное сообщение Resv Conf в пункт назначения.
