Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
understanding-SIP.pdf
Скачиваний:
118
Добавлен:
01.03.2016
Размер:
4 Мб
Скачать
☆

340

SIP: Understanding the Session Initiation Protocol

Table 15.4

HIP References

RFC 5201 HIP Base Protocol [10]

RFC 5202 ESP transport of HIP [13]

RFC 5203 HIP registration extension [14]

RFC 5204 HIP rendezvous extension [15]

RFC 5205 HIP DNS extension [16]

RFC 5206 HIP mobility and multihoming [17]

RFC 5207

HIP NAT traversal [18] (specification does not use hole punching and has limited utility)

15.7 Questions

Q15.1 List some P2P properties of SIP.

Q15.2 Explain how an overlay uses a DHT.

Q15.3 For the Chord overlay in Figure 15.4, fill in the missing entries in the finger tables of Tables 15.5 and 15.6.

Q15.4 Explain how HITs are self-certifying.

Q15.5 Why does the use of peer protocol require changes in the way a SIP URI is resolved?

Figure 15.4 Chord overlay for Question Q15.3.

Peer-to-Peer SIP

341

Table 15.5

Chord Finger Table for Node 27 in Figure 15.4

 

 

 

Closest to

k

Node

Actual Node

 

 

 

 

0

20

+ 27

53

1

21

+ 27

53

2

22

+ 27

53

3

23

+ 27

53

4

24

+ 27

?

5

25

+ 27

?

6

26

+ 27

?

7

27

+ 27

159

Table 15.6

Chord Finger Table for Node 180 in Figure 15.4

 

 

 

Closest to

k

Node

Actual Node

 

 

 

 

0

20

+ 180

192

1

21

+ 180

192

2

22

+ 180

?

3

23

+ 180

?

4

24

+ 180

202

5

25

+ 180

?

6

26

+ 180

27

7

27

+ 180

?

References

[1]Camarillo, G., “Peer-to-Peer (P2P) Architectures,” draft-iab-p2p-archs-01 (work in progress), April 2009.

[2]Rosenberg, J., H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, and E. Schooler, “SIP: Session Initiation Protocol,” RFC 3261, June 2002.

[3]Mahy, R., R. Sparks, J. Rosenberg, D. Petrie, and A. Johnston, “A Call Control and MultiParty Usage Framework for the Session Initiation Protocol (SIP),” draft-ietf-sipping-cc- framework-11 (work in progress), March 2009.

[4]Sinnreich, H., A. Johnston, and E. Shim, “Simple SIP Usage Scenario for Applications in the Endpoints,” draft-sinnreich-sip-tools-07 (work in progress), June 2009.

342

SIP: Understanding the Session Initiation Protocol

[5]Stoica, I., et al., “Chord: A Scalable Peer-to-Peer Lookup Service for Internet Applications,” ACM SIGCOMM 2001, San Diego, CA, August 2001, pp. 149-160.

[6]Jennings, C., et al., “Resource Location and Discovery (RELOAD) Base Protocol,” draft- ietf-p2psip-base-02 (work in progress), March 2009.

[7]Baset, S., H. Schulzrinne, and M. Matuszewski, “Peer-to-Peer Protocol (P2PP),” draft- baset-p2psip-p2pp-01 (work in progress), November 2007.

[8]http://www.ietf.org/html.charters/p2psip-charter.html.

[9]Jennings, C., et al., “A SIP Usage for RELOAD,” draft-ietf-p2psip-sip-01 (work in progress), March 2009.

[10]Moskowitz, R., et al., “Host Identity Protocol,” RFC 5201, April 2008.

[11]Nikander, P., J. Laganier, and F. Dupont, “An IPv6 Prefix for Overlay Routable Cryptographic Hash Identifiers (ORCHID),” RFC 4843, April 2007.

[12]Camarillo, G., et al., “HIP BONE: Host Identity Protocol (HIP) Based Overlay Networking Environment,” draft-ietf-hip-bone-01 (work in progress), March 2009.

[13]Jokela, P., R. Moskowitz, and P. Nikander, “Using the Encapsulating Security Payload (ESP) Transport Format with the Host Identity Protocol (HIP),” RFC 5202, April 2008.

[14]Laganier, J., T. Koponen, and L. Eggert, “Host Identity Protocol (HIP) Registration Extension,” RFC 5203, April 2008.

[15]Laganier, J., and L. Eggert, “Host Identity Protocol (HIP) Rendezvous Extension,” RFC 5204, April 2008.

[16]Nikander, P., and J. Laganier, “Host Identity Protocol (HIP) Domain Name System (DNS) Extensions,” RFC 5205, April 2008.

[17]Nikander, P., et al., “End-Host Mobility and Multihoming with the Host Identity Protocol,” RFC 5206, April 2008.

[18]Stiemerling, M., J. Quittek, and L. Eggert, “NAT and Firewall Traversal Issues of Host Identity Protocol (HIP) Communication,” RFC 5207, April 2008.

[19]Gurtov, A., Host Identity Protocol (HIP): Towards the Secure Mobile Internet, Wiley Series on Communications Networking & Distributed Systems, New York: John Wiley & Sons, 2008.

Соседние файлы в предмете [НЕСОРТИРОВАННОЕ]