Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
understanding-SIP.pdf
Скачиваний:
118
Добавлен:
01.03.2016
Размер:
4 Мб
Скачать
☆

 

 

SIP and the Internet

13

 

 

Table 1.2

 

URL and URI Schemes Used in Internet Communications

 

 

Scheme

Protocol

 

 

 

sip

SIP

 

 

 

sips

Secure SIP (TLS)

 

 

 

tel

Telephone number and dial string

 

 

 

im

Instant messaging inbox

 

 

 

pres

Presence

 

 

 

xmpp

Jabber IM and presence

 

 

 

h323

H.323

 

 

URN:ISBN:1-60783-995-4

URN namespaces are often used to identify XML extensions.

1.5 Domain Name Service

The Domain Name Service [17] is used on the Internet to map a symbolic name (such as www.amazon.com) to an IP address (such as 100.101.102.103 which is an example IPv4 address). DNS is also used to obtain information needed to route e-mail messages and, in the future, SIP messages. The use of names instead of numerical addresses is one of the Internet’s greatest strengths because it gives the Internet a human, friendly feel. Domain names are organized in a hierarchy. Each level of the name is separated by a dot, with the highest level domain on the right side. (Note that the dots in a domain name have no correspondence to the dots in an IP address written in dotted decimal notation.) General top-level domains are shown in Table 1.3 (see http://www.icann.org/tlds for the latest list). Some such as com, net, and edu are commonly encountered, while others such as aero and coop are rare. There is also a set of country domains such as: us (United States), uk (United Kingdom), ca (Canada), and au (Australia). Each of these top-level domains has just one authority that assigns that domain to a user or group.

Once a domain name has been assigned, the authority places a link in their DNS server to the DNS server of the user or group who has been assigned the domain. For example, when company.com is allocated to a company, the authoritative DNS server for the top-level com domain entry for company contains the IP address of the company’s DNS server(s). A name can then be further qualified by entries in the company’s DNS server to point to individual servers in their network. For example, the company’s DNS server may contain entries for www.

company.com, ftp.company.com, and smtp.company.com. A number of types of

DNS record types are defined. The DNS records used to resolve a host name into an IP address are called address records, or A records. Other types of records

14

SIP: Understanding the Session Initiation Protocol

 

 

 

Table 1.3

 

 

Generic Top Level Domains (gTLDs)

 

 

Domain

Description

 

 

 

com

Company

 

 

 

net

Network

 

 

 

int

Internet

 

 

 

org

Not-for-profit organization

 

 

 

edu

University or college

 

 

 

gov

U.S. government

 

 

 

mil

U.S. military

 

 

 

arpa

ARPAnet

 

 

 

info

Information

 

 

 

biz

Business

 

 

 

museum

Museum

 

 

 

name

Name

 

 

 

pro

Professional

 

 

 

aero

Air transport industry

 

 

 

coop

Cooperatives

 

include CNAME (canonical name or alias records), MX (mail exchange records), SRV (service records, used by SIP and other protocols), and TXT (free-form text records). Another type of DNS record is a PTR, or pointer record, used for reverse lookups. Reverse lookups are used to map an IP address back to a domain name. These records can be used to generate server logs that show not only the IP addresses of clients served, but also their domain name. Web browsing provides an example of the use of the DNS system. Another type of DNS record is known as a Naming Authority Pointer (NAPTR) record that can be used by a protocol known as ENUM [18] to map global telephone numbers into Internet URLs.

1.5.1DNS Resource Records

DNS resource records are text records that are stored in DNS servers and retrieved by DNS resolvers. Each record has a minimum of four fields: name, type, class, and time to live (TTL). The name is the owner of the record and the resource being identified. The type is the type of resource records such as A, AAAA, MX, SRV, NAPTR, PTR, or TXT. Class is the class of address, which is IN for Internet addresses (all other network addresses are CH for Chaos). The time to live field is a 32-bit integer count of the number of seconds the record should be cached before being discarded.

Common DNS resource record types are listed in Table 1.4. The resource records used by SIP are discussed in detail in the following sections.

 

 

 

SIP and the Internet

15

 

 

 

Table 1.4

 

 

 

Common DNS Resource Record Types

 

 

RR Type

Reference

Description

 

 

A

RFC 1035

Address IPv4, See Section 1.5.2

 

 

AAAA

RFC 3596

Address IPv6, See Section 1.5.2

 

 

CNAME

RFC 1035

Canonical name, used for aliases

 

 

MX

RFC 1035

Mail exchange

 

 

NAPTR

RFC 2915

Naming authority pointer record; see Section 1.5.4

 

 

NS

RFC 1035

Name server records

 

 

PTR

RFC 1035

Reverse domain name lookup

 

 

SOA

RFC 1035

Start of authority

 

 

SPF

RFC 4408

Sender policy framework for authorizing e-mail

 

 

SRV

RFC 2782

Services; see Section 1.5.3

 

 

TXT

RFC 1035

Text records

 

1.5.2Address Resource Records (A or AAAA)

The most common type of resource record is an address record. As the name suggests, it provides an address for a resource or a host name. Besides the name, TTL, class, and type fields it includes a target field, which is an IP address. An A record provides [17] an IPv4 address while an AAAA record [19] provides an IPv6 address. An AAAA record is usually called a “quad A” record.

Structure:

Name TTL Class A Target

For example,

ese.wustl.edu. 3600 IN A 128.252.168.2 ietf.org. 300 IN AAAA 2610:a0:c779:b::d1ad:35b4

are examples of an A record and an AAAA record. Notice the “.” used after the host name—this is to indicate that the address is absolute.

1.5.3Service Resource Records (SRV)

Service resource records or SRV records [20] are used to lookup a host that provides a particular service. A number of services have been defined for SRV records including SIP service. SRV records use an underscore ( _ ) in the service name to distinguish it from normal host names which may not include an underscore.

Structure:

Service.Proto.Name TTL Class SRV Priority Weight Port Target

16

SIP: Understanding the Session Initiation Protocol

The priority field is used to set the relative priority of this record, as an SRV query might return several SRV resource records. The priority is a 16 bit unsigned integer. Resolvers should use the lowest priority record (highest priority). The weight is a relative weight used to select between records with the same priority. It is also a 16 bit unsigned integer. The port is the transport port number that should be used for this service. This allows multiple instances of the same service to be run on the same host—each can utilize a different port number. The target is the domain name of the host. To reach the desired service, the target address and port number should be used.

For example,

_sip._udp.avaya.com. 300 IN SRV 0 100 5060 sip.avaya.com.

This example resource record is for SIP service using UDP as the transport protocol. The priority of this record is 0, indicating that it is the highest priority. The port number is 5060, the registered port for SIP. The target is sip.avaya. com, which will require an address (A or AAAA) lookup to resolve to an IP address. The use of SRV records in SIP will be discussed in Section 2.6.

1.5.4Naming Authority Pointer Resource Records (NAPTR)

Naming authority pointer resource records or NAPTR records [21] are used to point to another record or URI. They are used by SIP to discover which transport protocols a given domain or server supports. In a protocol known as ENUM, they are used to resolve a telephone number into a URI. The usage of NAPTR records in SIP are discussed in Section 2.6.

Structure:

Domain TTL Class Type Order Preference Flags Service Regexp Replacement

Example:

columbia.edu. 3600 IN NAPTR 1 0 “s” “SIP+D2U” “” _sip._udp.columbia.edu.

1.5.5DNS Resolvers

DNS resolvers are the software in an Internet host that looks up DNS records and sends DNS requests. When a user types in a Web address, such as www. artechhouse.com, the name must be resolved to an IP address before the browser can send the request for the index Web page from the Artech House Web server. The Web browser first launches a DNS query to the IP address for its DNS server, which has been manually configured or set up using DHCP.

Соседние файлы в предмете [НЕСОРТИРОВАННОЕ]