Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
understanding-SIP.pdf
Скачиваний:
118
Добавлен:
01.03.2016
Размер:
4 Мб
Скачать
☆

Network Address Translation

261

NAT B is endpoint independent mapping NAT with endpoint dependent filtering.

NAT A is address and port dependent mapping with endpoint independent filtering.

Packet sent from A 192.168.0.1:1234 to a STUN server at

15.1.2.3 creates a mapping of 23.3.2.8:4219

Packet sent from B 10.0.1.13:5678 to a STUN server at

15.1.2.3 creates a mapping of 2.73.3.2:31212

Assume NAT A has only a single IP address. Assume NAT

A and B do not implement port preservation.

Show the filter rules created as A and B begin hole punching. Will hole punching succeed?

Q10.8 Repeat Question Q10.7 with everything the same except:

NAT B is address dependent mapping NAT with endpoint dependent filtering.

NAT A is address and port dependent mapping with endpoint dependent filtering.

Show the filter rules created as A and B begin hole punching.

Will hole punching succeed?

Q10.9 For a SIP message sent by host A (hostname of hosta. mappings.org) to host Y1 in Question Q10.4, show the Via header in the response assuming the rport extension is used.

Q10.10 Explain the relationship between hole punching and ICE.

References

[1]Egevang, K., and P. Francis, “The IP Network Address Translator (NAT),” RFC 1631, May 1994.

[2]Rekhter, Y., et al., “Address Allocation for Private Internets,” BCP 5, RFC 1918, February 1996.

[3]Srisuresh, P., and M. Holdrege, “IP Network Address Translator (NAT) Terminology and Considerations,” RFC 2663, August 1999.

[4]http://www.ietf.org/html.charters/behave-charter.html.

[5]Hain, T., “Architectural Implications of NAT,” RFC 2993, November 2000.

[6]Audet, F., and C. Jennings, “Network Address Translation (NAT) Behavioral Requirements for Unicast UDP,” BCP 127, RFC 4787, January 2007.

[7]Senie, D., “Network Address Translator (NAT)-Friendly Application Design Guidelines,” RFC 3235, January 2002.

262

SIP: Understanding the Session Initiation Protocol

[8]Rosenberg, J., et al., “STUN—Simple Traversal of User Datagram Protocol (UDP) Through Network Address Translators (NATs),” RFC 3489, March 2003.

[9]Rosenberg, J., “Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer Protocols,” draft-ietf-mmusic-ice-19 (work in progress), October 2007.

[10]MacDonald, D., and B. Lowekamp, “NAT Behavior Discovery Using STUN,” draft-ietf- behave-nat-behavior-discovery-05 (work in progress), November 2008.

[11]Daigle, L., and IAB, “IAB Considerations for Unilateral Self-Address Fixing (UNSAF) Across Network Address Translation,” RFC 3424, November 2002.

[12]Rosenberg, J., and H. Schulzrinne, “An Extension to the Session Initiation Protocol (SIP) for Symmetric Response Routing,” RFC 3581, August 2003.

[13]Gurbani, V., R. Mahy, and B. Tate, “Connection Reuse in the Session Initiation Protocol (SIP),” draft-ietf-sip-connect-reuse-14 (work in progress), August 2009.

[14]Jennings, C., and R. Mahy, “Managing Client Initiated Connections in the Session Initiation Protocol (SIP),” draft-ietf-sip-outbound-16 (work in progress), October 2008.

[15]Huitema, C., “Real Time Control Protocol (RTCP) Attribute in Session Description Protocol (SDP),” RFC 3605, October 2003.

[16]Rosenberg, J., R. Mahy, and P. Matthews, “Traversal Using Relays Around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN),” RFC 5389, October 2008.

[17]Boulton, C., et al., “Best Current Practices for NAT Traversal for Client-Server SIP,” Internet Draft draft-ietf-sipping-nat-scenarios-09 (work in progress), September 2008.

Соседние файлы в предмете [НЕСОРТИРОВАННОЕ]