Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
understanding-SIP.pdf
Скачиваний:
118
Добавлен:
01.03.2016
Размер:
4 Мб
Скачать
☆

296

SIP: Understanding the Session Initiation Protocol

•A single c= field at the session level. This is the mos t common case.

•A session level c= field and some media level c= fields.

•Each media level field with no session level stream.

The same rules for attributes apply when both session and media level c= fields are present; the media field overrides the session level for that particular media stream.

13.2 SDP Extensions

There are a number of SDP extensions that have been defined. Common ones are summarized in Table 13.4.

The RTCP IP address and port attribute, a=rtcp [6] is covered in Chapter 10. The a=setup and a=connection attributes are used for connection oriented media, such as TCP. Section 8.5.2 shows the use of these attributes in establishing MSRP sessions. Another example is shown below of Binary Floor Control

Table 13.4

Common SDP Extensions

Attribute

Name

Reference

 

 

 

a=rtcp

Port and IP address for RTCP [6]

RFC 3605

a=mid

Media session identifier and grouping of

RFC 3388

a=group

media streams [7]

 

a=setup

Connection-oriented media using as TCP

RFC 4145

a=connection

transport [8]

 

a=key-mgt

Key management for MIKEY [9]

RFC 4567

a=crypto

Key management for SRTP [10]

RFC 4568

a=floorctrl

Binary Floor Control Protocol (BFCP)

 

a=confid

RFC 4583

a=userid

information [11]

 

a=floorid

 

 

a=fingerprint

Connection-oriented media using TLS [12]

RFC 4572

a=label

Media label [13]

RFC 4574

a=accept-types

Message Session Relay Protocol (MSRP)

 

a=accept-wrapped-types

RFC 4975

a=max-size

information [14]

 

a=path

 

 

a=ice-pwd

 

 

a=ice-ufrag

Interactive connectivity establishment (ICE) [15]

[15]

a=ice-lite

a=ice-mismatch

 

 

a=ice-options

 

 

a=chatroom

Chat room name for MSRP

[16]

Соседние файлы в предмете [НЕСОРТИРОВАННОЕ]