Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
understanding-SIP.pdf
Скачиваний:
118
Добавлен:
01.03.2016
Размер:
4 Мб
Скачать
☆

108 SIP: Understanding the Session Initiation Protocol

Q4.6 Generate a suitable PRACK message in response to the 180 Ringing response here:

SIP/2.0 180 Ringing

Via: SIP/2.0/UDP boyden.harvard.edu ;branch=z9hG4bK452352;received=1.2.3.4

To: Clyde <sip:clyde.tombaugh@lowell.edu>;tag=312323 From: Bill <sip:william.pickering@harvard.edu> ;tag=877s981

Call-ID: Ldfk37sfa2DF RSeq: 17314

CSeq: 53 INVITE

Content-Length: 0

Q4.7 Explain how PUBLISH can be used to create, refresh, update, and delete event state.

Q4.8 Generate the SUBSCRIBE that could have caused this NOTIFY to be sent:

NOTIFY sip:e.hubble@mtwilson.edu SIP/2.0 Via SIP/2.0/UDP room421.caltech.edu:5060 ;branch=z9hG4bK3841323

Max-Forwards: 70

To: <sip:e.hubble@mtwilson.edu>;tag=8311814 From: <sip:georgehale@caltech.edu>;tag=5363956k Call-ID: 58kjeGrkre88er

CSeq: 73 NOTIFY

Contact: <sip:georgehale@room421.caltech.edu> Event: presence

Subscription-State: active;expires=3540 Allow-Events: dialog

Content-Type: application/xml+dialog Content-Length: ...

Q4.9 How is a subscribe-created dialog terminated?

 

 

Q4.10 Explain when a 412 response might

be received

in

response to a PUBLISH. What should the

presence UA

do

after receiving this response?

 

 

References

[1]Rosenberg, J., H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, and E. Schooler, “SIP: Session Initiation Protocol,” RFC 3261, June 2002.

[2]Rosenberg, J., “Obtaining and Using Globally Routable User Agent (UA) URIs (GRUU) in the Session Initiation Protocol (SIP),” draft-ietf-sip-gruu-15 (work in progress), October 2007.

SIP Request Messages

109

[3]Rosenberg, J., H. Schulzrinne, and P. Kyzivat, “Indicating User Agent Capabilities in theSession Initiation Protocol (SIP),” RFC 3840, August 2004.

[4]Johnston, A., and O. Levin, “Session Initiation Protocol (SIP) Call Control—Conferencing for User Agents,” BCP 119, RFC 4579, August 2006.

[5]Roach, A., “Session Initiation Protocol (SIP)-Specific Event Notification,” RFC 3265, June 2003.

[6]Petrack, S., and L. Conroy, “The PINT Service Protocol: Extensions to SIP and SDP for IP Access to Telephone Call Services,” RFC 2848, June 2000.

[7]Rosenberg, J., H. Schulzrinne, and O. Levin, “A Session Initiation Protocol (SIP) Event Package for Conference State,” RFC 4575, August 2006.

[8]Camarillo, G., “The Session Initiation Protocol (SIP) Pending Additions Event Package,” RFC 5362, October 2008.

[9]Rosenberg, J., H. Schulzrinne, and R. Mahy, “An INVITE-Initiated Dialog Event Packagefor the Session Initiation Protocol (SIP),” RFC 4235, November 2005.

[10]Burger, E., and M. Dolly, “A Session Initiation Protocol (SIP) Event Package for Key Press Stimulus (KPML),” RFC 4730, November 2006.

[11]Mahy, R., “A Message Summary and Message Waiting Indication Event Package for the Session Initiation Protocol (SIP),” RFC 3842, August 2004.

[12]Rosenberg, J., “A Presence Event Package for the Session Initiation Protocol (SIP),” RFC 3856, August 2004.

[13]Rosenberg, J., “A Session Initiation Protocol (SIP) Event Package for Registrations,” RFC 3680, March 2004.

[14]Sparks, R., “The Session Initiation Protocol (SIP) Refer Method,” RFC 3515, April 2003.

[15]Rosenberg, J., “A Watcher Information Event Template-Package for the Session InitiationProtocol (SIP),” RFC 3857, August 2004.

[16]Clark, A., et al., “RTCP-XR Summary,” draft-ietf-sipping-rtcp-summary-06 (work in progress), March 2009.

[17]Niemi, A., “Session Initiation Protocol (SIP) Extension for Event State Publication,” RFC 3903, October 2004.

[18]Fielding, R., et al., “Hypertext Transfer Protocol—HTTP/1.1,” RFC 2616, June 1999.

[19]Sparks, R., “Internet Media Type message/sipfrag,” RFC 3420, November 2002.

[20]Levin, O., “Suppression of Session Initiation Protocol (SIP) REFER Method Implicit Subscription,” RFC 4488, May 2006.

[21]Sparks, R., and A. Johnston, “Session Initiation Protocol Call Control—Transfer,” RFC 5589, June 2009.

[22]Levin, O., and A. Johnston, “Conveying Feature Tags with the Session Initiation Protocol (SIP) REFER Method,” RFC 4508, May 2006.

110

SIP: Understanding the Session Initiation Protocol

[23]Campbell, B., et al., “Session Initiation Protocol (SIP) Extension for Instant Messaging,” RFC 3428, December 2002.

[24]Klyne, G., and D. Atkins, “Common Presence and Instant Messaging (CPIM): Message Format,” RFC 3862, August 2004.

[25]Peterson, J., “Address Resolution for Instant Messaging and Presence,” RFC 3861, August 2004.

[26]Donovan, S., “The SIP INFO Method,” RFC 2976, October 2000.

[27]Burger, E., H. Kaplan, and C. Holmberg, “Session Initiation Protocol (SIP) INFO Method and Package Framework,” draft-ietf-sip-info-events-03 (work in progress) January 2009.

[28]Rosenberg, J., and H. Schulzrinne, “Reliability of Provisional Responses in Session Initiation Protocol (SIP),” RFC 3262, June 2002.

[29]Hoffman, P., L. Masinter, and J. Zawinski, “The mailto URL Scheme,” RFC 2368, July 1998.

[30]Schulzrinne, H., “The tel URI for Telephone Numbers,” RFC 3966, December 2004.

[31]Camarillo, G., “Message Body Handling in the Session Initiation Protocol (SIP),” draft- ietf-sip-body-handling-06 (work in progress), March 2009.

Соседние файлы в предмете [НЕСОРТИРОВАННОЕ]