Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
understanding-SIP.pdf
Скачиваний:
118
Добавлен:
01.03.2016
Размер:
4 Мб
Скачать
☆

SIP Security

327

14.7 Questions

Q14.1 List the main differences between IPSec and TLS. Give an example of a common usage of each protocol on the Internet today.

Q14.2 Describe how mutual authentication can be achieved between a SIP UA and a SIP proxy. Clearly show how secrets and credentials are being shared.

Q14.3 Which parts of the SIP message shown below are protected by the identity signature? Give an example attack that could be launched for each part that is protected (e.g., if a particular header field is protected, explain what an attacker could do if they modified the header field).

INVITE sip:913145551212@siptest.mci.com SIP/2.0 From: sip:alan.johnston@siptest.mci.com;tag=1c31657 To: sip:913145551212@siptest.mci.com

Call-ID: call-1087694972-1 CSeq: 2 INVITE

Contact: <sip:alan.johnston@161.44.17.12> Content-Type: application/sdp Content-Length: 306 Accept-Language: en

Allow: INVITE, ACK, CANCEL, BYE, REFER, OPTIONS, NOTIFY, REGISTER, SUBSCRIBE

Supported: replaces, join User-Agent: Pingtel/2.1.11 (VxWorks) Date: Wed, 16 Apr 2008 01:29:40 GMT

Proxy-Authorization: DIGEST USERNAME=”alanjohnston”, REALM=”MCI”, NONCE=”f9d26bd9c4766eacd3101d8d2dc5f38d.1087694984”, URI=”sip:913145551212@siptest.mci.com”, RESPONSE=”fe1545a816d698b993b83bade8428c0f”

Via: SIP/2.0/UDP 161.44.17.12:5060;branch=dk32234df

v=0

o=jdoe 2890844526 2890842807 IN IP4 161.44.17.12 s=-

i=A Seminar on the session description protocol u=http://www.example.com/seminars/sdp.pdf e=j.doe@example.com (Jane Doe)

c=IN IP4 161.44.17.12 t=0 0

m=video 51372 RTP/SAVP 31 a=crypto:1 AES_CM_128_HMAC_SHA1_80

inline:d0RmdmcmVCspeEc3QGZiNWpVLFJhQX1cfHAwJSoj|2^20|1:32

Q14.4 Which type of attack on SIP do you think is the most damaging? Give an example of a security mechanism to defend against this attack.

Q14.5 Give an example of parameters that need to be configured in order to use SRTP. (Hint: look at the contents of SDP extensions used to carry SRTP information.)

Q14.6 Explain how best effort encryption works and why it is important.

328

SIP: Understanding the Session Initiation Protocol

Q14.7 How does the SIP certificate service simplify key provisioning in UAs?

Q14.8 What are the differences in packet format between RTP and SRTP?

Q14.9 What are the advantages and disadvantages of TLS and IPSec for securing SIP sessions?

Q14.10 Give examples of replay, impersonation, and hijacking attacks on a SIP session.

References

[1]Johnston, A., and D. Piscatello, Understanding VoIP Security, Norwood, MA: Artech House, 2006.

[2]Singh, S., The Code Book: The Science of Secrecy from Ancient Egypt to Quantum Cryptography, New York: Anchor, 2000.

[3]Schnier, B., Applied Cryptography: Protocols, Algorithms, and Source Code in C, 2nd ed., New York: John Wiley & Sons, 1996.

[4]Advanced Encryption Standard (AES), “Federal Information Processing Standard 197,” November 2001.

[5]ANSI X3.106, “American National Standard for Information Systems—Data Link Encryption,” American National Standards Institute, 1983.

[6]Rivest, R. L., The RC4 Encryption Algorithm, RSA Data Security, Inc., 1992.

[7]Rivest, R. L., A. Shamir, and L. M. Adleman, “A Method for Obtaining Digital Signatures and Public-Key Cryptosystems,” Communications of the ACM, Vol. 21, No. 2, February 1978, pp. 120–126.

[8]Diffie, W., and M. E. Hellman, “New Directions in Cryptography,” IEEE Transactions on Information Theory, Vol. 22, 1976, pp. 644–684.

[9]Rescorla, E., “Diffie-Hellman Key Agreement Method,” RFC 2631, June 1999.

[10]Zimmermann, P., A. Johnston, and J. Callas, “ZRTP: Media Path Key Agreement for Secure RTP,” draft-zimmermann-avt-zrtp-15 (work in progress), March 2009.

[11]Housley, R., “Internet X.509 Public Key Infrastructure and CRL Profile,” RFC 2459, November 1998.

[12]Kent, S., and R. Atkinson, “Security Architecture for the Internet Protocol,” RFC 2401, November 1998.

[13]Dierks, T., and E. Rescorla, “The Transport Layer Security (TLS) Protocol Version 1.1,” RFC 4346, April 2006.

[14]Dierks, T., and C. Allen, “The TLS Protocol Version 1.0,” RFC 2246, January 1999.

SIP Security

329

[15]Rescorla, E., and N. Modadugu, “Datagram Transport Layer Security,” RFC 4347, April 2006.

[16]Arends, R., et al., “DNS Security Introduction and Requirements,” RFC 4033, March 2005.

[17]Franks, J., et al, “HTTP Authentication: Basic and Digest Access Authentication,” RFC 2617, June 1999.

[18]Jennings, C., and R. Mahy, “Managing Client Initiated Connections in the Session Initiation Protocol (SIP),” draft-ietf-sip-outbound-20 (work in progress), June 2009.

[19]Gurbani, V., R. Mahy, and B. Tate, “Connection Reuse in the Session Initiation Protocol (SIP),” draft-ietf-sip-connect-reuse-13 (work in progress), March 2009.

[20]Audet, F., “The Use of the SIPS URI Scheme in the Session Initiation Protocol (SIP),” draft-ietf-sip-sips-09 (work in progress), November 2008.

[21]Peterson, J., and C. Jennings, “Enhancements for Authenticated Identity Management in the Session Initiation Protocol (SIP),” RFC 4474, August 2006.

[22]Jennings, C., and J. Fischl, “Certificate Management Service for The Session Initiation Protocol (SIP),” draft-ietf-sip-certs-07 (work in progress), November 2008.

[23]Lennox, J., “Connection-Oriented Media Transport over the Transport Layer Security (TLS) Protocol in the Session Description Protocol (SDP),” RFC 4572, July 2006.

[24]Yon, D., and G. Camarillo, “TCP-Based Media Transport in the Session Description Protocol (SDP),” RFC 4145, September 2005.

[25]Saito, M., and D. Wing, “Media Description for IKE in the Session Description Protocol (SDP),” draft-saito-mmusic-sdp-ike-04 (work in progress), March 2009.

[26]Kaufman, C., “Internet Key Exchange (IKEv2) Protocol,” RFC 4306, December 2005.

[27]Baugher, M., et al., “The Secure Real-time Transport Protocol (SRTP),” RFC 3711, March 2004.

[28]McGrew, D., “The Use of AES-192 and AES-256 in Secure RTP,” draft-ietf-avt-srtp-big- aes-01.txt (work in progress), July 2009.

[29]Handley, M., and V. Jacobson, “SDP: Session Description Protocol,” RFC 2327, April 1998.

[30]Arkko, J., et al., “MIKEY: Multimedia Internet KEYing,” RFC 3830, August 2004.

[31]Arkko, J., et al., “Key Management Extensions for Session Description Protocol (SDP) and Real Time Streaming Protocol (RTSP),” RFC 4567, July 2006.

[32]Andreasen, F., M. Baugher, and D. Wing, “Session Description Protocol (SDP) Security Descriptions for Media Streams,” RFC 4568, July 2006.

[33]McGrew, D., and E. Rescorla, “Datagram Transport Layer Security (DTLS) Extension to Establish Keys for Secure Real-Time Transport Protocol (SRTP),” draft-ietf-avt-dtls-srtp-07 (work in progress), February 2009.

330

SIP: Understanding the Session Initiation Protocol

[34]Wing, D., et al., “Requirements and Analysis of Media Security Management Protocols,” RFC 5479, April 2009.

[35]Gilman, R., R. Even, and F. Andreasen, “SDP Media Capabilities Negotiation,” draft-ietf- mmusic-sdp-media-capabilities-07 (work in progress), February 2009.

[36]Callas, J., et al., “OpenPGP Message Format,” RFC 4880, November 2007.

Соседние файлы в предмете [НЕСОРТИРОВАННОЕ]