Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
А4_Методичка.doc
Скачиваний:
0
Добавлен:
01.04.2025
Размер:
4 Мб
Скачать
☆

2.5.2 Служба Telnet і протокол telnet

Служба Telnet призначена для емуляції віддаленого терміналу і складається з: telnet -интерфейса користувача; telnet -процеса (серверна частина); TELNET -протокола.

Рис. 2.22 заємодія клієнта і сервера по протоколу TELNET

Протокол TELNET (TErminaL NETworking) - протокол і ПЗ, що дозволяють підключатися до віддаленого комп'ютера і працювати з нею через емульований термінал (протокол віртуального терміналу). Забезпечує двонаправлену передачу даних. Стандартно використовується 7-бітовий код ASCII в 8-бітовій упаковці.

Перший стандарт - RFC 0158 (Telnet Protocol : A Proposed Document T.C. O'Sullivan May - 19-1971), а остання версія - RFC 0855 (Telnet Option Specifications J. Postel, J.K. Reynolds May - 01-1983).

З'єднання TELNET створюється на базі з'єднання TCP, використовуваного для передачі даних і управляючої інформації TELNET. З'єднання TCP створюється між деяким вибраним користувачем-ініціатором (Telnet -клиентом) портом і портом з номером 23, закріпленим за протоколом TELNET на віддаленому комп'ютері (Telnet -сервері).

Протокол TELNET базується на наступних трьох принципах: концепції мережевого віртуального терміналу (NVT - network virtual terminal); узгодження додаткових режимів; симетричності терміналів і процесів.

NVT - це уявний пристрій, що знаходиться на обох кінцях з'єднання, у клієнта і сервера, за допомогою якого встановлюється відповідність між їх реальними терміналами.

Модель на основі TELNET, складається з двох NVT, які мають клавіатуру і екран, а також з'єднані інформаційними каналами. Клавіатура одного NVT з'єднана з екраном віддаленого NVT і навпаки. Можливий режим эховідображення (як місцевого, так і віддаленого) символів, що поступають з клавіатури, на місцевий екран.

Рис. 2.23 Модель на основі протоколу TELNET

У протоколі TELNET передбачені наступні типи команд для: узгодження додаткових режимів (опцій); керування і редагування (переривання, перевірка готовності, стирання символу, стирання рядка).

Режими функционорования Telnet -клієнтів і серверів: напівдуплексний; символ за один раз; рядок за один раз.

Протокол SMTP. (Simple Mail Transfer Protocol) - протокол для відправки пошти, як клієнтом на сервер, так і сервером на інший сервер. Порт за умовчанням - 25.

Перший стандарт - RFC 0788 (Simple Mail Transfer Protocol J. Postel Nov - 01-1981). Остання версія - RFC 2821 (Simple Mail Transfer Protocol J. Klensin, Ed. April 2001).

Доповнений розширеннями протокол SMTP часто називають ESMTP (Extended SMTP).

Для початку роботи клієнт просить з'єднання з сервером. Після успішного встановлення з'єднання сервер повідомляє клієнтові своє доменне ім'я, тип і версію встановленого ПЗ. Потім клієнт посилає серверу команди і чекає відповіді, що або підтверджують виконання команд, або повідомляють про неможливість виконання, або містять інформацію, запрошену клієнтом.

Деякі команди SMTP:

- EHLO (Розширене HELO) - якщо ПЗ сервера не підтримує команду EHLO, то видається повідомлення про помилку. В цьому випадку клієнт повинен повторити спробу, використовуючи команду HELO;

- HELO (Вітання) - у відповідь на цю команду сервер повідомляє, чи готовий він до продовження діалогу;

- MAIL (Відправник) - відправка електронного повідомлення неможливе без успішного виконання цієї команди, для кожного листа команда MAIL має бути виконана тільки один раз. На цю адресу лист повинен повернутися у разі неможливості доставки;

- RCPT (Одержувач) - сервер аналізує кожну адресу і після кожної команди RCPT видає повідомлення, що свідчить про можливість / неможливість доставки листа за вказаною адресою;

- DATA (Текст повідомлення) - серверу передається текст повідомлення, що складається із заголовка і відокремленого від нього, порожнім рядком, тіла повідомлення. Передача закінчується рядком, що складається з однієї точки. Цей рядок не є частиною повідомлення і видаляється на приймальній стороні;

- QUIT (Вихід) - командою QUIT клієнт закінчує діалог з сервером. Сервер посилає підтвердження і закриває з'єднання. Отримавши це підтвердження, клієнт теж припиняє зв'язок;

- HELP (Допомога) - якщо команда HELP викликається без параметрів, сервер посилає клієнтові список доступних команд. Якщо в якості параметра передана назва команди, то клієнтові посилається опис цієї команди;

- QUIT - Закриття сеансу зв'язку

Зв'язок з SMTP-сервером представлений у ПП. 5 на CD.