Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
А4_Методичка.doc
Скачиваний:
0
Добавлен:
01.04.2025
Размер:
4 Мб
Скачать
☆

2.5.3 Служба www та протокол http

Історична довідка. У 1989 р. Тім Бернерс-Ли запропонував глобальну гіпертекстову систему, що дозволила спочатку сполучати зв'язками текст, а надалі - графіку, звуки, відео. Глобальність цієї системи припускала, що дані розподілятимуться по всьому світу, а її основою стане Інтернет. Ця система дістала назву World Wide Web (WWW або W3). З 1990 р. також був запропонований гіпертекстовий протокол передачі даних (HTTP), Міжнародною організацією стандартів ISO був розроблений і встановлений стандарт HTML, була створена універсальна система адрес (URL) для адресації документів в WWW. З'явився перший браузер.

Вирішальне значення для всесвітнього поширення WWW мало те, що усі ці стандарти були зроблені загальнодоступними. На початок 2000 р. був розроблений стандарт HTML 4.01. [6]

Гіпертекстове середовище WWW і засоби мультимедіа разом утворюють систему гіпермедіа.

Служба WWW (World Wide Web або просто Web) - це мережа інформаційних ресурсів.

Служба WWW - є множною незалежних, але взаємозв'язаних серверів і призначена для обміну текстовою, графічною, аудіо і відео інформацією. Працюючи з Web, користувач послідовно з'єднується з Web -серверами і отримує інформацію. WWW побудована за схемою "клієнт-сервер".

Клієнтом виступає браузер, який являється також і інтерпретатором HTML. Як інтерпретатор, браузер залежно від команд / тегів виконує різні функції: розміщення тексту на екрані, обмін інформацією з сервером у міру аналізу отриманого HTML-текста та ін.

Сервер HTTP обробляє запити клієнта на отримання файлів, виконання програм та ін.

Рис. 2.24 Взаємодія клієнта і сервера по протоколу HTTP

Для роботи з ресурсами Web використовуються наступні механізми: HTML (HyperText Markup Language) - мова гіпертекстової розмітки документів; URL (Universal Resource Locator - уніфікований покажчик ресурсів) - спосіб адресації ресурсів в мережі, кожен з яких має унікальний для Web адрес, який називається уніфікованим / універсальним ідентифікатором ресурсу (URI - Universal Resource Identifier); HTTP (HyperText Transfer Protocol) - протокол обміну гіпертекстовою інформацією; CGI (Common Gateway Interface) - універсальний інтерфейс шлюзів для взаємодії HTTP -сервера з іншими програмами, встановленими на сервері (наприклад, СУБД.

Приклади стандартів: RFC 1866 "Hypertext Markup Language – HTML 2.0"; REC-html4-971218 "Hypertext Markup Language – HTML 4.0"; RFC 1945 "Hypertext Transfer Protocol – HTTP/1.0"; RFC2616 "Hypertext Transfer Protocol – HTTP/1.1"; ISO 8879 "Standard Generalized Markup Language – SGML

Протокол HTTP (Hypertext Transfer Protocol) - протокол передачі гіпертексту. Використовується службою WWW для передачі Web -сторінок. Перший документ - RFC 1945 (Hypertext Transfer Protocol - HTTP/1.0 T. Berners - Lee, R. Fielding, H. Frystyk May 1996). Остання версія - RFC 2616 (Hypertext Transfer Protocol - HTTP/1.1 R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners - Lee June 1999).

Tранспортним протоколом для HTTP є протокол TCP, причому сервер HTTP (сервер Web) знаходиться в стані очікування з'єднання з боку клієнта стандартно по порту 80 TCP, а клієнт HTTP (браузер Web) є ініціатором з'єднання.

У найзагальнішому випадку URL виглядає так:

protocol://user:password@host:port/path/file?paremeters#fragment

Окремі поля URL мають наступний сенс: protocol - прикладний протокол, за допомогою якого дістають доступ до ресурсу; user - користувач, від імені якого дістають доступ до ресурсу; password - пароль користувача для аутентифікації при доступі до ресурсу; host - IP -адрес або ім'я сервера, на якому розташований ресурс; port - номер порту, на якому працює сервер, що надає доступ до ресурсу; path - шлях до файлу, що містить ресурс; file - файл, що містить ресурс; paremeters - параметри для обробки ресурсом-програмою; fragment - точка у файлі, починаючи з якої слід відображувати. Приклад HTTP-клієнта представлений у ПП. 6 та ПП. 7 на CD.

Взаємодія між клієнтом і сервером Web здійснюється шляхом обміну повідомленнями. Повідомлення HTTP діляться на запити клієнта серверу і відповіді сервера клієнтові.

Запити і відповіді виглядають так: <початковий рядок>, <заголовок 1 >, <заголовок 2 >,…, <заголовок N >, <CR LF (порожній рядок)>, <тіло повідомлення (може бути відсутнім)>.

Формат початкового рядка (start - line) клієнта і сервера розрізняються. Заголовки бувають чотирьох видів: загальні (general - headers), які можуть бути присутніми як в запиті, так і відповідає; запитів (request - headers), які можуть бути присутніми тільки в запиті; відповідей (response - headers), які можуть бути присутніми тільки відповідає; об'єкту (entity - headers), які відносяться до тіла повідомлення і описують його вміст.

Кожен заголовок складається з назви, символу двокрапки ":" і значення.

У тілі повідомлення міститься інформація, яка передається. Тіло повідомлення є послідовністю октетів / байтів. Тіло повідомлення може бути закодоване, наприклад, для зменшення об'єму інформації, при цьому спосіб кодування вказується в заголовку об'єкту Content - Encoding.

Запит від клієнта до сервера складається з рядка запиту (request - line), заголовків (загальних, запитів, об'єкту) і, можливо, тіла повідомлення.

Рядок запиту : <Команда HTTP> <Ідентифікатор прошеного ресурсу> <Версія HTTP>

Протокол SNMP (Simple Network Management Protocol - протокол простого керування мережами) - це протокол керування мережами зв'язку на основі архітектури TCP/IP.

На основі концепції TMN в 1980-1990 рр. різними органами стандартизації були вироблені ряд протоколів керування мережами передачі даних з різним спектром реалізації функцій TMN. До одного з типів таких протоколів керування відноситься SNMP.

Також ця технологія забезпечує керуванняя і контроль за пристроями і додатками в мережі зв'язку шляхом обміну інформацією, що керує, між агентами, розташованими на мережевих пристроях, і менеджерами, розташованими на станціях керування. SNMP визначає мережу як сукупність мережевих РС, що управляють, і елементів мережі (головні комп'ютери, шлюзи і маршрутизатори, термінальні сервери), які разом забезпечують адміністративні зв'язки між мережевими керуючими станціями і мережевими агентами. Приклад SNMP представлений у ПП. 8 на CD.

Провайдери Інтернет – послуг. Провайдер (постачальник, цілком ISP – Internet Service Provider) – це організація, яка забезпечує іншим організаціям і приватним особам доступ до мережі Internet. Провайдери прокладають і підтримують у справному стані канали передачі інформації, мають спеціальні сервери для забезпечення підключень користувачів, обліку часу підключення, надання додаткових послуг, наприклад, електронної пошти.

Доступ до ресурсів Internet здійснюється за допомогою спеціального ПЗ - www browser або Web browser.

Документи в системі www подаються в спеціальному форматі розмітки різних частин документів, як-то: текст, посилання, графіка, таблиці, інше. Це формат HTML (HyperText Markup Language).

Основою www є технологія роботи з гіпертекстами, які, на відміну від звичайних текстів, містять виділені слова, звертаючись до яких можна отримати додаткову інформацію, тобто це є посиланнями на інші документи. Для цього використовується протокол HTTP.

Системою адресації, що використовується в www і, по суті, є стандартом адресації в Internet, є URL (Uniform Resourse Locator) - уніфікований локатор ресурсів, який містить інформацію про метод доступу, сервер доступу (номер порту), шлях до файлів.

Щоб отримати доступ до Internet, необхідно мати постійний мережевий зв’язок або комутовану лінію, що може надати провайдер - постачальник Internet-послуг ISP (Internet Service Provider). Провайдери - це посередники між Internet та її користувачами.

Отже, треба вирішити, яким типом підключення до Internet користуватись і якого провайдера вибрати. Існує багато комбінацій способів доступу і вибору провайдера. Щоб вибрати одну з них, необхідно сформулювати свої вимоги до Internet. Це: час і частота звертання; швидкість;скільки пристроїв (терміналів) буде підключено;які послуги Internet, якого рівня та в якій кількості використовуватимуться;яким чином використовуватиметься Internet (локально з офісу, регіонально за географічно розподіленими підрозділами компанії, динамічно по всій країні та за її межами); які співробітники компанії користуватимуться Internet; який рівень безпеки захисту інформації потрібний; чи передбачається в майбутньому користуватись іншими послугами Internet.

Від цього залежить вибір технічного і програмного забезпечення, а також провайдера за його можливостями задовольнити ці вимоги та ціною його послуг. До вибору провайдера слід підходити критично. Крім того треба визначити, хто з присутніх на ринку провайдерів може задовольнити ваші вимоги; вибрати тих, хто географічно найближчий; який провайдер потрібний: локальний, регіональний чи глобальний; тих, у кого рівень технічного забезпечення не нижчий за ваш; тих, хто має достатній досвід роботи з клієнтами з аналогічними потребами, а також з’ясувати: чи пропонує провайдер послуги з навчання та консультування клієнтів; чи здійснює провайдер технічне обслуговування клієнтів.

Порівняти ціни на послуги тих провайдерів, що залишилися у вашому списку, їх системи пільг, знижок і надбавок;

Поцікавитися, послугами яких провайдерів користуються ваші знайомі.

Бажано, щоб провайдер мав достатню кількість каналів доступу, щоб забезпечити безперебійний зв’язок.

При укладенні контракту з вибраним провайдером необхідно: чітко визначити, за що ви маєте платити додатково і що провайдер зобов’язаний виконувати за контрактом; не давати йому забути, що в нього є конкуренти; не укладати довгостроковий контракт за обіцянку знизити ціни, якщо це новий для вас провайдер; не включати до контракту пункт, що знімає відповідальність провайдера за ефективність підключення; включити пункт про гарантований максимальний термін обробки і передавання інформації; не включати пункт обов’язкового співробітництва тільки з одним провайдером; включити пункт, що забороняє провайдеру посягати на вашу інтелектуальну власність, використовувати або розголошувати її.

Усе більшої популярності у нових малих підприємств набувають послуги віртуальних сервісних центрів і офісів. Так звані бізнесові інкубатори збирають під одним дахом декілька малих підприємств, забезпечуючи їх спільною офісною площею, офісним обладнанням, бухгалтерією, консультаційною та юридичною допомогою, поки вони стануть спроможними до самостійного бізнесу. На відміну від них віртуальні центри та офіси надають такі послуги: користування телефонним номером; цілодобове приймання телефонних дзвінків; привітання від імені клієнта; передавання інформації про всі дзвінки на пейджер; збереження архіву повідомлень за період, указаний клієнтом; надання адреси електронної пошти; дублювання повідомлень електронною поштою; пересилання електронною поштою архіву за період, указаний клієнтом; надання різної інформації на бажання клієнта.